-   Linux - Hardware (
-   -   Nvidia drivers updating libGL conflict (

alexcpp 03-31-2006 05:21 PM

Nvidia drivers updating libGL conflict
I am having a bad problem which I don't know how to fix. I am running Suse 10 (32 bit version) on AMD 64. As you already know, I have Nvidia graphics card. One of the first things I did when I installed Suse 10 was to install Nvidia driver. Everything seemed to work fine. Then after some time I decided to learn some C++ 3d programming. So I read lots of tutorials and tried different code samples. For most of the code samples I had to install libraries like glut or mesa (or whatever). Not all worked but I got some result. Then after some more time I discovered problems with my 3d acceleration when I tried to run Enemy Territory. I thought I could have screwed up something, so, I tried to update the nvidia drivers. Here is what I got at the end of the installation process:


The runtime configuration check failed for the library '' (expected: '/usr/lib/', found: '/usr/local/lib/'). The most likely reason for this is that conflicting OpenGL libraries are installed in a location not inspected by 'nvidia-installer'. Please be sure you have uninstalled any third-party OpenGL and/or third-party graphics driver packages.
How would I go about uninstalling these packages? I did not use package managers to install them. I compiled them (and used make install). I don't even remember how many of these packages I installed.

Thanks a lot for your help

kaz2100 04-04-2006 10:48 AM

Usually, go back to the directory where you installed things, make uninstall takes care of "uninstall"ing. But not dependency and other problems.

All times are GMT -5. The time now is 01:58 PM.