LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 12-31-2003, 07:26 PM   #1
Pathian
Member
 
Registered: Sep 2003
Location: Dayton, Ohio and Hoffman Estates, IL
Distribution: Slackware 9.1 (laptop) Mandrake 9.2 (desktop)
Posts: 58

Rep: Reputation: 15
Nvidia Driver problem


I downloaded the current driver file from nvidia.com switched to runlevel 3 and ran the install script, came back to runlevel 5 and edited my XF86Config-4 file by changing driver "nv" to driver "nvidia" as per the readme file for the driver. I had a 32 meg GeForce2 DDR in this box and I cannot run Tux Racer, Armagetron, or Chromium correctly. Tux racer was the only one I tried before I tried updating the driver and it ran at about 1 or 2 fps, which is why I tried updating the driver. Now when I run any of those 3 programs I get similar errors.
Tuxracer at the console gives me
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
*** tuxracer error: Couldn't initialize video: Couldn't find matching GLX visual (Success)
Chromium gives
WARNING: could not read config file (/home/magician/.chromium)
WARNING: could not read score file (/home/magician/.chromium-score)
randomizing.
SDL initialized.
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Couldn't set GL mode: Couldn't find matching GLX visual
and Armagetron gives me
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Couldn't set video mode: Couldn't find matching GLX visual
(repeated many times, then)
Error in bool sr_InitDisplay() in rScreen.cpp:541 :

I could also post the contents of my XF86Config or XF86Config-4 as well if that would help in solving the problem, thanks a lot!
 
Old 12-31-2003, 08:57 PM   #2
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 48
In your XF86Config-4 file right under where you changed the nv to nvidia.....add this line
Option "IgnoreEDID" "1"
 
Old 12-31-2003, 08:59 PM   #3
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 79
See if you can find this little part. It is usually up toward the top.

Code:
# This loads the GLX module
    Load       "glx"
It may look like this right now.

Code:
# This loads the GLX module
#    Load       "glx"
Take out the # and try that. You may need to reboot or at least restart the GUI anyway.

Later

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
nVidia driver problem ? puishor Linux - Hardware 1 09-01-2005 12:38 PM
nvidia driver problem OstaX Linux - Hardware 5 11-26-2004 06:34 AM
nvidia fx5600 loads vesa driver instead of nvidia driver saburo62 Linux - Hardware 3 05-04-2004 03:59 PM
Problem with nvidia driver Mahony Linux - General 1 04-16-2004 06:11 AM
NVIDIA driver problem BraxKung Linux - Newbie 21 04-15-2003 05:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration