-   Linux - Hardware (
-   -   Nvidia driver not working properlly when resuming S3 suspend. (

redarrow 01-14-2007 01:47 PM

Nvidia driver not working properlly when resuming S3 suspend.

I just installed Fedora Core 6 on my system and the latest Nvidia driver (1.0-9631)..

Before installing the Nvidia driver, the S3 suspend function worked perfectly... after in stalling the driver it no longer resumes correctly.. the screen remains blank and nothing I do will wake it.. I tried switching to a terminal with Ctrl+Alt+F5.. nothing just blank..
The only thing I can do is reboot the machine..

Anyone have any ideas how I could work around this problem?


poweredbydodge 01-14-2007 03:03 PM

hey there - ran into similar junk when setting up my HTPC. Eventually I went back to FC5 for many reasons, but the short answer to what I believe you need is:

-- the beta driver 9742. is what i have it named as.

You should be able to google it.

This driver worked for me, without a hitch, getting rid of the 'random blank screen' that I experienced with the previous driver(s).

redarrow 01-15-2007 09:08 AM

Thanks for the reply poweredbydodge!

Unfortunately the latest set of drivers no longer seem to support my outdated Geforce 4 MX440..

But I found a solution on the Nvidia forums..

Basically I just had to:

Boot the kernel with agp=off

and edit /etc/pm/functions-nvidia, just commenting out "/usr/sbin/vbetool post" in resume_video() like:


        ### /usr/sbin/vbetool post
        /usr/sbin/vbetool dpms on
        /usr/sbin/vbetool vbestate restore < /var/run/vbestate
) >/dev/null 2>&1

It's working now! :D

All times are GMT -5. The time now is 01:00 AM.