-   Linux - Hardware (
-   -   Nvidia Direct Rendering (

danile3784 07-30-2003 09:54 AM

Nvidia Direct Rendering
I have al little Problem with my Nvidia GLX Acceleration Drivers: They are istalled and seam to work, but glxinfo says:

name of display: :0.0
display: :0 screen: 0
-------> direct rendering: No <----------
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3

Why is direct rendering switched "No"??? What can i do to get it switched "Yes"??? Please help me! Thanx

finegan 07-30-2003 04:59 PM

Is DRI enabled in you /etc/X11/XF86Config file and is the mode set? It should look like:


Section "DRI"
        Mode 0666



LavaDevil94 07-31-2003 10:27 PM

you can have DRI in nvidia? i thought you could only have it in all cards except nvidia. i think i saw somewhere that you shouldnt use DRI w/ nvidia, but i dunno.

danile3784 08-08-2003 02:25 AM

DRI is enabled in my /etc/X11/XF86Config and the mode is correct too.
hmmm no DRI for Nvidia?? I dont know. I use winex-gui and every time i run it it says hey DRI is no enabled so some games wont work.

PsychosisNode 08-08-2003 04:37 AM

Reading the instructions (the beeeg PDF manual) about the linux drivers from NVidia, in the section about editing yer XF86config file, iy says to change the "driver" entry to

Driver "nvidia"

in the "Device" section and to remove the lines

Load "DRI"
Load "GLcore"

from the "Modules" section if they exist. This is all I've heard about no DRI with NVidia.


mISOk 11-04-2003 08:17 PM

If you have SuSE 9.0 you can activate 3D by SaX2!

All times are GMT -5. The time now is 04:34 AM.