-   Linux - Hardware (
-   -   nvidia 6106, kernel 2.6.7, slackware 10, failure to load nvidia.ko (

Tarball_Phreak 07-21-2004 11:33 AM

nvidia 6106, kernel 2.6.7, slackware 10, failure to load nvidia.ko
I installed slackware 10 on a new computer and proceeded to upgrade to kernel 2.6.7. I originally compiled riva support into the kernel, and when i tried to install the latest nvidia driver set (6106) it would not complete because of this. I recompiled and removed riva support. Now when I try to install the nvidia drivers, it finishes compiling the module and then it says it can't load nvidia.ko and asks me to point it to my kernel source. I tried again and pointed it to /usr/src/linux-2.6.7/ which is where my source is. It still fails. Can anyone help?

mrvikki 07-21-2004 12:28 PM

This may not be terribly helpful if you've already tried it...
but rather than making it point to /usr/src/linux-2.6.7
change the symbolic link "linux" in your /usr/src to point to /usr/src/linux-2.6.7
and then compiling without specifying a directory. I remember a few versions
back having trouble because the nvidia program was having issues with pointing
to a user supplied directory and just wanted to look in /usr/src/linux
Maybe it's doing that and still looking in the /usr/src/linux-2.4.26 kernel that came
with slack10

Other than that I dunno sorry.

steved123 07-21-2004 04:12 PM

Nvidia and Slack 10 kernel 2.6.7
I've run into the same problem. The Nvidia driver works, although it complains during installation, with 2.4.26 but I can't get it to install with 2.6.7. I installed the 2.6.7 packages but have to change the xfree.conf from "nvida" to "vesa" to run GUI.

rbirmann 08-04-2004 03:16 PM

I run into this problem too... try running the installer with parameters --kernel-name=2.6.7 and --kernel-source-path=[KERNEL SOURCE PATH]

[KERNEL SOURCE PATH] should be something like /usr/src/linux-2.6.7

these optiions should be used to compile the driver for a different kernel (other than the currently running kernel), but it was the only way I could do it. Everything ok after reboot!!

also look at the readme file at: /usr/share/doc/NVIDIA_GLX-1.0/README for needed changes in the XF86Config file

All times are GMT -5. The time now is 01:16 AM.