LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 11-19-2007, 12:41 PM   #1
guillermo
LQ Newbie
 
Registered: Aug 2007
Location: Argentina
Posts: 25

Rep: Reputation: 15
Thumbs down NTP sync problem


Hello!

Im having troubles setting a local ntp, i mean, i want to sync all my server from one principal via ntp, everything works fine executing in the client:

[root@ntpclient root]# ntpdate -u ipntphost
19 Nov 17:09:39 ntpdate[24306]: step time server iphost offset 6820.727447 sec

The date is ok but the time is wrong is past 2 hours, here are 15:11

date stdout in the ntp server is ok

How can i fix this ?

Regards!
 
Old 11-19-2007, 03:00 PM   #2
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 7,831
Blog Entries: 15

Rep: Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668
Time in UNIX/Linux is stored in UTC (a/k/a GMT or Zulu).

What you SEE however, is defined based on your timezone information.

The default time zone information on Linux is found /etc/localtime. If you do "zdump /etc/localtime" you'll see what time it the timezone has based on your system clock. It should also show what timezone it is reflecting (e.g. EST for U.S. Eastern Standard time or BST for Brittish Summer Time.)

Also the /etc/localtime can be overriden with the variable TZ set. Type "echo $TZ" to see if this is set. That is to say if your /etc/localtime is using EST but TZ is set to BST the time you see when you type "date" is going to be for BST rather than for EST.

All the different timezone files are stored in /usr/share/zoneinfo or its subdirectories. Your /etc/localtime should be a copy of one of those or a link to one of those. For example my /etc/localtime is a copy of /usr/share/zoneinfo/Americas/New_York because New York is in the U.S. Eastern Time Zone like I am.

Also make sure your BIOS does NOT have "use UTC" enabled - the hardware clock is written to from the system clock at shutdown. The system clock in turn reads from the system clock and I've seen this cause problem especially on dual boot systems that have Windows as one of the OSes.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NTP sync up time sidra Linux - Networking 1 09-27-2007 09:07 PM
NTP sync problem. makkays Linux - Networking 4 05-02-2007 04:20 PM
NTP Sync? carlosinfl Linux - Networking 12 04-13-2006 10:33 AM
ntp time sync eyewittness Linux - Networking 2 08-11-2004 09:18 AM
NTP sync problems rbutler Linux - Newbie 0 01-17-2003 01:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration