LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 11-17-2017, 12:31 PM   #16
batman23
Member
 
Registered: Mar 2004
Posts: 67

Rep: Reputation: 8

Quote:
Originally Posted by Rodrigo7 View Post
Reading around the Grub manual, I saw this:

>>GRUB looks for its configuration file as soon as it is loaded. If one is found, then the full menu interface is activated using whatever entries were found in the file. If you choose the command-line menu option, or if the configuration file was not found, then GRUB drops to the command-line interface. <<

So I'm thinking that there may just not be a configuration file present, since I'm not getting an option to choose between command-line or menu interface, it's taking me directly to the CL.
hmmm

you don't get anything to choose from initially?

what does "ls" return

This is directly from grub manual.

-- Command: ls [arg ...]
List devices or files.

With no arguments, print all devices known to GRUB.

Last edited by batman23; 11-17-2017 at 12:32 PM.
 
Old 11-17-2017, 01:03 PM   #17
Rodrigo7
Member
 
Registered: Aug 2011
Distribution: Kubuntu
Posts: 42

Original Poster
Rep: Reputation: Disabled
Thanks, here's the output from ls:

(hd0) (hd0,gpt3) (hd0,gpt2) (hd0,gpt1) (cd0) error: failure reading sector 0x0 from `cd0'.

ADDED: I forgot to answer your question. Nope, there's nothing to choose from initially.

Last edited by Rodrigo7; 11-17-2017 at 01:04 PM. Reason: new line added
 
Old 11-17-2017, 01:38 PM   #18
batman23
Member
 
Registered: Mar 2004
Posts: 67

Rep: Reputation: 8
set command

Quote:
Originally Posted by Rodrigo7 View Post
Thanks, here's the output from ls:

(hd0) (hd0,gpt3) (hd0,gpt2) (hd0,gpt1) (cd0) error: failure reading sector 0x0 from `cd0'.

ADDED: I forgot to answer your question. Nope, there's nothing to choose from initially.
Please type "set" and post the result of that command.

Command: set [envvar=value]

Set the environment variable ENVVAR to VALUE. If invoked with no
arguments, print all environment variables with their values.
 
1 members found this post helpful.
Old 11-17-2017, 04:33 PM   #19
TheEzekielProject
Member
 
Registered: Dec 2016
Distribution: Devuan
Posts: 476

Rep: Reputation: 115Reputation: 115
You should normally be able to bring up the Grub menu by holding shift when booting the computer. If that works, try selecting Advanced and selecting the kernel with "(Recovery)" at the end and see if that boots with picture.
Sometimes there are issues with Nvidia drivers that cause a problem like your describing. Booting with Recovery option should make it boot with nouveau drivers instead
 
Old 11-17-2017, 06:32 PM   #20
Rodrigo7
Member
 
Registered: Aug 2011
Distribution: Kubuntu
Posts: 42

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by batman23 View Post
Please type "set" and post the result of that command.

Command: set [envvar=value]

Set the environment variable ENVVAR to VALUE. If invoked with no
arguments, print all environment variables with their values.
It was rather laborious as the PC where I'm typing this is on the same monitor and I had to keep switching the display source. But here goes. After entering
Code:
set envvar=value
and hitting Enter, next I typed "set" followed by Enter again and got the following:

Code:
grub> set
?=0
cmdpath=(hd0,gpt1)/EFI/ubuntu
color_highlight=black/light-gray
color_normal=light-gray/black
envvar=value
feature_200_final=y
feature_all_video_module=y
feature_chainloader_bpb=y
feature_default_font_path=y
feature_menuentry_id=y
feature_menuentry_options=y
feature_nativedisk_cmd=y
feature_ntldr=y
feature_platform_search_hint=y
feature_timeout_style=y
grub_cpu=x86_64
grub_platform=efi
lang=
locale_dir=
net_default_ip=(null)
net_default_mac=(null)
net_default_server=
pager=
prefix=(hd0,gpt2)/boot/grub
pxe_default_server=
root=hd0,gpt2
secondary_locale_dir=
grub>
 
Old 11-17-2017, 06:35 PM   #21
batman23
Member
 
Registered: Mar 2004
Posts: 67

Rep: Reputation: 8
Quote:
Originally Posted by Rodrigo7 View Post
It was rather laborious as the PC where I'm typing this is on the same monitor and I had to keep switching the display source. But here goes. After entering
Code:
set envvar=value
and hitting Enter, next I typed "set" followed by Enter again and got the following:


You do not need to run this.
This is just how to set a variable with the set command.
The main thing was to see what the variables are currently set at.
This is what you posted with typing "set"

Code:
grub> set
?=0
cmdpath=(hd0,gpt1)/EFI/ubuntu
color_highlight=black/light-gray
color_normal=light-gray/black
envvar=value
feature_200_final=y
feature_all_video_module=y
feature_chainloader_bpb=y
feature_default_font_path=y
feature_menuentry_id=y
feature_menuentry_options=y
feature_nativedisk_cmd=y
feature_ntldr=y
feature_platform_search_hint=y
feature_timeout_style=y
grub_cpu=x86_64
grub_platform=efi
lang=
locale_dir=
net_default_ip=(null)
net_default_mac=(null)
net_default_server=
pager=
prefix=(hd0,gpt2)/boot/grub
pxe_default_server=
root=hd0,gpt2
secondary_locale_dir=
grub>


please run this and post

ls /boot/grub

The "grub.cfg" file should be in this path.

Last edited by batman23; 11-17-2017 at 06:36 PM.
 
Old 11-17-2017, 06:37 PM   #22
Rodrigo7
Member
 
Registered: Aug 2011
Distribution: Kubuntu
Posts: 42

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TheEzekielProject View Post
You should normally be able to bring up the Grub menu by holding shift when booting the computer. If that works, try selecting Advanced and selecting the kernel with "(Recovery)" at the end and see if that boots with picture.
Sometimes there are issues with Nvidia drivers that cause a problem like your describing. Booting with Recovery option should make it boot with nouveau drivers instead
When researching how to get into the Grub menu, the Web told me it could be the Shift key, the Space key, or the Escape key. On the first two bootup tries, Shift or Space didn't seem to do anything. But pressing Escape finally took me to the Grub prompt (and nothing else, unfortunately).

Note that I was having the same sort of problem even before installing the GTX 1050, when the computer was relying on the integrated graphics.
 
Old 11-17-2017, 06:41 PM   #23
Rodrigo7
Member
 
Registered: Aug 2011
Distribution: Kubuntu
Posts: 42

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by batman23 View Post
please run this and post

ls /boot/grub

The "grub.cfg" file should be in this path.
Here's what it gave me:

Code:
x86_64-efi/ unicode.pf2 locale/ fonts/ grubenv grub.cfg
 
Old 11-17-2017, 06:44 PM   #24
batman23
Member
 
Registered: Mar 2004
Posts: 67

Rep: Reputation: 8
Quote:
Originally Posted by Rodrigo7 View Post
Here's what it gave me:

Code:
x86_64-efi/ unicode.pf2 locale/ fonts/ grubenv grub.cfg
type

configfile /boot/grub/grub.cfg

what happens?

It should bring up some menu entries.
Please post what it brings up.

If it does bring up menu entries.

press "e"

That should take you to the commands in that menuentry.

Then you can find the command "linux"

Curious to see what happens.
 
1 members found this post helpful.
Old 11-17-2017, 06:51 PM   #25
Rodrigo7
Member
 
Registered: Aug 2011
Distribution: Kubuntu
Posts: 42

Original Poster
Rep: Reputation: Disabled
Huh -- when I typed that in and hit Enter, the screen went dark, then the Kubuntu logo appeared, and then the screen went blank again. This is exactly what happens when I'm trying to boot the normal way into Kubuntu. (I suspect it IS actually booting properly, just not displaying anything. But of course I could be wrong.)
 
Old 11-17-2017, 06:52 PM   #26
batman23
Member
 
Registered: Mar 2004
Posts: 67

Rep: Reputation: 8
Quote:
Originally Posted by Rodrigo7 View Post
Huh -- when I typed that in and hit Enter, the screen went dark, then the Kubuntu logo appeared, and then the screen went blank again. This is exactly what happens when I'm trying to boot the normal way into Kubuntu. (I suspect it IS actually booting properly, just not displaying anything. But of course I could be wrong.)
please type

terminal_output

post the result please
 
Old 11-17-2017, 06:55 PM   #27
TheEzekielProject
Member
 
Registered: Dec 2016
Distribution: Devuan
Posts: 476

Rep: Reputation: 115Reputation: 115
Idk if Kubuntu enables ssh by default or not but you could try ssh just to see if it's booted properly or not
 
Old 11-17-2017, 06:59 PM   #28
Rodrigo7
Member
 
Registered: Aug 2011
Distribution: Kubuntu
Posts: 42

Original Poster
Rep: Reputation: Disabled
Before continuing, I want to add that I just noticed that when the screen goes what I've been calling "black" or "blank," is not totally black as if the monitor were turned off. If I switch the lights off in the room, you can see a slight glow coming off the "black" screen.

Now on to the results of terminal_output:

Quote:
Active output terminals:
gfxterm
Available output terminals:
console spkmodem serial_* serial cbmemc audio
grub>
 
Old 11-17-2017, 07:00 PM   #29
Rodrigo7
Member
 
Registered: Aug 2011
Distribution: Kubuntu
Posts: 42

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TheEzekielProject View Post
Idk if Kubuntu enables ssh by default or not but you could try ssh just to see if it's booted properly or not
Thanks, can I do that from Grub? It's the only spot where I get to see and do anything.
 
Old 11-17-2017, 07:02 PM   #30
batman23
Member
 
Registered: Mar 2004
Posts: 67

Rep: Reputation: 8
Quote:
Originally Posted by Rodrigo7 View Post
Before continuing, I want to add that I just noticed that when the screen goes what I've been calling "black" or "blank," is not totally black as if the monitor were turned off. If I switch the lights off in the room, you can see a slight glow coming off the "black" screen.

Now on to the results of terminal_output:
lets try something else first

set gfxmode=800x600
save_env gfxmode

set timeout=10
save_env timeout

then reboot and tell me if the screen resolution is different

Last edited by batman23; 11-17-2017 at 07:05 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
upgraded to kubuntu 11.4: screen flickers after full-screen openGL sonicboy Ubuntu 7 05-03-2011 10:31 PM
Try to install Kubuntu but can't get past welcome screen mb722004 Linux - Newbie 5 12-09-2007 01:30 AM
cant see the splash screen (kubuntu) eduac Linux - Hardware 5 04-15-2007 01:59 AM
How to tell the screen resolution? (kUbuntu) LDJ Linux - Newbie 2 01-25-2007 05:02 PM
Kubuntu 5.0.4 Screen Resoloution RagingFuryBlack Ubuntu 1 06-27-2005 06:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 01:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration