LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
 
Search this Thread
Old 03-26-2006, 07:14 AM   #1
schatoor
Senior Member
 
Registered: Jul 2002
Location: a tiny place caled hendrik ido ambacht in the netherlands
Distribution: SuSE, debian, slackware, lfs
Posts: 1,358

Rep: Reputation: 45
not able to record sounds with C-Media Electronics CM8738 sound card


Hi,

I just installed a new sound card: CM8738 by C-Media Electronics. Basic installation was a breeze in Windows and Linux. I'm able to play sounds in both systems.
However recording sounds gave me some more trouble. I got this working under windows, but not properly so under Linux
Under Linux, when I say something in the microphone, I actually hear this in the speaker. But I can not record any of it. Under Windows I can.
Here is what I tried:

Code:
sohail@thabox:/home/sohail/temp$ arecord -f dat -d 0 rec.wav
Recording WAVE 'rec.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Stereo
Aborted by signal Interrupt...
sohail@thabox:/home/sohail/temp$ aplay rec.wav
Playing WAVE 'rec.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Stereo
The second command should have produced the recording on the loudspeakers, but I hear nothing.
Using alsamixer, I see that nothing is muted and every thing is turned up max volume.
Any Ideas guys and girls?
 
Old 03-26-2006, 09:52 AM   #2
schatoor
Senior Member
 
Registered: Jul 2002
Location: a tiny place caled hendrik ido ambacht in the netherlands
Distribution: SuSE, debian, slackware, lfs
Posts: 1,358

Original Poster
Rep: Reputation: 45
Hmmm... recording seems to work with audacity. Just installed it. Wonder what the hell is wrong with arecord and krec. Oh well...
 
Old 03-26-2006, 10:05 AM   #3
burntfuse
Member
 
Registered: Sep 2005
Location: Laurel, MD, USA
Distribution: Slackware 10.1, FC5
Posts: 164

Rep: Reputation: 30
I had the same problem with this soundcard - I tried it out by putting a mic near my guitar amp, but couldn't hear anything played back unless I cranked it up to insane levels while recording and stood outside the room. Unfortunately, it seems that you have to put the mic through a preamp before running it to the microphone input (couldn't get anything through 'Line In'). Maybe the ALSA drivers don't set the recording volume correctly or something?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound with a CM8738 sound card -- alsa installed istar80 Linux - Hardware 1 06-17-2005 02:02 PM
Sound on c-media CM8738 dhbiker Slackware 1 10-20-2004 02:20 PM
Mandrake 10.0 and CM8738 sound card kobica Linux - Hardware 1 07-28-2004 02:57 PM
Xandros delux 2.0 When I try to run Sound server Control ,Media Player & Sound Record Jesta Linux - Distributions 0 05-15-2004 09:35 PM
C-Media (cm8738) sound card & alsa problems BBQ_Matt Linux - Hardware 3 02-05-2004 03:39 AM


All times are GMT -5. The time now is 01:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration