-   Linux - Hardware (
-   -   No USB module loaded (

dev8080 10-01-2003 08:13 PM

No USB module loaded
I have installed RH 9.0 on VAIO laptop. My usb port does not seem to work. Nothing happens when I insert any device into USB port. I tried with digital camera and flash card without any success. When I run /sbin/lsmod it does not show up any usb module. But when I query rpm -qa, it shows usbutils, libusb and libusb-devel.

Please help me setting up usb.

Thanks in advance.

Mirar 10-02-2003 03:05 AM

I have no idea how RH 9.0 is supposed to initialize the usb, but you might check out how you load modules at boot, and put in your usb device modules there...

I load the modules manually, and it works for me. But I have only a printer connected. Someone else here can probably name the modules you need, I forgot the exact names and I'm running 2.6.0, so they are called differently (usbcore, uhci_hcd, usblp - for my printer).

Brian1 10-02-2003 11:59 AM

There are several threads here related to your questions.

But for now list your output of ' lsmod '

Output of ' cat /proc/bus/usb/devices '

Output of ' cat /proc/bus/usb/drivers '

If no usb is is shown you will need to load the proper modules.
Is it 1.0 or 2.0 ports?
If 1.0 then try ' insmod usb-ohci ' or ' insmod usb-uhci '
If 2.0 then ' insmod ehci-hcd '

If one of them loads with no errors then you can add it to your /etc/modules.conf file. Example of my /etc/modules.conf

alias eth0 3c59x
alias eth1 3c59x
alias scsi_hostadapter aic7xxx
alias usb-controller usb-ohci
alias sound-slot-0 emu10k1
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
alias char-major-89 i2c-dev
options w83781d force_w83782d=0,0x2d force_subclients=0,0x2d,0x48,0x49 force_w83627hf=0,0x2c force_subclients=0,0x2c,0x4a,0x4b init=0
alias usb-controller1 ehci-hcd
alias ieee1394-controller ohci1394

Now when you plug in a device like a usb harddrive it does not automatically show up. You must mount it manually.
Example of a mount command ' mount /dev/sda1 /mnt/usb ' Lots of threads of how to do this.

There are several threads related to mounting cameras.

Good luck
" When in doubt RTFM "

dev8080 10-03-2003 09:05 PM

There is no usb directory in /proc/bus/

and the output of lsmod is as follows...
I do not understand what does loading module means. is it same as intalling rpm packages?

Module Size Used by Not tainted
ide-cd 35708 0 (autoclean)
cdrom 33728 0 (autoclean) [ide-cd]
nm256_audio 72284 3 (autoclean)
sound 74228 3 (autoclean) [nm256_audio]
ac97 5088 0 (autoclean) [nm256_audio]
soundcore 6404 5 (autoclean) [sound]
mousedev 5492 1 (autoclean)
input 5856 0 (autoclean) [mousedev]
parport_pc 19076 1 (autoclean)
lp 8996 0 (autoclean)
parport 37056 1 (autoclean) [parport_pc lp]
orinoco_cs 5864 1
orinoco 36024 0 [orinoco_cs]
autofs 13268 0 (autoclean) (unused)
hermes 8196 0 [orinoco_cs orinoco]
ds 8680 2 [orinoco_cs]
yenta_socket 13472 2
pcmcia_core 57216 0 [orinoco_cs ds yenta_socket]
ipt_REJECT 3928 6 (autoclean)
iptable_filter 2412 1 (autoclean)
ip_tables 15096 2 [ipt_REJECT iptable_filter]
ext3 70784 2
jbd 51892 2 [ext3]

michaelk 10-03-2003 11:35 PM

Modules aka drivers unlike windows can be loaded or unloaded at will. I don't see any USB modules being loaded on your system.

Try the following commands:
modprobe usbcore
modprobe usb-uhci
modprove usb-storage

I suspect that RH might not be able to detect the USB controller.
What does the following command show

dev8080 10-04-2003 01:13 AM

usb controller shows up in lspci. following is the output
and no output for modprobe usbcore and the other two.

output of lspci...
00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (AGP disabled) (rev 03)
00:07.0 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:08.0 VGA compatible controller: Neomagic Corporation NM2200 [MagicGraph 256AV] (rev 20)
00:08.1 Multimedia audio controller: Neomagic Corporation NM2200 [MagicMedia 256AV Audio] (rev 20)
00:09.0 FireWire (IEEE 1394): Sony Corporation CXD1947Q i.LINK Controller (rev 01)
00:0a.0 CardBus bridge: Ricoh Co Ltd RL5c478 (rev 80)
00:0a.1 CardBus bridge: Ricoh Co Ltd RL5c478 (rev 80)
00:0b.0 Communication controller: Rockwell International HCF 56k Data/Fax Modem (rev 01)

michaelk 10-04-2003 06:43 AM

Check again with lsmod. Maybe there loaded.
Also check the output of dmesg. Look for anything USB related.

dev8080 10-04-2003 12:54 PM

Nothing showing up in lsmod and no 'usb' term in dmesg :( The output of dmesg is quite lengthy to be posted but there is no usb related entry in it.

michaelk 10-04-2003 01:00 PM

The guide suggests turning off plug and pray in the BIOS

Brian1 10-04-2003 01:06 PM

The lspci output show the hardware you have on your machine. It does not mean it is active.

According to your lsmod it shows no USB Modules loaded. You need to load the proper modules to use USB. The contents of /proc is nothing but a virtual filesystem that will only show info when there is a module or driver to go off of. Once you load a USB module it should have something in /proc/bus/usb.

Goto to my website I have working on. The USB part is not complete but I believe there is enough info there to get you going. I have a few more things to check out before I finish it up. Please check back in a few weeks.

dev8080 10-04-2003 04:13 PM

I disabled the plug and play operating system support in the bios and guess what, It detected usb-controller as new hardware and did some configuration during boot-up. But lsmod still doesn't show any usb modules. How do I load modules? When I tried insmod usb-uhci it gave error...

Using /lib/modules/2.4.20-8/kernel/drivers/usb/usb-uhci.o
/lib/modules/2.4.20-8/kernel/drivers/usb/usb-uhci.o: unresolved symbol usb_check_bandwidth_Rcff29776
/lib/modules/2.4.20-8/kernel/drivers/usb/usb-uhci.o: unresolved symbol usb_deregister_bus_R371417bf
/lib/modules/2.4.20-8/kernel/drivers/usb/usb-uhci.o: unresolved symbol usb_free_bus_Rdbad5778
/lib/modules/2.4.20-8/kernel/drivers/usb/usb-uhci.o: unresolved symbol usb_claim_bandwidth_Ra455fae7
/lib/modules/2.4.20-8/kernel/drivers/usb/usb-uhci.o: unresolved symbol usb_alloc_bus_R9f4a89b8
/lib/modules/2.4.20-8/kernel/drivers/usb/usb-uhci.o: unresolved symbol usb_register_bus_R76c1b63d
/lib/modules/2.4.20-8/kernel/drivers/usb/usb-uhci.o: unresolved symbol usb_root_hub_string_Ra68718f0
/lib/modules/2.4.20-8/kernel/drivers/usb/usb-uhci.o: unresolved symbol usb_alloc_dev_Re7e8dc6f
/lib/modules/2.4.20-8/kernel/drivers/usb/usb-uhci.o: unresolved symbol usb_inc_dev_use_R20d5ffd5
/lib/modules/2.4.20-8/kernel/drivers/usb/usb-uhci.o: unresolved symbol usb_free_dev_Rcafa84f6
/lib/modules/2.4.20-8/kernel/drivers/usb/usb-uhci.o: unresolved symbol usb_disconnect_Re559ca2a
/lib/modules/2.4.20-8/kernel/drivers/usb/usb-uhci.o: unresolved symbol usb_release_bandwidth_R0e3fa584
/lib/modules/2.4.20-8/kernel/drivers/usb/usb-uhci.o: unresolved symbol usb_connect_R184b0d90
/lib/modules/2.4.20-8/kernel/drivers/usb/usb-uhci.o: unresolved symbol usb_new_device_R12852f22

simillar error was thrown for insmod usb-uhci and ehci-hcd

michaelk 10-04-2003 04:22 PM

Did you try loading this module instead.

Brian1 10-04-2003 06:27 PM

All that is left that I can tell from what I see is try loading the ' usb-ohci ' module like michaelk says. If not then the hardware is just incompatiable with what I know.

Actually looking at:
It says it should use the usb-uhci module.

Also since this is a laptop, Even though it has an intel chipset, it may have been modified so it can fit in a smaller space. This means it is custom made and does not follow what the chipset was intended to fully do.

I have the same problem with my notebook and getting the temperture sensor info. It just is not there even though lm_sensors has drivers for that chipset. The chipset does not contain that piece of info.

Have fun
" When in doubt, RTFM "

dev8080 10-04-2003 07:19 PM

Thanks a lot
yes, I did try loading usb-ohci with a similar kind of error. The USB controller was working fine with windows. Does this mean that my USB controller is incompatible with Linux? If this is so, then linux is far behind. I had completely removed windows so that I can learn Linux. It is strange for me to hear that 2 of my hardwares are incompatible with linux.

I have simillar problem with my internal modem Rockwell International HCF 56k Data/Fax Modem

Still hoping for magic to happen........................................

michaelk 10-04-2003 07:43 PM

Do you have USB 2.0 ports?

If so try

All times are GMT -5. The time now is 08:36 AM.