LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 03-10-2004, 05:25 PM   #1
fedetxf
Member
 
Registered: Nov 2003
Location: Argentina
Distribution: RedHat 9
Posts: 54

Rep: Reputation: 15
No support for ATAPI with cdrdao


Whenever I run K3B it warn me:

"No support for ATAPI with cdrdao
You will not be able to use all your reading devices as copy sources since there is at least one not configured to use SCSI emulation and your system does not support ATAPI with cdrdao.
Solution: The best and recommended solution is to enable ide-scsi (SCSI emulation) for all devices. This way you won't have any problems."

Running cdrecord -scanbus yeilds:
[root@localhost root]# cdrecord -scanbus
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J?rg Schilling
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.7'
scsibus0:
0,0,0 0) 'IOMEGA ' 'ZIPCD1024INT-A ' ' 1.8' Removable CD-ROM
0,1,0 1) *
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *

And K3B declares this about my devices:
/dev/scd0 (0,0,0) Generic SCSI
/dev/hdc ATAPI

The second is the DVD rom drive I guess itś the one the warning is talking about.
How do I enable scsi ide emulation on that device and how do I set up the /dev/cdrom and /dev/cdrom1 to point to these drives?
 
Old 03-11-2004, 06:54 AM   #2
Maxxer
LQ Newbie
 
Registered: Mar 2004
Location: Moggio (it)
Distribution: Debian / RedHat
Posts: 10

Rep: Reputation: 0
have a look here

http://www.linux-1u.net/CDRW/LiloGrub/

perfetcly explained!
 
Old 03-11-2004, 02:43 PM   #3
fedetxf
Member
 
Registered: Nov 2003
Location: Argentina
Distribution: RedHat 9
Posts: 54

Original Poster
Rep: Reputation: 15
So I just pass the regular kernel the parameter hdc=ide-scsi and I'm set?

I want to know if I should still access the drives as /dev/cdrom and /dev/cdrom1 or use the other devices?

Thanks for your help.
 
Old 03-11-2004, 02:56 PM   #4
Maxxer
LQ Newbie
 
Registered: Mar 2004
Location: Moggio (it)
Distribution: Debian / RedHat
Posts: 10

Rep: Reputation: 0
Quote:
Originally posted by fedetxf
So I just pass the regular kernel the parameter hdc=ide-scsi and I'm set?
Yep!
When doing "cdrecord -scanbus" you should see one more device
Quote:
I want to know if I should still access the drives as /dev/cdrom and /dev/cdrom1 or use the other devices?
No changes, you will still have /dev/cdrom and so on!

ciao
maxxer

Last edited by Maxxer; 03-11-2004 at 02:58 PM.
 
Old 03-11-2004, 05:46 PM   #5
fedetxf
Member
 
Registered: Nov 2003
Location: Argentina
Distribution: RedHat 9
Posts: 54

Original Poster
Rep: Reputation: 15
I still have some issues...
I edited /boot/grub/menu.lst
default=1
timeout=10
splashimage=(hd0,5)/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-8)
root (hd0,5)
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ hdb=ide-scsi hdc=ide-scsi
initrd /initrd-2.4.20-8.img
title Windows 98
rootnoverify (hd0,0)
chainloader +1

and I now get this output for cdrecord -scanbus
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J?rg Schilling
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.7'
scsibus0:
0,0,0 0) 'IOMEGA ' 'ZIPCD1024INT-A ' ' 1.8' Removable CD-ROM
0,1,0 1) 'E-IDE ' 'DVD-ROM DVD-8210' '221I' Removable CD-ROM
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *

but when I try to copy a CD I get this:

System
-----------------------
K3b Version: 0.10.1
KDE Version: 3.1-10 Red Hat
QT Version: 3.1.1

cdrdao
-----------------------
Cdrdao version 1.1.7 - (C) Andreas Mueller <andreas@daneb.de>
SCSI interface library - (C) Joerg Schilling
Paranoia DAE library - (C) Monty
Check http://cdrdao.sourceforge.net/drives.html#dt for current driver tables.
ERROR: Cannot open SCSI device '0,1,0': Cannot open '/dev/sg1'
ERROR: Please use option '--device bus,id,lun', e.g. --device 0,6,0
ERROR: Cannot setup device 0,1,0.

cdrdao comand:
-----------------------
/usr/bin/cdrdao read-cd --device 0,1,0 --driver generic-mmc --paranoia-mode 3 -n -v 2 --eject --remote 16 --datafile /tmp/kde-fede/k3b_0.img /tmp/kde-fede/k3b_0.toc


Running k3bsetup gives this output and nothing else.

[root@localhost root]# kcmshell k3bsetup2
QMutex::unlock: unlock from different thread than locker
was locked by 0, unlock attempt from 1092322304

Any ideas what can be wrong?

Last edited by fedetxf; 03-11-2004 at 05:49 PM.
 
Old 03-11-2004, 07:08 PM   #6
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
pick up the latest versions of cdrdao and k3b; the newest cdrdao works perfectly with ATAPI devices, and k3b will use it correctly (but may show errors)

there should be some rpm's available, but if not, just compile from source (i had problems with my compilation so i had to use a package)

it seems strange, however, that k3b says that you need an scsi device for reading; you should not have to

if the dvd drive is simply for reading, you don't need the ide-scsi option; if you still use the older cdrdao, only that drive needs ide-scsi emulation
 
Old 03-12-2004, 12:28 PM   #7
fedetxf
Member
 
Registered: Nov 2003
Location: Argentina
Distribution: RedHat 9
Posts: 54

Original Poster
Rep: Reputation: 15
I got md5 error when I downloded the 1.1.8 rpm from sourceforge. I used 3 mirrors and allways get the same error.

Anyway, is it possible to just use cdrecord to burn and not cdrdao? I'll download the newer k3b later and try again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cdrdao doesn't work thewilli Linux - Software 2 11-28-2004 01:21 PM
another ATAPI with cdrdao question DB9 Linux - Hardware 6 04-07-2004 02:19 PM
K3B - No support for ATAPI with cdrdao perry Linux - Hardware 2 11-14-2003 10:55 AM
cdrdao vexer Linux - Software 1 05-14-2003 11:49 PM
cdrdao twk Linux - Software 2 05-19-2002 05:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration