-   Linux - Hardware (
-   -   No sound with SiS7012 onboard sound. (

amos 12-06-2002 05:24 AM

No sound with SiS7012 onboard sound.
I recently installed Mandrake 9.0 on a new laptop and everything works fine except for the sound and the modem. I was expecting the modem to be a problem but the onboard sound (SiS7012) is supposed to be supported. When I log in to KDE I get the following during startup:

Sound Server informational message:

Error while initializing the sound driver:

device: default can't be opened for playback (No such device)

The sound server will continue, using the null output device.

Gnome just gives me an error message when I try to open the mixer.

Running sndconfig gives me the following:

A PCI sound card was found in your system. The details are:

Model: Silicon Integrated Systems [SiS] |SiS7012 PCI Audio Accelerator

After hitting ok it then gives me the message:

The Silicon Integrated Systems [SiS] |SiS7012 PCI Audio Accelerator is currently supported, but yours is currently disabled. You can possibly fix this by setting 'PnP OS' to 'no' in your BIOS.

The only options for OS in the BIOS are WIN98 and ACPI.

When I look at dmesg it contains the following lines near the bottom:

PCI: Enabling device 00:02.7 (0000 -> 0001)
PCI: No IRQ known for interrupt pin C of device 00:02.7. Please try using pci=biosirq.
unable to grab IRQ 0
Intel ICH soundcard not found or device busy

Any suggestions as to what this means and what I need to do would be welcome.



amos 12-06-2002 07:44 AM

I've just been looking at the ALSA website.

Although it says that the 7012 soundchip is supported, it describes the chipset as SiS735 (which is the South-Bridge chip I think, whatever that is).

Would the fact that the chipset on my laptop is the SiS961 make any difference as to whether the onboard sound is detected and setup correctly?



centurion 12-09-2002 09:38 PM

I have been looking into the conflict caused between SIS7012 audio and sis7013modem. drivers for linux.

A laptop, with SIS650 host bridge and SIS961 southbridge. Mandrake 9, celeron 1.7.

I noticed that Al the modules would load nicely at start up, but as soon as I tried to dial out with the modem, the sound stopped working. This situation would remain until I reloaded the sound module. This behavior was evident with both Alsa and OSS/free modules.

I actually suspect the problem lies with the sound AC97 module, not knowing how to deal with another app accessing the same hardware, and the reloading of the sound module causes a ac97 reset returning control to the sound module. I think the best way to solve this is to make the ac97 module control access for both the sound and modem drivers. According to the AC97 ver 2.2 spec, both the modem and 6 channel sound should be able to operate at the same time

Any suggestions about implementing this?

crashmeister 12-10-2002 03:25 AM

I never used alsa with SiS 7012.Tried once but no go.It does work fine for me with OSS and the trident driver.I got a line in my Bios that goes like:
ac97 sound : enabled
On my box it got IRQ 11

BTW - the guy that writes the drivers for sis graphics is working on a driver for the sound to get included in the next version of alsa.His website is

centurion 12-10-2002 05:01 AM

I tried Alsa, OSSfree, and OSScommercial all with the same result. As soon as I dial out with the modem the sound stops. Reloading the sound module gets sound going again.

crashmeister 12-10-2002 06:53 AM

No - idea.First of all I never used the modem.Second of all I compile all drivers in the kernel to avoid this.

amos 12-10-2002 08:00 AM

Centurion, did your sound work straight out of the box or did you have to fiddle with it to get it working?

Since the last post I've recompiled the kernel with APCI support instead of APM after reading a post about someone who got their sound working by doing this (I think it was a Red Hat forum). Although this didn't cure the sound it did mean that the computer would power itself down when I shut it down.

I also finally got the SiS driver to compile, although it still doesn't make the sound work. Followed the instructions in the Readme regarding the alteration to modules.conf but it didn't work.

Then tried it with the verbose method listed on the ALSA website under the SiS7012 section (I'd already tried this with the suggested intel8x0 module) but substituting sis7012 where snd-intel-8x0 (or whatever it said) was.

During bootup it now tells me that its loaded the SiS 7012 module, then it tells me that its loading alsactl to reload the mixer settings.

Unfortunately it still gives me the same error message on logging in to KDE. Running sndconfig still has the same result, and the mixers still don't work.

Trying to open alsamixer gives me the following message:

alsamixer: function snd_ctl_open failed for default: No such device

Looking at dmesg now gives me the following instead of the original message above:

ac97_codec: Primary ac97 codec not present

There's a message further up dmesg almost identical to the original message about the sound chip but referring to device 00.02.6 which is the modem. Apparently Smart-Link have released an updated driver but I haven't tried it yet.

By the way Centurion's description of his(?) laptop is identical to mine although the host bridge is referred to as a SiSM650 on the Clevo website.

Any suggestions as to what I should do next?



jdixon 12-10-2002 11:11 AM

Someone on a Geocrawler message board reported they were able to get their Sis7012 sound working. The URL is:

James Dixon

amos 12-10-2002 02:03 PM

I think that's the message I found in a different forum.

I've downloaded a patch for the 2.4.19 kernel, but I have a few questions.

1. Can I use this patch on the 2.4.19-16mdk kernel or do I need to start with a plain 2.4.19 kernel?

2. Other than the kernel compiling HOWTO, are there any good tutorials on applying patches?

3. When do patches like this get incorporated into the kernel proper?

Anyway, I'll start having a go myself tomorrow, any tips before then would be welcome.

On a related note, recompiling the kernel the other day was my first go, can someone tell me what the purpose of the symlink in the /usr/src directory is for? Does it need to point to the kernel being loaded, or the kernel being compiled, or what?

For anyone else thinking of recompiling a kernel for the first time I found this tutorial extremely useful:

Although you need to make sure that you type bzImage not bzimage which is what I did the first time.



crashmeister 12-10-2002 04:10 PM

If you are recompiling kernels and going to patch them it might be a good idea to download the newest stable and see if what you need is in there already anyway.

amos 12-10-2002 07:32 PM

Problems with that method:

1. I'm on the internet on my girlfriend's laptop (running windows), its a dial up connection so I'm not even going to think about downloading the full kernel sources.

2. Although the patch to take me from 2.4.19 to 2.4.20 is only 4meg she doesn't have either a CDR drive or an ethernet connection to enable me to fetch the files across to my laptop.

3. The next editions of Linux Format and PCPlus which both usually have the kernel sources on their coverdisks don't come out until the end of the month.

So any patching will have to be to the 2.4.19 kernel for now. Another thing that occurred to me before, if and when I get around to compiling 2.4.20, will I be able to reuse the .config file from 2.4.19 as a starting point when I run make menuconfig or make xconfig etc.

Anyway I'm getting off topic.

I'll let you know how I get on tomorrow, and whether this finally cures my sound problems.



centurion 12-10-2002 08:18 PM

My Sound worked straight of with both RH8 and Mandrake 9. The sound and modem (pctel) modules even existed in the kernel together fine. The only problem was no sound once I started to use the modem until I reloaded the sound module.

pc-overkill 12-11-2002 01:40 PM

I found this link when i was looking for another problem with a
ECS K7s5a board.
The sound on that board is 7012 too, maybe there is some hints,
that might be useful in this howto:)

amos 12-12-2002 06:13 AM


It turned out my girlfriend had a USB Zip Drive she virtually never used. After failing to patch the Mandrake 2.4.19-16mdk kernel with the ACPI patch, I got a vanilla 2.4.19 kernel off a Linux Format coverdisk, patched it to turn it into 2.4.20, then applied the ACPI patch for the 2.4.20 kernel, and recompiled with all of the ACPI options apart from CPU Enumeration(?) enabled.
After I booted with the new kernel I had to comment out all references to sound in modules.conf and add the line

alias sound i810_audio

This still gave me the same error message when booting into KDE, but sound was now working, I got rid of the message by opening the Sound Server section in the configuration part of the main menu, and changing the option from ALSA to OSS Free.

Bizarrely when I now run sndconfig it detects the card and tells me that it isn't supported.

The link that pc-overkill left appears to be suggesting that to use the snd-intel8x0 driver both it and the soundcard need to be compiled into the kernel, I might try that if I get bored.

Things to do:

1. Try and get the modem to work.

2. Work out how to replace supermount with something that works.



centurion 12-12-2002 12:56 PM

Awesome, to get the modem working, get the PCTEL modem drivers and install them. There is a link to the pctel modem drivers from let us know if you are successful in getting both the sound and modem working ast the same time..


All times are GMT -5. The time now is 12:49 AM.