LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 01-13-2004, 07:16 AM   #1
hope
LQ Newbie
 
Registered: Jan 2004
Location: Milan - Italy
Distribution: Gentoo Linux
Posts: 9

Rep: Reputation: 0
no sound with ALSA, 2.6.1 kernel, intel8x0 (unmuted)


Hi all,

this is a strange problem:
  • since I've formatted my Gentoo distro, I hear no sound with ALSA build into 2.6.1 kernel, alsa-lib-0.9.8, alsa-utils-0.9.8 and a intel8x0 audio chip. I came back to 2.4.22 (gentoo-sources) + alsa-driver and NOTHING WORKS.
  • some time ago with 2.4.x kernel, alsa-lib, alsa-drivers, alsa-utils -> ALL was WORKING with my intel8x0 audio chip (I followed the Gentoo Alsa Guide)
    (The only thing I changed is the AGP card --> now an ATI Radeon 9200 SE)
Of course I unmuted the card ... and I tried everything I could image ... (different versions of alsa-lib, alsa-drivers ...., kernel options compiled as modules or build into the kernel, different kernel version ....) but nothing.

Some cues :
  • --- from lspci ---

    00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97 Audio (rev 02)
  • --- from "make menuconfig" ---
<*> Sound card support
-- Advanced Linux Sound Architecture --->
<*> Sequencer support
< > Sequencer dummy client[*] OSS API emulation
<*> OSS Mixer API
<*> OSS PCM (digital audio) API[*] OSS Sequencer API
<*> RTC Timer support
[ ] Verbose printk[*] Debug[*] Debug memory[*] Debug detection
Generic devices --->
ISA devices --->
PCI devices --->
<*> Intel i8x0/MX440, SiS 7012; Ali 5455; NForce Audio; AMD768/8111
ALSA USB devices --->
-- Open Sound System --->
  • --- from dmesg ---

    Advanced Linux Sound Architecture Driver Version 1.0.0rc2.
    request_module: failed /sbin/modprobe -- snd-card-0. error = -16
    PCI: Setting latency timer of device 0000:00:1f.5 to 64
    ac97 quirk for Fujitsu-Siemens Scenic (110a:0056)
    intel8x0: clocking to 48000
    joystick(s) found
    drivers/usb/core/usb.c: registered new driver snd-usb-audio
    ALSA device list:
    #0: Intel 82801BA-ICH2 at 0x2000, irq 17
  • --- what about /etc/modules.d/alsa and kernel 2.6.x with ALSA statically build ???? --- and what about /etc/init.d/alsasound ???? ---

    I tried every possible configuration of /etc/modules.d/alsa and I tried to load alsasound as I did with kernel 2.4.x and alsa-driver and I tried to don't load it ... but nothing !
    When I start /etc/init.d/alsasound I get NO ERRORS (if I compiled ALSA as modules alsasound loads them) and amixer and alsamixer WORK perfectly .... just NO SOUND !!!! :-(
  • --- from amixer ---

    Simple mixer control 'Master',0
    Capabilities: pvolume pswitch pswitch-joined
    Playback channels: Front Left - Front Right
    Limits: Playback 0 - 63
    Front Left: Playback 63 [100%] [on]
    Front Right: Playback 63 [100%] [on]
    Simple mixer control 'Master Mono',0
    Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    Playback channels: Mono
    Limits: Playback 0 - 31
    Mono: Playback 31 [100%] [on]
    Simple mixer control '3D Control - Center',0
    Capabilities: volume volume-joined
    Playback channels: Mono
    Limits: 0 - 15
    Mono: 15 [100%]
    Simple mixer control '3D Control - Depth',0
    Capabilities: volume volume-joined
    Playback channels: Mono
    Limits: 0 - 15
    Mono: 15 [100%]
    Simple mixer control '3D Control - Switch',0
    Capabilities: pswitch pswitch-joined
    Playback channels: Mono
    Mono: Playback [on]
    Simple mixer control 'PCM',0
    Capabilities: pvolume pswitch pswitch-joined
    Playback channels: Front Left - Front Right
    Limits: Playback 0 - 31
    Front Left: Playback 31 [100%] [on]
    Front Right: Playback 31 [100%] [on]
    Simple mixer control 'PCM Out Path & Mute',0
    Capabilities:
    Mono:
    Simple mixer control 'Line',0
    Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined cswitch-exclusive
    Capture exclusive group: 0
    Playback channels: Front Left - Front Right
    Capture channels: Front Left - Front Right
    Limits: Playback 0 - 31
    Front Left: Playback 31 [100%] [on] Capture [off]
    Front Right: Playback 31 [100%] [on] Capture [off]
    Simple mixer control 'CD',0
    Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined cswitch-exclusive
    Capture exclusive group: 0
    Playback channels: Front Left - Front Right
    Capture channels: Front Left - Front Right
    Limits: Playback 0 - 31
    Front Left: Playback 31 [100%] [on] Capture [off]
    Front Right: Playback 31 [100%] [on] Capture [off]
    Simple mixer control 'Mic',0
    Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch cswitch-joined cswitch-exclusive
    Capture exclusive group: 0
    Playback channels: Mono
    Capture channels: Front Left - Front Right
    Limits: Playback 0 - 31
    Mono: Playback 31 [100%] [on]
    Front Left: Capture [on]
    Front Right: Capture [on]
    Simple mixer control 'Mic Boost (+20dB)',0
    Capabilities: pswitch pswitch-joined
    Playback channels: Mono
    Mono: Playback [on]
    Simple mixer control 'Mic Select',0
    Capabilities:
    Mono:
    Simple mixer control 'Video',0
    Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined cswitch-exclusive
    Capture exclusive group: 0
    Playback channels: Front Left - Front Right
    Capture channels: Front Left - Front Right
    Limits: Playback 0 - 31
    Front Left: Playback 31 [100%] [on] Capture [off]
    Front Right: Playback 31 [100%] [on] Capture [off]
    Simple mixer control 'Phone',0
    Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch cswitch-joined cswitch-exclusive
    Capture exclusive group: 0
    Playback channels: Mono
    Capture channels: Front Left - Front Right
    Limits: Playback 0 - 31
    Mono: Playback 31 [100%] [on]
    Front Left: Capture [off]
    Front Right: Capture [off]
    Simple mixer control 'PC Speaker',0
    Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    Playback channels: Mono
    Limits: Playback 0 - 15
    Mono: Playback 15 [100%] [on]
    Simple mixer control 'Aux',0
    Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined cswitch-exclusive
    Capture exclusive group: 0
    Playback channels: Front Left - Front Right
    Capture channels: Front Left - Front Right
    Limits: Playback 0 - 31
    Front Left: Playback 31 [100%] [on] Capture [off]
    Front Right: Playback 31 [100%] [on] Capture [off]
    Simple mixer control 'Mono Output Select',0
    Capabilities:
    Mono:
    Simple mixer control 'Capture',0
    Capabilities: cvolume cswitch cswitch-joined
    Capture channels: Front Left - Front Right
    Limits: Capture 0 - 15
    Front Left: Capture 15 [100%] [on]
    Front Right: Capture 15 [100%] [on]
    Simple mixer control 'Mix',0
    Capabilities: cswitch cswitch-joined cswitch-exclusive
    Capture exclusive group: 0
    Capture channels: Front Left - Front Right
    Front Left: Capture [off]
    Front Right: Capture [off]
    Simple mixer control 'Mix Mono',0
    Capabilities: cswitch cswitch-joined cswitch-exclusive
    Capture exclusive group: 0
    Capture channels: Front Left - Front Right
    Front Left: Capture [off]
    Front Right: Capture [off]
    Simple mixer control 'Digital Audio Mode',0
    Capabilities: pswitch pswitch-joined
    Playback channels: Mono
    Mono: Playback [on]
    Simple mixer control 'Digital Mono Direct',0
    Capabilities: pswitch pswitch-joined
    Playback channels: Mono
    Mono: Playback [on]
    Simple mixer control 'External Amplifier Power Down',0
    Capabilities: pswitch pswitch-joined
    Playback channels: Mono
    Mono: Playback [on]
    Simple mixer control 'Low Power Mixer',0
    Capabilities: pswitch pswitch-joined
    Playback channels: Mono
    Mono: Playback [on]
    Simple mixer control 'Zero Fill DAC',0
    Capabilities: pswitch pswitch-joined
    Playback channels: Mono
    Mono: Playback [on]

Please help me ... I can't understand what should I try ....

Last edited by hope; 01-13-2004 at 07:19 AM.
 
Old 01-13-2004, 01:04 PM   #2
rufius
Member
 
Registered: Oct 2002
Location: Miami, FL
Distribution: Ubuntu
Posts: 184

Rep: Reputation: 30
hope, my suggestions to you is to go get the new 1.0.1 alsa libraries and drivers and recompile them, I did that and it worked fine for me on 2.6.
 
Old 01-13-2004, 08:27 PM   #3
BWebb
Member
 
Registered: Jan 2004
Posts: 32

Rep: Reputation: 15
I'm having a similar problem on a 2.4 kernel. I do have all of the 1.0.1 libraries and utilities, all of the volume controls are unmuted, yet still I have no sound.

Further investigation continues tomorrow...

Cheers,

Bret
 
Old 01-14-2004, 06:33 AM   #4
hope
LQ Newbie
 
Registered: Jan 2004
Location: Milan - Italy
Distribution: Gentoo Linux
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by rufius
hope, my suggestions to you is to go get the new 1.0.1 alsa libraries and drivers and recompile them, I did that and it worked fine for me on 2.6.
Thank you rufius for your suggestion.
I previously installed the new 1.0.1 alsa libraries and drivers but with the same problem.

I try to explain better:
  • My system with kernel 2.4.x and alsa-lib and driver version ??? (I don't remember) was perfectly working
  • two weeks ago I changed my hard disk and I reinstalled my distro (ACCEPT_KEYWORDS="~x86") with kernel 2.6.x and alsa lib/drivers 1.0.x and sound was NOT working.
  • I came back to kernel 2.4.x and nothing ... NO SOUND.
  • I formatted my system and reinstalled my gentoo distro only with stable package (ACCEPT_KEYWORDS="x86") and kernel 2.4.x ....
    I came back to alsa 0.98 because I thought it was a problem of the new alsa lib and drivers. But the problem is the same ... NO SOUND !
I thought to a hardware failure but the sound card is working in win2k :-(

Last edited by hope; 01-14-2004 at 06:47 AM.
 
Old 01-18-2004, 07:24 AM   #5
hope
LQ Newbie
 
Registered: Jan 2004
Location: Milan - Italy
Distribution: Gentoo Linux
Posts: 9

Original Poster
Rep: Reputation: 0
  • I just compiled a 2.6.1-r1 gentoo-dev kernel
  • I just emerged alsa-lib-1.0.1
  • alsa-tools-1.0.1
"alsaconf" detect my card ... configure it whithout errors, I unmute the card .... but nothing ! no sound. The only way is to compile oss kernel support but I like ALSA !

please help
 
Old 01-18-2004, 07:38 AM   #6
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
Did you try a lsmod to see if the intel-modules are there, also with the change to the new Alsa you need to use the following to load modprobe snd-intel8x0;modprobe snd-pcm-oss;modprobe snd-mixer-oss;modprobe snd-seq-oss. I found I had to put the modprobe commands in /etc/rc.d/rc.local to have the modules load or they didn't load and no sound, this is for Fedora, I'm not sure where Gentoo puts in the modules you want loaded that aren't loaded automatically.

Also you may want to check /etc/modules.conf or something along those lines, sorry I have never used Gentoo so I'm not sure, for these lines:

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-intel8x0
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss



Also did you try alsamixer to check to make sure that alsa is unmuted?

Not sure if this will help you, just some ideas.

Last edited by JayCnrs; 01-18-2004 at 07:41 AM.
 
Old 01-19-2004, 11:59 AM   #7
hope
LQ Newbie
 
Registered: Jan 2004
Location: Milan - Italy
Distribution: Gentoo Linux
Posts: 9

Original Poster
Rep: Reputation: 0
  • the modules are correctly loaded. In gentoo the alsa-tools package comes with the "alsasound" script that loads the needed modules.
  • the modules.conf is the same of yours. I have just some lines more :
    alias /dev/mixer snd-mixer-oss
    alias /dev/dsp snd-pcm-oss
    alias /dev/midi snd-seq-oss
    options snd cards_limit=1
  • I tried alsamixer ... everything is unmuted and at the 100%
I don't know how it is possible !

thanks for your suggestions !
simone
 
Old 01-19-2004, 03:17 PM   #8
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
Perhaps this thread from the Gentoo forums may help. I had to do some tinkering as well to get alsa to work with the 2.6 kernel. Its very picky as to whether its is loaded as a module or compiled directly into the kernel.
 
Old 01-22-2004, 04:06 AM   #9
hope
LQ Newbie
 
Registered: Jan 2004
Location: Milan - Italy
Distribution: Gentoo Linux
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Crashed_Again
Perhaps this thread from the Gentoo forums may help.
thx C_A for your suggestion. I followed the thread and now I have a cue. I think the problem is with alsa-lib >= 0.9.8. I tried to come back to 0.9.2 but they don't compile on kernel 2.6.x because they need the alsa-driver package and the 2.4.x kernel tree.
So I have no sound yet ... any suggestion ?

tnx, simon
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA no sound intel8x0 Suse 9.2 Help chillz Linux - Hardware 5 12-11-2004 03:02 PM
No sound: channels unmuted, volume raised, kernel 2.6.7 netmask Slackware 3 07-18-2004 12:28 AM
nforce2(intel8x0) sound and kernel 2.6.2 jplev22 Linux - Hardware 2 02-10-2004 07:39 AM
peculiar sound problem (MDK90, Intel8x0, ALSA) deputyjim Linux - General 3 11-26-2002 03:56 PM
ALSA 5.1 sound with intel8x0 Tomasfuego Linux - General 0 11-11-2002 11:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 11:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration