LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 10-12-2008, 10:27 PM   #1
samkook
LQ Newbie
 
Registered: Jun 2006
Distribution: slackware
Posts: 4

Rep: Reputation: 0
No sound trough fiber optic


I have ax360 headphones that support 5.1 and I'm trying to make em wirk trough fiber optic, but i get no sound. If I use the normal pc connectors, I have sound, but only stereo.

I'm using Slackware 12.1 and have a realtek alc655 sound chip integrated in my motherboard(gigabyte 7n400 pro rev2)

I already tried almost every possible combinations in alsamixer without success and i'm sure everything i need is unmuted.

I managed to get stereo sound with the fiber optic with this .asoundrc config file, but I can't control the volume and even if i mute the master the sound is still playing (not all sound play, only the kde sounds and a video using this codec: [faad] AAC (MPEG2/4 Advanced Audio Coding))

Code:
# Override the default output used by ALSA.
# If you do not override the default, your default
# device is identical to the (unmixed) analog device
# shown below.  If you prefer mixed and/or digital
# output, uncomment the appropriate four lines below
# (only one slave.pcm line).
### Currently set w/digital-hw as the default output,
### comment out this entire section to use unmixed
### analog as your default
### -jarod
pcm.!default {
  type plug
## Uncomment the following to use mixed analog by default
#  slave.pcm "dmix-analog"
## Uncomment the following to use unmixed digital by default
  slave.pcm "digital-hw"
## Uncomment the following to use mixed digital by default
#  slave.pcm "dmix-digital"
}

# Alias for analog output on the Audigy (hw:0,0)
# - This is identical to the device named "default"--which
# always exists and refers to hw:0,0 (unless overridden)
# - Therefore, we can specify "hw:0,0", "default", or "analog"
# to access analog output on the Audigy
pcm.analog {
 type plug
 slave.pcm "analog-hw"
}

# Control device (mixer, etc.) for the Audigy card
ctl.analog {
 type hw
 card 0
}

# Alias for (rate-converted) mixed analog output on the
# Audigy (hw:0,0)
#  - This will accept audio input--regardless of rate--and
# convert to the rate required for the dmix plugin
# (in this case 48000Hz)
pcm.mixed-analog {
 type plug
 slave.pcm "dmix-analog"
}

# Control device (mixer, etc.) for the Audigy card
ctl.mixed-analog {
 type hw
 card 0
}

# Alias for (rate-converted) digital (S/PDIF) output on the
# Audigy (hw:0,0)
#  - This will accept audio input--regardless of rate--and
# convert to the rate required for the S/PDIF hardware
# (in this case 48000Hz)
pcm.digital {
 type plug
 slave.pcm "digital-hw"
}

# Control device (mixer, etc.) for the Audigy card
ctl.digital {
 type hw
 card 0
}

# Alias for mixed (rate-converted) digital (S/PDIF) output on the
# Audigy (hw:0,0)
#  - This will accept audio input--regardless of rate--and
# convert to the rate required for the S/PDIF hardware
# (in this case 48000Hz)
pcm.mixed-digital {
 type plug
 slave.pcm "dmix-digital"
}

# Control device (mixer, etc.) for the Audigy card
ctl.mixed-digital {
 type hw
 card 0
}

# The following devices are not useful by themselves.  They
# require specific rates, channels, and formats.  Therefore,
# you probably do not want to use them directly.  Instead use
# of of the devices defined above.

# Alias for analog output on the Audigy (hw:0,0)
# Do not use this directly--it requires specific rate,
# channels, and format
pcm.analog-hw {
 type hw
 card 0
 # The default value for device is 0, so no need to specify
}

# Control device (mixer, etc.) for the Audigy card
ctl.analog-hw {
 type hw
 card 0
}

# Alias for digital (S/PDIF) output on the Audigy (hw:0,0)
# Do not use this directly--it requires specific rate,
# channels, and format
pcm.digital-hw {
 type hw
 card 0
 device 2
}

# Control device (mixer, etc.) for the Audigy card
ctl.digital-hw {
 type hw
 card 0
}

# Direct software mixing plugin for analog output on
# the Audigy (hw:0,0)
# Do not use this directly--it requires specific rate,
# channels, and format
pcm.dmix-analog {
 type dmix
 ipc_key 1234
 slave {
   pcm "analog-hw"
   period_time 0
   period_size 1024
   buffer_size 4096
   rate 48000
 }
}

# Control device (mixer, etc.) for the Audigy card
ctl.dmix-analog {
 type hw
 card 0
}

# Direct software mixing plugin for digital (S/PDIF) output
# on the Audigy (hw:0,0)
# Do not use this directly--it requires specific rate,
# channels, and format
pcm.dmix-digital {
 type dmix
 ipc_key 1235
 slave {
   pcm "digital-hw"
   period_time 0
   period_size 1024
   buffer_size 4096
   rate 48000
 }
}

# Control device (mixer, etc.) for the Audigy card
ctl.dmix-digital {
 type hw
 card 0
}
I searched for about 4 hours and I'm out of ideas, so I hope one of you have one.
 
Old 10-13-2008, 11:35 AM   #2
forum1793
Member
 
Registered: May 2008
Posts: 312

Rep: Reputation: 34
For me, I needed to unmute iec958 in alsamixer for optical cable. I know you've said you you played with all settings so this probably not it.

Optical output I think only sends out signal. It probably does not control volume. My optical goes to stereo receiver which controls volume. The specs on your headset (and/or its box) say they have in-line volume control.

Check that plastic protector on optical is not there. I had this situation and did not think they were there, but they were.

I haven't had much experience in the asoundrc file.
 
Old 10-13-2008, 03:33 PM   #3
samkook
LQ Newbie
 
Registered: Jun 2006
Distribution: slackware
Posts: 4

Original Poster
Rep: Reputation: 0
I'm sure the plastic protectors are not there because it's working in windows, and yes I have unmuted iec958 several times. Thanks anyway.
 
Old 10-14-2008, 07:22 PM   #4
forum1793
Member
 
Registered: May 2008
Posts: 312

Rep: Reputation: 34
What kernel are you using. I had to go to 2.6.25 for hdmi but I also didn't try optical before that. Perhaps newer kernel will help. Currently using 2.6.25.16.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
3 isdn 1 fiber optic , use all at once nullcode000 Linux - Networking 3 05-16-2006 03:27 AM
Fiber Optics Ryan0rZ General 3 12-18-2004 03:55 AM
wireless USB optic mouse too sensitive RH9 old dell pc physivic Linux - Hardware 2 11-15-2004 07:00 AM
Fiber Optic Cables HadesThunder General 6 04-22-2004 05:01 AM
Logitech USB Optic Mouse insanebluecow Linux - Hardware 2 06-13-2003 04:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 03:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration