LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 09-04-2002, 10:36 PM   #1
wavydavey
LQ Newbie
 
Registered: Sep 2002
Location: Northern California
Distribution: Red Hat 7.3
Posts: 11

Rep: Reputation: 0
No Sound Red Hat 7.3


I am having issues with my sound under Red Hat 7.3. KDE or GNOME

Intel MB with Yamaha Sound built in ( OPL3-SA3 ) Which is on the supported list. I get the error when it boots up that the device is null. I went in chmod to 777 just to be sure. Sound works just fine when I put Windows back in. I have used sndconfig but that has not helped. I have read a bunch of other threads but nothing so far has helped out my issue.

Please help....Linux Newbie

Module Size Used by Not tainted
ad1848 25664 0 (autoclean) (unused)
sound 71692 0 (autoclean) [ad1848]
soundcore 6500 2 (autoclean) [sound]
binfmt_misc 7460 1
autofs 11972 0 (autoclean) (unused)
tulip 43232 1
ipchains 43496 11
ide-cd 30272 0 (autoclean)
cdrom 32032 0 (autoclean) [ide-cd]
usb-uhci 24484 0 (unused)
usbcore 71904 1 [usb-uhci]
ext3 67328 2
jbd 49528 2 [ext3]
 
Old 09-04-2002, 10:58 PM   #2
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
what is the error?

did you try to set the volume with aumix
 
Old 09-05-2002, 09:41 AM   #3
wavydavey
LQ Newbie
 
Registered: Sep 2002
Location: Northern California
Distribution: Red Hat 7.3
Posts: 11

Original Poster
Rep: Reputation: 0
Here is the info you requested.

Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (No such device)
The sound server will continue, using the null output device.


[root@localhost root]# aumix
aumix: error opening mixer

[root@localhost root]# cd /
[root@localhost /]# aumix
aumix: error opening mixer
[root@localhost /]#

Thanks
 
Old 09-05-2002, 12:39 PM   #4
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
the problem / answer is more than likely going to be in modules.conf / kernel params

try this

http://www.linuxvalley.it/encycloped...sound/OPL3-SA2
 
Old 09-05-2002, 06:12 PM   #5
wavydavey
LQ Newbie
 
Registered: Sep 2002
Location: Northern California
Distribution: Red Hat 7.3
Posts: 11

Original Poster
Rep: Reputation: 0
I'll look at it & try it out....

I will let you know the outcome.

Thanks
 
Old 09-05-2002, 10:36 PM   #6
wavydavey
LQ Newbie
 
Registered: Sep 2002
Location: Northern California
Distribution: Red Hat 7.3
Posts: 11

Original Poster
Rep: Reputation: 0
Well I have messed around with that doc but a little over my head. I disabled the built in sound in the bios & restarted the machine. It reconfigured with out the sound. Then I went back in and enabled the sound & restarted the machine & still get the same error....

Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (No such device)
The sound server will continue, using the null output device.


Here is an excerpt from var/log/messages

Sep 5 19:40:00 localhost kernel: ad1848/cs4248 codec driver Copyright (C) by Hannu Savolainen 1993-1996
Sep 5 19:40:00 localhost kernel: ad1848: OPL3-SA2 WSS mode detected Sep 5 19:40:00 localhost kernel: ad1848: ISAPnP reports 'OPL3-SA2 WSS mode' at
i/o 0xe80, irq 5, dma 1, 3 Sep 5 19:40:01 localhost modprobe: modprobe: Can't locate module sound-service-
0-0 Sep 5 19:40:01 localhost last message repeated 2 times
Sep 5 19:40:01 localhost modprobe: modprobe: Can't locate module sound-slot-1 Sep 5 19:40:01 localhost modprobe: modprobe: Can't locate module sound-service-
1-0 Sep 5 19:40:01 localhost modprobe: modprobe: Can't locate module sound-slot-1
Sep 5 19:40:02 localhost modprobe: modprobe: Can't locate module sound-service-1-0
Sep 5 19:40:02 localhost modprobe: modprobe: Can't locate module sound-service-0-3
Sep 5 19:40:20 localhost modprobe: modprobe: Can't locate module sound-service-0-0

I have gone in to sndconfig & set it to the paramerters that I see in the messages. That did not help either.


Unable To Play Audio

An error occurred opening /dev/audio


I hope that this may give more light on my prob & help with some more advice.
 
Old 09-05-2002, 10:42 PM   #7
wavydavey
LQ Newbie
 
Registered: Sep 2002
Location: Northern California
Distribution: Red Hat 7.3
Posts: 11

Original Poster
Rep: Reputation: 0
Now lsmod looks diff...

Module Size Used by Not tainted
mpu401 22208 0 (unused)
ad1848 25664 0 (unused)
sound 71692 0 [mpu401 ad1848]
soundcore 6500 2 [sound]
binfmt_misc 7460 1
autofs 11972 0 (autoclean) (unused)
tulip 43232 1
ipchains 43496 11
ide-cd 30272 0 (autoclean)
cdrom 32032 0 (autoclean) [ide-cd]
usb-uhci 24484 0 (unused)
usbcore 71904 1 [usb-uhci]
ext3 67328 2
jbd 49528 2 [ext3]


Now what do I do?
 
Old 09-05-2002, 10:49 PM   #8
wavydavey
LQ Newbie
 
Registered: Sep 2002
Location: Northern California
Distribution: Red Hat 7.3
Posts: 11

Original Poster
Rep: Reputation: 0
Nevermind...on the last post...I rebooted & it is back to the same.

Module Size Used by Not tainted
ad1848 25664 0 (autoclean) (unused)
sound 71692 0 (autoclean) [ad1848]
soundcore 6500 2 (autoclean) [sound]
binfmt_misc 7460 1
autofs 11972 0 (autoclean) (unused)
tulip 43232 1
ipchains 43496 11
ide-cd 30272 0 (autoclean)
cdrom 32032 0 (autoclean) [ide-cd]
usb-uhci 24484 0 (unused)
usbcore 71904 1 [usb-uhci]
ext3 67328 2
jbd 49528 2 [ext3]


Thanks
 
Old 09-08-2002, 01:44 AM   #9
wavydavey
LQ Newbie
 
Registered: Sep 2002
Location: Northern California
Distribution: Red Hat 7.3
Posts: 11

Original Poster
Rep: Reputation: 0
Well the update on my prob....

I did not have the patience to work thru the issue so I went & bought a SoundBlaster card, disabled my onboard sound and bingo it works like it is supposed to.

Thanks for the effort.
 
Old 09-09-2002, 11:08 AM   #10
FreakboY
Member
 
Registered: Jun 2002
Location: TX, USA
Distribution: Slackware
Posts: 381

Rep: Reputation: 31
please help me out!!
i have the same problem!!!


thanx!
 
Old 09-09-2002, 11:27 AM   #11
wavydavey
LQ Newbie
 
Registered: Sep 2002
Location: Northern California
Distribution: Red Hat 7.3
Posts: 11

Original Poster
Rep: Reputation: 0
I was not able to make any dents in the progress of trying to get the onboard sound(The motherboard is from 1997 & we know that is about 20 computer years old) to work. I went and bought a Soundbblaster 128 pci. I disabled my onboard sound in the bios. Loaded up Redhat 7.3 & disconfigured the bad sound card. Shut down the machine & installed the new card. When RH7.3 started up it detected the new card & set it up. No problems!

I do not know if this is the help you were looking for but this is all I did.
 
Old 09-09-2002, 01:06 PM   #12
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
With RH 7.3 all the systems I installed came up with sound working.

If your card is supported in Linux then it may require a kernel patch or rebuild.
 
Old 09-09-2002, 05:15 PM   #13
wavydavey
LQ Newbie
 
Registered: Sep 2002
Location: Northern California
Distribution: Red Hat 7.3
Posts: 11

Original Poster
Rep: Reputation: 0
I went and looked at that link you sent & messed around a bit but was a little more then I felt comfortable doing at this time. I am just inthe stage of trying Linux out to see if I can get over my MS dependancy. So I wanted it to be more of an easy process. In the future I may go back & see if I can get the onboard sound to work, but for now i just wanted it to be "easy". And it was.

Thank you.
 
Old 09-09-2002, 07:49 PM   #14
FreakboY
Member
 
Registered: Jun 2002
Location: TX, USA
Distribution: Slackware
Posts: 381

Rep: Reputation: 31
how to disconfigure!??
 
Old 09-09-2002, 08:33 PM   #15
wavydavey
LQ Newbie
 
Registered: Sep 2002
Location: Northern California
Distribution: Red Hat 7.3
Posts: 11

Original Poster
Rep: Reputation: 0
When I went into the bios I disabled the sound & I left the new one out. I booted up RH 7.3 and when it came to the point of detecting new hardware it told me that the onboard sound was gone & if I wanted to unconfigure the changes...I did so & then let the machine go all the way to KDE. Then I shut the machine down & installed the new card.

I did not have to go in & monkey with anything on a command line or anything. It was all automated.

I hope that helps. If you need more explanation on a specific step that I did then let me know.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound in Red hat 8.0 tonan Linux - Hardware 4 09-28-2004 08:57 AM
No sound in Red Hat 9 theragsin Linux - Hardware 1 06-21-2004 05:14 PM
No sound on Red Hat 8.0 ssmaitra Linux - Software 1 03-05-2004 01:20 AM
No sound Red Hat 9 brett108 Linux - Newbie 5 09-20-2003 04:10 PM
No Sound in Red Hat 8 cat5e Linux - Hardware 13 03-02-2003 01:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 12:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration