-   Linux - Hardware (
-   -   No sound output from audio players but audio from flash exists (

Janus_Hyperion 09-24-2012 06:43 PM

No sound output from audio players but audio from flash exists
I am having a very weird problem with my laptop since last night. Every time I login and start some music player (or even if I don't), everything is normal for a few minutes. After those initial few minutes, the sound is completely dead from the music players and sound settings under GNOME/Cinnamon do not show any device as being recognized.

I was wondering if pulseaudio crashed and tried to restart it - no use. Here is what I saw.


#  pulseaudio --start

N: [pulseaudio] main.c: User-configured server at {96b4dc501e4113f6e74f263d0000001c}unix:
/home/username/.pulse/96b4dc501e4113f6e74f263d0000001c-runtime/native, which appears to be local. Probing deeper.
E: [pulseaudio] main.c: Daemon startup failed.

Also, this.


# pulseaudio -k && pulseaudio --start

E: [pulseaudio] main.c: Failed to kill daemon: No such process

However, when I play a video (from youtube, for example) in Firefox, there are no problems with audio - it plays normally.


# alsamixer -c 0
Shows me all the available sound devices and is responsive when I change the sound. But sound output is present. This happens with both headphones and speakers. Both work fine with flash.

PHP Code:

# lspci

00:1b.0 Audio deviceIntel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
01:00.1 Audio devicenVidia Corporation HDMI Audio stub (rev a1

Long story! My question - how can I fix this sound instabilty? Any suggestions would be much appreciated. Thanks a lot in advance.

Janus_Hyperion 09-27-2012 09:52 AM

The problem was clearing files in /tmp at too high a frequency. Issue solved.

All times are GMT -5. The time now is 03:19 PM.