-   Linux - Hardware (
-   -   No sound or bad sound card with Codec: Realtek ALC888 (

ludger 02-06-2011 02:14 PM

No sound or bad sound card with Codec: Realtek ALC888
I have, as many other people problems with a Realtek ALC888 chip. Could anybody help me solving it?
I have an MSI X600 laptop with a motherboard sound card wich can not be turned off in bios. Besides my MSI has a RV710/730 multimedia sound card of ATI Technologies Inc. with the infamous Realtek ALC888 chip that I just, as many others can not get right installed. I've tried it in UBUBTU first. In the best configuration I only got sound via the internal sound card. Most of the time both cards were not even visible.
A week ago I have disided to put my hopes on OpenSUSE. First of all I followed the explanation on the google page of Piotr (I did also installed all multimedia for openSUSE ).
By adding the line; options snd_hda_intel model = hp-6stack to / etc./modeprobe.d/50-sound.conf the sound started a little bit to function. The sound card was visible in the output window in sound preferences, but the sound continued to come out of the internal speaker, very tinny and no soundcolor at all. It also came out with wrong speed; very weird, like Ben described in a Thread on the OpenSuse forum November 17, 2010( Then it turn to go too slowly, as if the speed of the music depends on the amount of memory use? As I said I have an MSI laptop with GNOME. In short, Ben and Knurpht semes to figured it. So one more time; Is there anybody who can help me out with this?


EricTRA 02-15-2011 02:19 AM

Hello and Welcome to LinuxQuestions,

You marked your thread as solved. Would you mind sharing your solution with the community so that others in a similar situation can try it out too? Thanks in advance. Off the Zero Reply List.

Kind regards,


ludger 02-16-2011 04:18 AM

dear EricTRA and other forum members, My solution was as simple as could be, but not simple to understand. I did find help on the Dutch Google site of Pjotr where he writes on this page how I could change the alsa-base.conf file in /etc/modprobe.d/ (UBUNTU)
I did tried to solve my problem for several months by trying it this way, but did not succeed; most of the time no card to be seen at all, and when I could see him I did not get any sound, or just via the intern speaker. Awful and no color at all.

So I installed Open Suse in stead of UBUNTU.

After placing this tread I installed UBUNTU again, besides Open Suse with complete installed MUlitmedia etc and with this clean install I added again the line options snd_hda_intel model=6stack-hp
in /etc/modeprobe.d/alsa-base.conf

So this is my file now;


# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
options snd_hda_intel model=6stack-hp

As I said, I did not understand what helped, but from that moment on I did have sound, with color, out of my 4 speakers and out of my headphones with the right tempo! In open Suse my problem is still not solved, but that is no issue for this moment any more.
For my use I just need one Distro complete functioning. The solving of the Open Suse problem is for the future, when I have more basic knowledge of Linux. ;-))

So I would say; all the best for this moment guys and girls, when you need more from me I'll be there Greetings Ludger

EricTRA 02-16-2011 04:20 AM


Thanks for sharing that. I'm sure it'll be put to use by someone.

Kind regards,


All times are GMT -5. The time now is 08:16 PM.