-   Linux - Hardware (
-   -   No sound on headphone's jack? Normal sound output OK (

sreeharsha.t 02-16-2009 11:53 AM

No sound on headphone's jack? Normal sound output OK

I have installed Fedora 10-x86_64. I was happy and content with the distribution. Earlier, I found that there is no sound on my headphone's jack where as the normal sound output from my laptops's speakers is OK. I fiddled with the available mixers but couldnt get anything. There seem to be 5 different mixers (HDA, ALSA, OSS), 3 for the playback and 2 for the capture.

I am using an acer 4530 laptop. It has a nvidia Nforce MCP77 chipset.

and the o/p
lsmod| grep snd :

snd_hda_intel        476576  3
snd_seq_dummy          11396  0
snd_seq_oss            39104  0
snd_seq_midi_event    14848  1 snd_seq_oss
snd_seq                61968  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device        15380  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            52224  0
snd_mixer_oss          23168  1 snd_pcm_oss
snd_pcm                85512  2 snd_hda_intel,snd_pcm_oss
snd_timer              30352  2 snd_seq,snd_pcm
snd_page_alloc        16656  2 snd_hda_intel,snd_pcm
snd_hwdep              16392  1 snd_hda_intel
snd                    68984  16 snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
soundcore              14992  1 snd

I did a alsa-info and upload the details at:

Any help on this?

sreeharsha.t 02-17-2009 12:37 AM

hey yo!!

I got the sound o/p on my headphones jack. This time, I included all the available options such as (surround, front speaker, PC speaker) in the alsa mixer. The surround one is muted by default, so I tried unmuting it and it worked!! :) strangely my headphones jack is being called as surround speaker jack by alsa mixer.

I guess alsa has detected my sound card as a 5.1 sound card and it mapped my headphones out jack to the surround speaker jack. To support this, even when I plug my headphones, the normal PC speaker which is mapped as 'front speaker' is still playing. I have to mute it manually to cut the audio from it.

I tried the command alsaunmute command and it says that it 'guessed the card "HDA Intel" "ALC888" .... '

From the above line its evident that it didnt determine my sound card exactly and that's why the mapping errors.

Is there a way in which we can specify the type or operational mode of my sound card to set it to work as a stereo one, not as 5.1??

shri19 06-13-2009 08:57 AM

thanx a lot buddy. i went through weeks of struggle to fix this issue on my acer 4530. million thanx to u for this simple tip.

All times are GMT -5. The time now is 07:30 PM.