LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   No sound on Acer TravelMate 6291with Intel High Definition Audio on Fedora Core 6 (https://www.linuxquestions.org/questions/linux-hardware-18/no-sound-on-acer-travelmate-6291with-intel-high-definition-audio-on-fedora-core-6-a-565605/)

akiglobal 06-30-2007 09:00 AM

No sound on Acer TravelMate 6291with Intel High Definition Audio on Fedora Core 6
 
I just bought a brand new Acer TravelMate 6291 and i installed Fedora Core 6 on it. Fedora recognized my onboard soundcard as Intel High Definition Audio...but when I tested it, there was no sound came out of it. anyone can help me please?

janstedehouder 07-01-2007 10:53 PM

I may have a solution, at least on that worked on my Acer 3681 with Ubuntu.

Step 1: open a terminal and type:

Code:

gksu gedit /etc/modprobe.d/alsa-base
Step 2: add the following line at the end of the document

Code:

options snd-hda-intel model=auto
Step 3: Make sure that you have no sound related programs running and type:

Code:

sudo rmmod snd_hda_intel
Step 4: Type

Code:

sudo modprobe snd_hda_intel
If that doesn't work, a reboot might do the trick

akiglobal 07-03-2007 08:15 AM

Switch Fedora Core 6 to OpenSuse 10.2
 
Hi Janstedehouder..thank you for your quick and thoughtful reply. I decided to switch to OpenSuse 10.2 for its ability to recognise many hardwares. Unfortunately, the same problem still occur, OpenSuse recognise my Intel High Definition Audio but with no sound. So, I tried your solution with a little adaptation in OpenSuse 10.2.

I performed your step 1 with vi /etc/modprobe.d/sound and performed your step 2,3,4 verbatim and performed an init 6.

To my surprise, the problem prevails. I don't know why..but I will never give up..

so..again thank you and I hope maybe you have another solution for me? :)

Go Open Source And Bless Acer

ntviscom 07-07-2007 05:03 AM

Hi Akiglobal,
Have you tried model=acer option?

dashcloud 07-07-2007 08:25 AM

Can you post /sbin/lspci (just the part about your sound card), and also provide /proc/asound/card0/codec#0 (just the part until it says Default PCM)

mrdav1e 07-08-2007 12:05 PM

No Sound on Asus Z35F - Success Story
 
This problem had me stumped for days and I tried 4 different distros to get the sound working, finally resolving back to Ubuntu 7.04 i386.

I followed steps 1 - 4 above with the following exceptions:
Step 2 I changed model=asus, this is what finally got the sound working.
Step 3, I received an error msg the sound card was in use so I just ignored it, no other apps were running. A restart did the trick!

Thanks!
Dave

akiglobal 07-11-2007 01:07 AM

thanks ntviscom, but i still can't get the sound out.


hi...dashcloud this is my lspci -vv output on audio device

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
Subsystem: Acer Incorporated [ALI] Unknown device 012a
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 74
Region 0: Memory at d0440000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Address: 0000000000000000 Data: 0000
Capabilities: [70] Express Unknown type IRQ 0
Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag-
Device: Latency L0s <64ns, L1 <1us
Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
Link: Supported Speed unknown, Width x0, ASPM unknown, Port 0
Link: Latency L0s <64ns, L1 <1us
Link: ASPM Disabled CommClk- ExtSynch-
Link: Speed unknown, Width x0
Capabilities: [100] Virtual Channel
Capabilities: [130] Unknown (5)

and for your request on /proc/asound/card0/codec#0, i found it empty, codec#1 isn't, oddly enough...and it has realtek in it? care you to enlight me. thanks.

mrdav1e 07-12-2007 09:23 AM

Bios
 
Just to double check, is audio enabled in your BIOS?

ntviscom 07-14-2007 06:23 AM

Hi,
This notebook contains a Realtek ALC268 sound chip which hasn't been supported
by ALSA now, but you can get the sound working if you recompile the latest ALSA sources and two patch files (https://bugtrack.alsa-project.org/al...ew.php?id=3165)

Do the following:
- download latest alsa-driver 1.0.14 from ALSA site
*- download realtek12.tar.gz from
https://bugtrack.alsa-project.org/al...ew.php?id=3104 [^]
* - unpack the alsa driver
*- replace two files from the realtek12 package into alsa driver dir
*alsa-driver-1.0.14/pci/hda
*- ./configure
*- make
*- sudo make install
*- set up the soundcard with yast, add 'model=toshiba' parameter
*- reboot

Unfortunately the microphone still doesn't work.

akiglobal 07-19-2007 12:08 AM

hi mrdav1e. the sound is automatically activated..I know this because I test it with windows vista without adding supplementary drivers.


All times are GMT -5. The time now is 08:07 AM.