LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 12-08-2005, 09:36 AM   #1
shiyongzhe
LQ Newbie
 
Registered: Dec 2005
Posts: 2

Rep: Reputation: 0
no sound in SuSE 9.3 w/Ensoniq es1371 chipset


I am running SuSE 9.3 with kernel 2.6.11.4-20a-default.

I 'm having trouble configuring sound support. I can play audio CDs (presumably because the drive is wired directly to the onboard sound), but other than that I can't get the system to produce so much as a beep.

lspci gives:
Code:
# lspci
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x] (rev 82)
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP]
0000:00:07.0 ISA bridge: VIA Technologies, Inc. VT82C596 ISA [Mobile South] (rev 12)
0000:00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)0000:00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 08)
0000:00:07.3 Host bridge: VIA Technologies, Inc. VT82C596 Power Management (rev 20)
0000:00:0e.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 08)
0000:00:10.0 USB Controller: NEC Corporation USB (rev 43)
0000:00:10.1 USB Controller: NEC Corporation USB (rev 43)
0000:00:10.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
0000:00:13.0 Serial controller: 3Com Corp, Modem Division (formerly US Robotics) 56K FaxModem Model 5610 (rev 01)
0000:01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)
I'm including my /dev/sndstat file below as a summary of my sound setup. I understand /dev/sndstat is legacy stuff, but it's handy for this purpose. Also, the Mixers: entry looks pretty suspect, but I'm not sure where I'd make a change to get that corrected.

Code:
# cat /dev/sndstat
Sound Driver:3.8.1a-980706 (ALSA v1.0.8 emulation code)
Kernel: Linux linux 2.6.11.4-20a-default #1 Wed Mar 23 21:52:37 UTC 2005 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
Ensoniq AudioPCI ENS1371 at 0xe800, irq 3

Audio devices:
0: ES1371 DAC2/ADC (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices:
0: ES1371

Timers:
7: system timer

Mixers:
0: 0x8a054e53 ?\uffffN,0x8a054e53 ?\uffffN
Any help would be very much appreciated
 
Old 12-08-2005, 10:02 AM   #2
vangelis
Member
 
Registered: Nov 2004
Location: Hellas
Distribution: Zenwalk 6.4
Posts: 337
Blog Entries: 4

Rep: Reputation: 30
your sound device seems ok from a first look, check kmix in kde if anything is muted or low.
Happened many time to fresh installs
 
Old 12-08-2005, 10:36 AM   #3
shiyongzhe
LQ Newbie
 
Registered: Dec 2005
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by vangelis
your sound device seems ok from a first look, check kmix in kde if anything is muted or low.
Happened many time to fresh installs
Thanks for your reply vangelis. I've used both kmix and alsamixer to raise volume levels and unmute everything I can find, but to no avail. I should note that if I raise the master volume all the way up, it does increase the amount of hum/white noise coming from my speakers, yet I still can't get the system to produce a "real" sound (e.g., using the "Test" button in the YaST sound configurator).

Last edited by shiyongzhe; 12-08-2005 at 09:00 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ensoniq es1371 - no sound torsin Linux - Hardware 5 12-01-2006 04:21 AM
ensoniq es1371 problems torsin Debian 6 11-01-2005 09:40 AM
Strange noise from the spreakers (Ensoniq / ES1371 sound card and Fedora Core 2) (A) Linux - Hardware 0 10-17-2004 12:16 PM
Problems with Ensoniq ES1371 maas15 Linux - Hardware 3 08-22-2004 10:57 PM
Sound Blaster 128/ensoniq es1371 driver install Rodcl Linux - Hardware 8 08-19-2002 01:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 07:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration