-   Linux - Hardware (
-   -   no sound in Fedora 8 "PULSEAUDIO: Unable to connect-" (reposted) (

Legolas327 03-30-2008 06:04 PM

no sound in Fedora 8 "PULSEAUDIO: Unable to connect-" (reposted)
I am reposting this because I did not get anywhere under the Fedora thread. Hopefully this will work. I am very frustrated with this issue. new system/ No sound!!

I have read many threads and still not sure what to do. This is a newly built and loaded computer and after upgrades. I have onboard sound MCP55 HDA intel. I am trying to use the spdif optical out. I get nothing. I have an other computer same FD8 OS but it has a audigy z-2 sound card running spdif out (not optical) and it works just fine. If you can help please do. I am out of ideas and not sure what to look for to correct the issue?


    [root@GraysNew ~]# uname -a
Linux GraysNew #1 SMP Thu Mar 20 13:39:08 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

When I run system-config-soundcard I get this in the scsrun.log. First big clue is the "PULSEAUDIO: Unable to connect: Connection refused"
Why I don't know?


------- System Config Soundcard Log --------
Sun Mar  2 09:53:30 EST 2008

Playing WAVE '/usr/share/system-config-soundcard/sound-sample.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
*** PULSEAUDIO: Unable to connect: Connection refused
amixer: Mixer attach default error: Connection refused
ProbeCards, method =  hal
--------- Card 0 --------
Active 1
Vendor: nVidia Corporation
Model: MCP55 High Definition Audio
Driver: snd-hda-intel

Here is my aplay -L listing (note the null on the digital out)


    [root@GraysNew ~]# aplay -L
    HDA NVidia, ALC882 Analog
    Front speakers
    HDA NVidia, ALC882 Analog
    4.0 Surround output to Front and Rear speakers
    HDA NVidia, ALC882 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
    HDA NVidia, ALC882 Analog
    5.0 Surround output to Front, Center and Rear speakers
    HDA NVidia, ALC882 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    HDA NVidia, ALC882 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    HDA NVidia, ALC882 Digital
    IEC958 (S/PDIF) Digital Audio Output
    Discard all samples (playback) or generate zero samples (capture)

Here is my amixer list:


[root@GraysNew ~]# amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Front Left: Playback 49088 [75%] [on]
  Front Right: Playback 49088 [75%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 65536 [100%] [off]
  Front Right: Capture 65536 [100%] [off]

Here is the asound version:


[root@GraysNew ~]# cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.15 (Tue Nov 20 19:16:42 2007 UTC).

Here is my asound.conf file:


[root@GraysNew ~]# cat /etc/asound.conf
#Generated by system-config-soundcard
#If you edit this file, don't run system-config-soundcard,
#all your changes here could be lost.
#DEV 1
defaults.pcm.card 0
defaults.pcm.device 1
defaults.ctl.card 0

Here is my sysconfig/hwconf listing for audio:


class: AUDIO
bus: PCI
detached: 0
driver: snd-hda-intel
desc: "nVidia Corporation MCP55 High Definition Audio"
vendorId: 10de
deviceId: 0371
subVendorId: 10de
subDeviceId: c55e
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  f
pcifn:  1


[root@GraysNew ~]# cat /proc/asound/pcm
00-02: ALC882 Analog : ALC882 Analog : capture 2
00-01: ALC882 Digital : ALC882 Digital : playback 1 : capture 1
00-00: ALC882 Analog : ALC882 Analog : playback 1 : capture 2
Here is my lspci -vn:


[root@GraysNew ~]#  clr; lspci -v |grep -iC 10 audio
00:0f.1 Audio device: nVidia Corporation MCP55 High Definition Audio (rev a2)
        Subsystem: nVidia Corporation Unknown device c55e
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 20
        Memory at cfff0000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [44] Power Management version 2
        Capabilities: [50] Message Signalled Interrupts: Mask+ 64bit+ Queue=0/0 Enable-
        Capabilities: [6c] HyperTransport: MSI Mapping Enable- Fixed+
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

Not sure what to make of this:

Subsystem: nVidia Corporation Unknown device c55e
My lsmod output:


      [root@GraysNew ~]# lsmod |grep snd
snd_usb_audio          95169  0
snd_usb_lib            24001  1 snd_usb_audio
snd_rawmidi            28865  1 snd_usb_lib
snd_hda_intel        361577  4
snd_seq_dummy          11461  0
snd_seq_oss            37313  0
snd_seq_midi_event    15041  1 snd_seq_oss
snd_seq                56673  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device        15061  4 snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            45889  0
snd_mixer_oss          22721  2 snd_pcm_oss
snd_pcm                80201  3 snd_usb_audio,snd_hda_intel,snd_pcm_oss
snd_timer              27721  2 snd_seq,snd_pcm
snd_page_alloc        16465  2 snd_hda_intel,snd_pcm
snd_hwdep              16073  2 snd_usb_audio,snd_hda_intel
snd                    60137  17 snd_usb_audio,snd_rawmidi,snd_hda_intel,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
soundcore              15073  2 snd

Here is a listing of installed alsa software:


[root@GraysNew ~]# clr; yum list installed |grep alsa
alsa-lib.x86_64                          1.0.15-1.fc8          installed
alsa-lib.i386                            1.0.15-1.fc8          installed
alsa-lib-devel.x86_64                    1.0.15-1.fc8          installed
alsa-lib-devel.i386                      1.0.15-1.fc8          installed
alsa-oss.x86_64                          1.0.14-3.fc8          installed
alsa-oss-devel.i386                      1.0.14-3.fc8          installed
alsa-oss-devel.x86_64                    1.0.14-3.fc8          installed
alsa-oss-libs.x86_64                    1.0.14-3.fc8          installed
alsa-oss-libs.i386                      1.0.14-3.fc8          installed
alsa-plugins-jack.x86_64                1.0.15-2.fc8          installed
alsa-plugins-oss.x86_64                  1.0.15-2.fc8          installed
alsa-plugins-pulseaudio.x86_64          1.0.15-2.fc8          installed
alsa-plugins-samplerate.x86_64          1.0.15-2.fc8          installed
alsa-plugins-upmix.x86_64                1.0.15-2.fc8          installed
alsa-plugins-vdownmix.x86_64            1.0.15-2.fc8          installed
alsa-tools.x86_64                        1.0.12-4.fc7          installed
alsa-utils.x86_64                        1.0.15-1.fc8          installed
alsamixergui.x86_64                      0.9.0-0.3.rc1.fc8.2    installed
bluez-utils-alsa.x86_64                  3.20-6.fc8            installed

Here is a listing of my pulseaudio installed software:

akode-pulseaudio.x86_64                  2.0.2-4.fc8            installed
alsa-plugins-pulseaudio.x86_64          1.0.15-2.fc8          installed
kde-settings-pulseaudio.noarch          3.5-36.fc8.1          installed
pulseaudio.x86_64                        0.9.8-5.fc8            installed
pulseaudio-core-libs.x86_64              0.9.8-5.fc8            installed
pulseaudio-esound-compat.x86_64          0.9.8-5.fc8            installed
pulseaudio-libs.i386                    0.9.8-5.fc8            installed
pulseaudio-libs.x86_64                  0.9.8-5.fc8            installed
pulseaudio-libs-devel.i386              0.9.8-5.fc8            installed
pulseaudio-libs-devel.x86_64            0.9.8-5.fc8            installed
pulseaudio-libs-glib2.x86_64            0.9.8-5.fc8            installed
pulseaudio-libs-glib2.i386              0.9.8-5.fc8            installed
pulseaudio-libs-zeroconf.i386            0.9.8-5.fc8            installed
pulseaudio-libs-zeroconf.x86_64          0.9.8-5.fc8            installed
pulseaudio-module-bluetooth.x86_64      0.9.8-5.fc8            installed
pulseaudio-module-gconf.x86_64          0.9.8-5.fc8            installed
pulseaudio-module-jack.x86_64            0.9.8-5.fc8            installed
pulseaudio-module-lirc.x86_64            0.9.8-5.fc8            installed
pulseaudio-module-x11.x86_64            0.9.8-5.fc8            installed
pulseaudio-module-zeroconf.x86_64        0.9.8-5.fc8            installed

Help would be greatly appreciated.

Simon Bridge 03-30-2008 06:23 PM

Sorry about the other thread, I got distracted...

This is a newly built and loaded computer and after upgrades.
Did you have sound before the upgrades? (Did it pass the sound test?)
... have you checked against this thread?

The above info suggests that your card is recognized and active, the correct driver is being used. You seem to have the alsa and pulseaudio packages. But there's much more. Work your way through the howto and tell me where you get stuck.

Legolas327 03-30-2008 11:42 PM

Thank you Simon :)

To your first question: This is a new computer from assembled parts "Newegg" all new components and fresh FD 8 installed and then the regular updates after installation. I have never had sound or any indication of sound and would get the "sound server not connected and sent to Null output" or something like that every time I booted up.

I am very happy but not completely finished. I followed the guide as you provided. It was great!! For the first time I can see "PCM" in my receiver window which means that the sound card has made connection!!! Unfortunately it gets disconnected in about 2-5 minutes or disappears and reappears. I can hear sound coming out of my receiver when I complete a command or such in a terminal so I know sound is available when the "PCM" led is lit up.

However, two things. I do not have the "svn" versions of the pulseadio files as listed in the howto, but I think I have all required:

[root@GraysNew ~]# rpm -qa pulse*

And secondly I am using KDE which means I had to do some set up in Gnome and work my way through some Gnome menus.

I am not sure what to check now. Currently the PCM connection is gone in the receiver and no sound but the Pulseaudio managers shows that I am still connected.

Legolas327 03-31-2008 12:34 AM

It is late EST and I have to go to work tomorrow. One last note. I didn't do any thing different but reboot a couple of times but now the "PCM" is solid in the receiver and I can play music out of Amarok. Yeah.. the only thing is that the Pulseaudio shows me as disconnected???? I have something fighting something else for control of the audio output which is oh so much better than I had before but I don't know what? I don't know which server is connected now?


Simon Bridge 03-31-2008 05:52 AM

What makes you think there is a conflict?

Check you are not using OSS anywhere. (Like in any media-player settings.)
Double-check you have enabled pulseaudia as per the howto.

Look through your logs, you may have an irq conflict (not unlikely on a hybrid system).

The point, partly, of pulseaudio is that different apps can call on the server without having to compete. You'd be running some sort of player, and the system sounds. You could try disabling the system sounds to see if the conflict goes away.

Legolas327 04-01-2008 10:21 PM

Thank you Simon. I don't want you think that I went away. I just had to do quite a bit to my system. Ummm... basically I did all that you asked. That howto is wonderful but as stated before I was getting unstable connection. After trying various things I finally started crashing and locking up any media player that I tried. So I had the bright Idea of reinstalling Alsa and Pulseaudio. Oh boy LOL I basically removed KDE and Gnome applications that were Dependant on alsa by accident. After reloading all of those (approximately 320) I went through the Howto walk through again exactly step by step. I now have sound playing great through Rhythmbox and system sounds.

I am trying to figure out why Xine (which I absolutely love) is not working? It was one of the programs removed so I reinstalled Xine and all of the codex files but it fails to operate properly. I get a black blank screen and it locks up and I have to use the kill command on it.

So far things that work are: Rhythmbox and Kmplayer
Thinks that fail and lock up the system are: xine, Mplayer, and Amarok.

I am a little gun shy at this point to mess up what I have working.

Any ideas what I need to do to get my Xine working again?

dnguyen 04-02-2008 03:22 PM

My newly upgraded Fedora 8 has no sound too. I am using Dell Optiplex desktop, with Intel soundcard. Only the "Soundcard Detection" tool in System->Administration can play a test sound. Other softs like vlc, rythmbox, or skype (as someone reported working) failed. Everything is fine with previous Fedora 7, and there is no hardware change at all, the only wrong move so far is upgrading to Fedora 8.
Anyone has the same problem?

Legolas327 04-02-2008 06:10 PM

I am looking for solutions to xine engine applications failing: This is a list of the xine installed rpms:


[gray@GraysNew ~]$ yum list installed |grep xine
gxine.x86_64                            0.5.11-14.fc8          installed
gxine-mozplugin.x86_64                  0.5.11-14.fc8          installed
totem-xine.x86_64                        2.20.1-1.lvn8          installed
totem-xine-devel.x86_64                  2.20.1-1.lvn8          installed
totem-xine-galago.x86_64                2.20.1-1.lvn8          installed
totem-xine-lirc.x86_64                  2.20.1-1.lvn8          installed
totem-xine-mozplugin.x86_64              2.20.1-1.lvn8          installed
xine.x86_64                              0.99.5-1.lvn8          installed
xine-lib.x86_64                          1.1.11-1.fc8          installed
xine-lib.i386                            1.1.11-1.fc8          installed
xine-lib-arts.x86_64                    1.1.11-1.fc8          installed
xine-lib-devel.x86_64                    1.1.11-1.fc8          installed
xine-lib-extras.x86_64                  1.1.11-1.fc8          installed
xine-lib-extras-nonfree.x86_64          1.1.11-1.lvn8          installed
xine-plugin.x86_64                      1.0-5.fc8              installed

I have tested Xine without the Pulseaudio connected and it works just fine. If I try to use xine with Pulse audio connected it locks xine up and disconnects pulseaudio. I have read many posting on issues with Xine and Pulseaudio and the one solution provided in this posting is to place the following statement into the .xine/config file:


audio.driver:pulse (or polypaudio or esd depending on xine version)

I did this but no change.

The odd thing is that I have a 32bit 386 setup working just fine with Fedora 8 and all video and sound applications. I did none of the Pulseaudio setup and it has worked with just fine with all sounds and applications. I ran the pulseaudio -vv command and it tested good. I don't have any of the Pulseaudio controls shown below installed.


* PulseAudio Volume Control
    * PulseAudio Volume Meter
    * PulseAudio Manager
    * PulseAudio Device Chooser
    * PulseAudio Preferences

At this point I am considering removing the Pulseaudio completely if I can get AlSA to work with out it. The reason I have not is that since I did a new install directly from the Fedora 8 dvd and the Fedora 8 team are all excited about Pulseaudio and I am sure they did detail testing before releasing that I have something uniquely buggy with my system. I can start all over again from scratch (total reload) but I seriously hate to that.

Any Ideas?


Simon Bridge 04-04-2008 08:39 AM
... seen this.

Apologies for making you do the work here - I'm snowed.

Legolas327 04-04-2008 12:54 PM

Hi Simon. Thanks for the reference. I have great sound through the optical spidif cable which I did not have before I started this thread and am connected via PCM but my issue now is getting anything with the xine engine to not crash when trying to connect or conflict with the psuedoaudio server. There are a few posting on how to make the xine engine to work with pulseaudio work but I did not get any change in results.

I also think that I may have messed up some things on the base Fedora 8 platform when I removed Asla and Pulseaudio and reinstalled. Because of this doubt and knowing the amount of system (KDE and Gnome) applications that were removed and reloaded I think it best to do a reload, get to this functioning position, then analyze where I am. I have increased my knowledge ten fold (ok double) so don't think it will be difficult to get back to where I am now on a clean installed system.


Legolas327 04-21-2008 08:11 AM

I have been off of this posting awhile but been very busy trying everything suggested here and reading many other sites. When I left this posting last I was able to play sound out of my computer for applications that did not use the Xine engine ( xine and a few other xine type of applications). After trying many of the suggestions supplied by other sites I ended up not having any sound again. :mad: Fearing that I had messed up my basic set up I reloaded Fedora 8 from the beginning all over again and did exact step by step instructions per this site:

Which worked well before but somehow I could not get sound to work again.

In frustration I loaded up Ubuntu Gutsy 7.10 and with in five minutes I have sound in all application. Of course Ubuntu does not use the Pulseaudio server.

I am giving up on the pulseaudio. Way too much trouble!!!
I would like to use Fedora 8 or 9 when it comes out but I tried removing the pulseaudio applications on a clean installation and setting everything to use just the alsa server but failed.

Any suggestions on how to use Fedora 8 or 9 with out pulseaudio?


Simon Bridge 04-22-2008 02:45 AM

You can remove the alsa-plugins-pulseaudio package and enable ESD (or artsd). It's supposed to be a drop-in, but I suspect it may be a couple of releases before it is seamless.

How to disable pulseaudio
Fedora Pulse-audio Howto

All times are GMT -5. The time now is 10:19 AM.