-   Linux - Hardware (
-   -   No sound from old games (OSS) OR OSS-sound to wrong soundcard (

pingu 02-15-2013 12:42 PM

No sound from old games (OSS) OR OSS-sound to wrong soundcard
So I finally ditched my old, lovely Debian Lenny w kde 3.5 :'-(
Now I'm going for Linux Mint or LMDE, both with Mate. (Both behave exactly the same here.)

32-bit systems, Intel Pentium Dual_Core (64 bit capable)
My mobo has built-in sound, also my graphics card (Nvidia GT218) has sound via HDMI.
Both these use hda-intel.

00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)

First I had PulseAudio and Alsa, with oss-compat. <-- (First thing I fail to understand, why both Alsa AND Pulseaudio??)
Also I installed alsa-oss, didn't change anything.

Normal sound works fine, but when I start my old games (CivCTP, RT2 & smac / Alien Crossfire) there is no sound. However, there's also NO complaint about "no /dev/dsp" or similar when I start them from terminal!?
So I don't know if OSS sound doesn't work, or if it is directed to wrong soundcard? I have nothing I can connect to hdmi-port, so can't check that way.
I can't blacklist driver for one card as they both use the same.

Now sound is the one thing I never really have managed to understand, making it quite difficult for me to troubleshoot.

I tried selecting sound ouput via gnome-control-center and via pavucontrol - both seems to do the same thing, none has any settings specific for OSS.

I tried starting my games using some pulseaudio tools:

#pacat /dev/urandom > padsp | /usr/local/spel/smac/smacx
#pacat /dev/urandom | /usr/local/spel/smac/smacx
#padsp /usr/local/spel/smac/smacx

Created a file /usr/local/bin/sx:

export LD_PRELOAD=/usr/lib/i386-linux-gnu/

Nothing works, no error messages. Tried debugging mode whereever I could, nothing.
However, "pacat /dev/urandom > padsp" alone gave sound - well actually noise, like an untuned radio.

I then removed pulseaudio and installed OSS4 - still no difference!

Now I just don't know what to do, any help much appreciated!

pingu 02-16-2013 07:19 AM

I dragged my 'puter to the TV, plugged in HDMI.
Seems there is no way I can get sound out via hdmi, not regular sound also no sound from my old games.
So one question answered, now remains "How get sound from my old games?"
I reinstalled PulseAudio & a bunch of other sound-related stuff, disabled hdmi-soundcard but still no sound in my games.
(apt-get install mate-media-pulse pulseaudio pulseaudio-utils paman asoundconf-gtk paprefs pavucontrol pulseaudio-module-raop pulseaudio-esound-compat)

All times are GMT -5. The time now is 01:06 AM.