-   Linux - Hardware (
-   -   No sound from external speakers in Fedora 8 (laptop speakers ok) (

openSauce 03-01-2009 04:52 PM

No sound from external speakers in Fedora 8 (laptop speakers ok)

My Toshiba Satellite Pro A200 running Fedora 8 continues to play sound out of the laptop speakers when external speakers are plugged in (and no sound out of the external). What can I do to diagnose/fix this?

Extra info:

~$ /sbin/lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
~$ uname -r

Iltbreg 03-02-2009 08:41 PM


did you check in Volume Control to see if this wasn't simply disabled?

openSauce 03-02-2009 09:19 PM

Didn't actually notice it existed - used to the windows way of just plugging the speakers in. But now that I've found it, it doesn't appear to be disabled. Volume Control lists 3 non-capture devices in the Change Device menu, I'm not sure which one I should be looking at, but I've set all volumes to maximum and it hasn't changed anything.

tredegar 03-03-2009 09:11 AM

I had a similar problem once. I fixed it by R-clicking the speaker Icon -> Select Master channel
This needed to be set to "Front". Then everything worked as expected. YMMV.

richardash1981 03-03-2009 11:06 AM

In most of these laptop sound chipsets there isn't a direct link between the bit that senses something plugged in to the output jack and the bit which controls where the sound comes out. So the "windows" behaviour of switching the sound when the external speakers are plugged in depends on the drivers linking the two bits together.

It is possible to get the ALSA drivers in the kernel to do the same job, i.e. sense the headphone jack and re-route the audio. This is implementation-dependent however, so you will need to pass the correct options to the kernel module (snd-hda-intel) to tell it what hardware you actually have. This will probably be some variant of model="something", you need to look for information related to your laptop model to find out what to use, or use modinfo to find out all the options and try them all in turn.

openSauce 03-08-2009 09:29 AM


Originally Posted by tredegar (Post 3463358)
I had a similar problem once. I fixed it by R-clicking the speaker Icon -> Select Master channel
This needed to be set to "Front". Then everything worked as expected. YMMV.

Was that in Gnome or KDE? I don't get a Select Master Channel option when I right-click on the Gnome speaker icon.

@richardash: Let me see if I've understood you right. Below is the output of /sbin/modinfo snd-hda-intel. I've bolded the 'model' line, but it doesn't seem to give any options.


filename:      /lib/modules/
description:    Intel HDA driver
license:        GPL
alias:          pci:v000010DEd00000AC3sv*sd*bc*sc*i*
alias:          pci:v000010DEd00000AC2sv*sd*bc*sc*i*
alias:          pci:v000010DEd00000AC1sv*sd*bc*sc*i*
alias:          pci:v000010DEd00000AC0sv*sd*bc*sc*i*
alias:          pci:v000010DEd00000777sv*sd*bc*sc*i*
alias:          pci:v000010DEd00000776sv*sd*bc*sc*i*
alias:          pci:v000010DEd00000775sv*sd*bc*sc*i*
alias:          pci:v000010DEd00000774sv*sd*bc*sc*i*
alias:          pci:v000010DEd000007FDsv*sd*bc*sc*i*
alias:          pci:v000010DEd000007FCsv*sd*bc*sc*i*
alias:          pci:v000010DEd0000055Dsv*sd*bc*sc*i*
alias:          pci:v000010DEd0000055Csv*sd*bc*sc*i*
alias:          pci:v000010DEd0000044Bsv*sd*bc*sc*i*
alias:          pci:v000010DEd0000044Asv*sd*bc*sc*i*
alias:          pci:v000010DEd000003F0sv*sd*bc*sc*i*
alias:          pci:v000010DEd000003E4sv*sd*bc*sc*i*
alias:          pci:v000010DEd00000371sv*sd*bc*sc*i*
alias:          pci:v000010DEd0000026Csv*sd*bc*sc*i*
alias:          pci:v000010B9d00005461sv*sd*bc*sc*i*
alias:          pci:v00001039d00007502sv*sd*bc*sc*i*
alias:          pci:v00001106d00003288sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA00sv*sd*bc*sc*i*
alias:          pci:v00001002d0000960Csv*sd*bc*sc*i*
alias:          pci:v00001002d00007919sv*sd*bc*sc*i*
alias:          pci:v00001002d0000793Bsv*sd*bc*sc*i*
alias:          pci:v00001002d00004383sv*sd*bc*sc*i*
alias:          pci:v00001002d0000437Bsv*sd*bc*sc*i*
alias:          pci:v00008086d0000293Fsv*sd*bc*sc*i*
alias:          pci:v00008086d0000293Esv*sd*bc*sc*i*
alias:          pci:v00008086d0000284Bsv*sd*bc*sc*i*
alias:          pci:v00008086d0000269Asv*sd*bc*sc*i*
alias:          pci:v00008086d000027D8sv*sd*bc*sc*i*
alias:          pci:v00008086d00002668sv*sd*bc*sc*i*
depends:        snd-pcm,snd-page-alloc,snd,snd-hwdep
vermagic: SMP mod_unload
parm:          power_save:Automatic power-saving timeout (in second, 0 = disable). (int)
parm:          index:Index value for Intel HD audio interface. (int)
parm:          id:ID string for Intel HD audio interface. (charp)
parm:          model:Use the given board model. (charp)
parm:          position_fix:Fix DMA pointer (0 = auto, 1 = none, 2 = POSBUF, 3 = FIFO size). (int)
parm:          probe_mask:Bitmask to probe codecs (default = -1). (int)
parm:          single_cmd:Use single command to communicate with codecs (for debugging only). (bool)
parm:          enable_msi:Enable Message Signaled Interrupt (MSI) (int)
parm:          power_save_controller:Reset controller in power save mode. (bool)
parm:          enable:bool

I added the line

options snd-hda-intel model=auto
to /etc/modprobe.conf, since I vaguely remember reading that somewhere as a fix for this, then ran modprobe snd-hda-intel (no output, not sure if that's what I was meant to do), but the external speakers are still not working.

The machine is a Toshiba Satellite Pro A200, but that page doesn't have any info on the soundcard.


Originally Posted by richardash1981
you need to look for information related to your laptop model to find out what to use

What info am I looking for exactly? A soundcard model number?

richardash1981 03-09-2009 05:10 PM

Google for
Toshiba Satellite Pro A200 snd-hda-intel
provides a reasonable set of information. suggests that model=levono may be the right one, others mention model=laptop.

Both of those seem worth trying. To see if it has worked, you will need to do

modprobe -r snd-hda-intel
and then

modprobe snd-hda-intel
in order to unload and reload the driver for the new option to take effect. When trying out, you can also do

modprobe snd-hda-intel model=foo
to specify options as a one-off on the command line.

openSauce 03-15-2009 03:48 PM

Neither model=lenovo nor model=laptop worked unfortunately. Incidentally I had to reboot each time to try these options, as I couldn't unload the driver:


$ sudo /sbin/modprobe -r snd_hda_intel
FATAL: Module snd_hda_intel is in use.

If anyone can suggest a way round this that might be handy. lsmod reports that the module is in use by "6" (6 what? other modules?), but doesn't say what they are.


$ /sbin/lsmod | grep snd_hda_intel
snd_hda_intel        361833  6
snd_pcm                80201  3 snd_hda_intel,snd_pcm_oss
snd_page_alloc        16465  2 snd_hda_intel,snd_pcm
snd_hwdep              16073  1 snd_hda_intel
snd                    60137  18 snd_hda_intel,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep

In any case, if I can't guess what option to use the above may be moot. The link in your last post described another solution someone found:


Originally Posted by 3dOptics
I was having the same problem with my sager np2090 in Ubuntu Gusty. I fixed it by going to System, Preferences, Sound, and under "Default mixer tracks" click PCM. (The reason to do this is so that PCM will control the volume for both front and headphones.) Then close the window. Now double click on the sound icon in the system tray, then from the edit menu, click on preferences, check "off-hook", then close. Now a tab labelled "switches" will be displayed, click it and check "off-hook". On the "playback" tab, max out the volume on headphones and front. Pressing the volume keys on your keyboard should slide up and down the PCM slider. Now if you plug in your headphones your system speakers will mute, unplug them and your system speakers will turn back on. Dont move the front slider up or down when you have headphones plugged in because it will turn on the system speakers while you are using your headphones. Only control volume with the PCM slider or the volume keys on your keyboard.

I've tried checking "off-hook" in the switches tab, but it doesn't stay checked when I close the preferences dialog and open it up again. Does anyone know what the problem is there?

All times are GMT -5. The time now is 04:59 AM.