LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   No sound, Asus VX1 Laptop - AD1986A (https://www.linuxquestions.org/questions/linux-hardware-18/no-sound-asus-vx1-laptop-ad1986a-590843/)

BeePee007 10-10-2007 01:59 PM

No sound, Asus VX1 Laptop - AD1986A
 
Hello,

I'm new converting from Windows to PClinuxOS:

I have a problem with my laptop:
Initially I managed to get the sound card to work but when I first tried to play something (mp3) with Amarok the sound went dead.
I managed once to get the sound back by runing alsaconf but next time I tried Amarok the sound died again and won't come back online anymore.

I ran the "ALSA Information Script" and the results are here.

Any help would be much appreciated. Thanks

Simon Bridge 10-11-2007 11:12 PM

Your sound went dead on attempting to play an mp3 file? You have previously been able to play this mp3 file? (Or other mp3 files?) Now you have no sound? Only system sounds?

Obvious things to try:

alsamixer (check that output is not muted)

Another player (mplayer say) in CLI. Watch the messages.

try playing open formats - ogg/vorbis, say.

You seem to have the correct driver loaded. Perhaps it is playing only to the wrong output or at the wrong volume.

BeePee007 10-12-2007 05:34 AM

Hello,

Thanks you helped me a lot by looking over my config. I start to think this might be a hardware or hardware compatibility issue.

Ok, here is the problem in some more detail:

A while back I tested Kunbuntu but never got any sound to work on this laptop. Then I lost all networking on it and moved to PClinuxOS which I like a lot better.

I found in order to get the sound working I had to upgrade the kernel. Did that and had sound: system sounds, could play music and watch video via the browser, could play DVDs, etc. but as soon as I opened Amarok the sound died = no more sound whatsoever (any and all of the above). I restarted alsa and the sound was back, opened Amarok => no sound, restarted alsa but the sound didn't come back this time. Rebooted and the sound came back, started Amarok => sound gone, restarted alsa, rebooted but no more sound at all.

Yesterday, I downloaded Mandrivia 2008 and booted from the live CD => it played the system sound perfectly. [Unfortunately, I didn't test Amarok]. Rebooted PClinuxOS => no sound. Booted again Mandrivia live CD => no sound.

I have tried Amarok with mp3 and web radio and it looks like the sound died as soon as Amarok started up. Booting into windows => sounds works perfectly.

I have seen somewhere that disabling the modem in the BIOS might help - unfortunately I have no such option in the BIOS of my laptop. :(

I have now found out as well why I lost the network in my Kubuntu test: If the laptop becomes really warm, after running for several hours, booting up linux (any distro, live CD or installed, several kernels) there is no more network, neither Lan nor Wlan. Booting into Windows everything works. Letting the laptop cool down and booting Linux => network works.

Looking at the way it works in Linux I would suspect some faulty hardware but why does it work in Windows? We have two identical laptops in the company and as soon as my colleague is back from his business trip I will test his laptop to see if I can reproduce the same on his.

Simon Bridge 10-12-2007 05:50 PM

Looks like ACPI may be responsible.

Which laptop is this? (Can you locate your specs online?)

Check your BIOS for "advanced" ACPI stuff and shut them down.
BIOS can sometimes switch components (like network) off when it thinks it needs to (Like if the laptop is hot and/or the OS is not windows). The firmware is compensating for windows.

Then we want to look at your boot options - this will be on the kernel line in /boot/grub/menu.lst

Many laptops need noapic nolapic in there.

Have you tried another player since? Other codecs? Say... boot the kubuntu live, and try playing the example files. If they play, check the configuration like before. Then you can compare your working config with the non-working.

BeePee007 10-13-2007 04:35 PM

Many thanks for helping.

I start getting the feeling that the sound problem could be thermic as well. Had some sound again and it went away on its own after a some time while playing various video formats from the web (youtube, etc.).

Just booted the perfectly cold laptop and system sound came on during login; searched around for a file mine for about 2 minutes; tested sound => gone. Will try in the morning if Amarok plays mp3 right away upon login.

The specs to the Asus VX1-5E008P-A can be found here

BIOS - have latest: 206 - has nothing about ACPI, actually the BIOS has very little options - including 'Advanced Options'. (If you want I can post some screen shots of the BIOS pages).

Tried playing with Grub menu: booted with "acpi=off noacpi nolacpi": result was the same except the bluetooth went down. Next booted with "acpi=off noacpi": result was the same but bluetooth worked again.

Next week I'll have access to the second VX1 and will test if it has the same issues.

Simon Bridge 10-13-2007 06:29 PM

Quote:

I start getting the feeling that the sound problem could be thermic as well.
Me too... something is switching your soundcard off.

Usually, noacpi OR acpi=off (not at the same time) will run your fan continuously. If you still get overheating in those conditions, then the sound-card is probably broken. But then, it should have the same issue in windows. Do you have the same problem running live?

Quote:

noacpi nolacpi
That's, noapic nolapic (watch the spelling).

Possibly you need to reset the thermal zones.

BeePee007 10-14-2007 07:05 AM

Live Distros: To play sound at all I need a recent kernel thus older live CDs don't work. The only working one I have now is 'Mandrivia 2008' which plays sound sometimes and sometimes not. I think it has to do with the initial temperature of the laptop since the CD boot takes a lot longer than booting from HD.

This morning I booted up the cold laptop and as soon as the system welcome sound plaid I opened up Amarok and it plaid the mp3 song perfectly. I added an entire playlist and it kept playing. I started a youtube movie while Amarok was playing and it plaid sound, so I quit Amarok while watching and listening to youtube, returned to Amarok before the movie ended, tried all kinds of things I could think of: result I did have sound for about 2 hours but just as long as I played continuously. As soon as I stopped playing sound for a few seconds: now it is dead again.

So this IS definitely a thermal issue! But only affecting Linux and not windows.

Next I will test extensively the second laptop and check if I can reproduce the same on that one that one I doubt that it is faulty hardware. But where can this issue come from and why is windows not making any problems.

Oh and I will try those boot option some more.

Quote:

Possibly you need to reset the thermal zones.
How do I do that?

Many thanks for your patience with me ;)

BeePee007 10-14-2007 08:06 AM

OK, I played around with the various boot options and found the one that worked:

Code:

title linux 2.6.22.9
kernel (hd0,4)/boot/vmlinuz-2.6.22.9.tex1 BOOT_IMAGE=linux_2.6.22.9 root=/dev/hda5 nolacpi acpi=on splash=silent vga=788
initrd (hd0,4)/boot/initrd-2.6.22.9.tex1.img

Had tried all of these:

Code:

title linux 2.6.22.9.av acpi=off
kernel (hd0,4)/boot/vmlinuz-2.6.22.9.tex1.av BOOT_IMAGE=2.6.22.9.tex1.av root=/dev/hda5 acpi=on splash=silent vga=788 acpi=off
initrd (hd0,4)/boot/initrd-2.6.22.9.tex1.av.img

title linux 2.6.22.9.av noacpi nolacpi
kernel (hd0,4)/boot/vmlinuz-2.6.22.9.tex1.av BOOT_IMAGE=2.6.22.9.tex1.av root=/dev/hda5 acpi=on splash=silent vga=788 noacpi nolacpi
initrd (hd0,4)/boot/initrd-2.6.22.9.tex1.av.img

title linux 2.6.22.9.av noacpi
kernel (hd0,4)/boot/vmlinuz-2.6.22.9.tex1.av BOOT_IMAGE=2.6.22.9.tex1.av root=/dev/hda5 acpi=on splash=silent vga=788 noacpi
initrd (hd0,4)/boot/initrd-2.6.22.9.tex1.av.img

title linux 2.6.22.9.av  nolacpi
kernel (hd0,4)/boot/vmlinuz-2.6.22.9.tex1.av BOOT_IMAGE=2.6.22.9.tex1.av root=/dev/hda5 acpi=on splash=silent vga=788  nolacpi
initrd (hd0,4)/boot/initrd-2.6.22.9.tex1.av.img

title linux 2.6.22.9.av acpi=off noacpi nolacpi
kernel (hd0,4)/boot/vmlinuz-2.6.22.9.tex1.av BOOT_IMAGE=2.6.22.9.tex1.av root=/dev/hda5 acpi=on splash=silent vga=788 acpi=off noacpi nolacpi
initrd (hd0,4)/boot/initrd-2.6.22.9.tex1.av.img

title linux 2.6.22.9.av acpi=off noacpi
kernel (hd0,4)/boot/vmlinuz-2.6.22.9.tex1.av BOOT_IMAGE=2.6.22.9.tex1.av root=/dev/hda5 acpi=on splash=silent vga=788 acpi=off noacpi
initrd (hd0,4)/boot/initrd-2.6.22.9.tex1.av.img

title linux 2.6.22.9.av acpi=off  nolacpi
kernel (hd0,4)/boot/vmlinuz-2.6.22.9.tex1.av BOOT_IMAGE=2.6.22.9.tex1.av root=/dev/hda5 acpi=on splash=silent vga=788 acpi=off  nolacpi
initrd (hd0,4)/boot/initrd-2.6.22.9.tex1.av.img

but only the one with just nolacpi worked for me. Even the network worked on the hot laptop. But it only lasted for about half an hour. Now it is all dead again :( I was a bit too fast in my happyness... :o

I tried to reboot with nolacpi on or off but the problem remains. All i can do now is to check the other laptop.

Aaaaarrrrrrgggggghhhhhhh :( :( :(

But still many many thanks for the help and patience with me :D

BeePee007 10-15-2007 05:07 AM

OK, tested laptop 2 and it is even worse: can't get it play any sound.

Started the cold laptop with the Mandrivia 2008 live CD, no sound. Started the live CD with option "nolacpi" and "nolacpi acpi=on", it wouldn't even start X but just hang there.

Next pulled out the HD of laptop1 and put it into laptop 2.
Booted PClinuxOS from my HD both with/without "nolacpi", but no sound.

Since this problem persists on any distro with both identical hardware latops and with windows it works, I come to the conclusion that there is a hardware compatibility issue with this laptop model. :(

Simon Bridge 10-16-2007 02:55 PM

Quote:

but only the one with just nolacpi worked for me.
It is also the only one in your list with acpi=on. You havn't been careful wuth your variables. I also see that you didn't try "noapic nolapic".

When you boot noacpi, do the fans run continuously? At all?

You could also try acpi=force.

Thermal zones are changed something like:
echo -n "65:60:50:55:50:45" > /proc/acpi/thermal_zone/THRM/trip_points

BeePee007 10-23-2007 06:34 AM

OK I have tried all possible permutation of "acpi=on", "acpi=off", "acpi=force" with " ", "noapic", "nolapic", "noapic nolapic": none plays music, none makes the fan run continuously, all "acpi=off" plus some "noapic" and "noapic nolapic" prevent bluetooth from working.

I tried "echo -n "65:60:50:55:50:45" > /proc/acpi/thermal_zone/THRM/trip_points" as root
and got
"-bash: echo: write error: Invalid argument"
The path exists on my installation and trip_points is an Empty Document.

Will have to look further...

BeePee007 11-01-2007 08:54 PM

Finally solved!!!!!!!

Created a /etc/modprobe.d/options:
Code:

options snd-hda-intel model="3stack"
rebooted

That was all.


Did some more testing:

Code:

# options snd-hda-intel model="auto" # no go
# options snd-hda-intel model="asus" # no go
# options snd-hda-intel model="laptop" # works
# options snd-hda-intel model="laptop_automute" # no go
# options snd-hda-intel model="3stack" # works
# options snd-hda-intel model=auto # no go
# options snd-hda-intel model=asus # no go
options snd-hda-intel model=laptop
# options snd-hda-intel model=laptop_automute # no go
# options snd-hda-intel model=3stack # works

As you can see I have 2 models that work and in my case the use of "" didn't play any role.

Maybe these can give you geeks out there some hints on how to make your setup work. From what Google got me: a lot of poeple got it to work using "options snd-hda-intel model=<<name>>" where <<name>> is the name of the manufacturer of their laptop or motherboard.

This all seems only to apply to Intel on board sound chips!

GrueMaster 11-02-2007 10:23 PM

Sorry for not seeing this earlier. Did you try "model=laptop-eapd"? I have an Asus Z62F, and like all of the other Asus laptops currently supported (yours isn't in the driver yet), they need the eapd switch (external amp power). The reason you may be seeing on again/off again behavior could be acpi shutting down the audio through eapd.

Let me know if that model works and I'll get it added to the driver for the next alsa release.

Tobin

BeePee007 11-03-2007 02:30 PM

Thanks GrueMaster,

"model=laptop-eapd" gives no joy > no sound.

Been on "model=laptop" all day now > it works without any problems

Tested model="3stack" for a short time only > seemed to work

All other combinations > no sound.

So regarding sound I'm happy now. Hope this info helps for the development.

Many thanks for all the answers :)

GrueMaster 11-03-2007 03:49 PM

Ok, I'll add it as a laptop. Here's the patch, if you want to add it to your driver.

Code:

diff -r 3e1a17f8baca pci/hda/patch_analog.c
--- a/pci/hda/patch_analog.c    Wed Oct 31 17:36:20 2007 +0100
+++ b/pci/hda/patch_analog.c    Sat Nov 03 12:47:36 2007 -0700
@@ -841,6 +841,7 @@ static struct snd_pci_quirk ad1986a_cfg_
        SND_PCI_QUIRK(0x1043, 0x1297, "ASUS Z62F", AD1986A_LAPTOP_EAPD),
        SND_PCI_QUIRK(0x1043, 0x12b3, "ASUS V1j", AD1986A_LAPTOP_EAPD),
        SND_PCI_QUIRK(0x1043, 0x1302, "ASUS W3j", AD1986A_LAPTOP_EAPD),
+      SND_PCI_QUIRK(0x1043, 0x1443, "ASUS VX1", AD1986A_LAPTOP),
        SND_PCI_QUIRK(0x1043, 0x1447, "ASUS A8J", AD1986A_3STACK),
        SND_PCI_QUIRK(0x1043, 0x817f, "ASUS P5", AD1986A_3STACK),
        SND_PCI_QUIRK(0x1043, 0x818f, "ASUS P5", AD1986A_LAPTOP),



All times are GMT -5. The time now is 01:04 AM.