LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 08-02-2004, 07:33 AM   #1
Creak
Member
 
Registered: Feb 2004
Distribution: debian
Posts: 187

Rep: Reputation: 30
No NVIDIA-GLX modules ???


Hi!

I don't have the NVIDIA-GLX modules when i do a xdpyinfo. O
Is there a solution ?

Thx
 
Old 08-02-2004, 08:11 AM   #2
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 380Reputation: 380Reputation: 380Reputation: 380
make sure you have this line in your x configuration file:

Load "glx"
 
Old 08-02-2004, 08:21 AM   #3
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,991

Rep: Reputation: 76
What kind of graphics card do you have? You may need to download and install the accelerated graphics drivers from nvidia's web-site (nvidia rather than the default nv that most distros install).
 
Old 08-02-2004, 09:23 AM   #4
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 380Reputation: 380Reputation: 380Reputation: 380
which you can get here:

http://www.nvidia.com/object/linux.html
 
Old 08-02-2004, 10:30 AM   #5
Creak
Member
 
Registered: Feb 2004
Distribution: debian
Posts: 187

Original Poster
Rep: Reputation: 30
It seems to be good for my XFree86-4 file:
Quote:
grep Load /etc/X11/XF86Config-4
# Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
And i already have the nVidia 6106 driver... in facts it's since i've installed them that i have this problem.

Just to know, if you have the 6106 driver, can you test the output of xdpyinfo please ? do you have the NVIDIA-GLX module ?

Thx
 
Old 08-02-2004, 12:59 PM   #6
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,991

Rep: Reputation: 76
Yes, I do have the nvidia-GLX extension. I get this:
Code:
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
        compiled for 4.0.2, module version = 1.0.5336
        Module class: XFree86 Server Extension
        ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
What do you have in the Device section? You need
Code:
        Driver  "nvidia"
and not
Code:
        Driver  "nv"
…you should also see the nvidia logo on the display when X starts up if it's installed right.

Also, check /var/log/XFree86.0.log to check which config file it's loading (XF86Config vs XFree86Config-4)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia legacy driver and nvidia-glx questions darkleaf Linux - Software 6 06-27-2005 02:42 PM
How to install glx and GLcore modules? linx win Debian 5 02-07-2005 02:57 AM
nvidia glx Amir21 Linux - Newbie 2 12-01-2004 12:03 PM
NVIDIA-GLX and General NVIDIA Problems g452 Slackware 7 05-30-2004 02:10 PM
nvidia glx snu Linux - General 4 07-09-2003 02:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration