-   Linux - Hardware (
-   -   No mouse pointer (cursor), mouse does work (

whizz 11-17-2005 01:27 PM

No mouse pointer (cursor), mouse does work. Help me, please!
I've got a strange problem. I have SuSE 9.3 and Windows XP installed on my pc. Now I'm trying SuSE again since a while (I do like Windows a lot :P) and at first my monitor doesn't work in graphical mode. (Solved that... :) (I have a dual monitor, which didn't seem to work well... ). But now I do have graphics (on a single monitor) exept for the mouse pointer. My mouse still works (I do get mouse-over effects) but I dont see a cursor/pointer. Anyone got a solution?

edit: forgot to mention: I have an Microsoft optical mouse, connected by USB.

What I already tried:
- Reboot
- Use the control center to change the mouce cursor theme
- Try another USB port

whizz 11-19-2005 04:09 AM


TeeTee 03-26-2006 07:01 PM

Did you ever determine the problem? Did you need a change to your xorg.conf file? I have a new install of Fedora Core 5 and have the same problem.

I tried:
- reboot
- login as different user
- change the screen resolution -- system-config-display
- selecting a different mouse pointer style
- doing a find from / `find / -type f -name "*mouse*"
- mouseconfig is gone is Fedora C5

Seems like either an X config problem, but I'm not sure.

whizz 03-31-2006 09:15 AM

I've reinstalled SuSE, en then it worked correctly, after installing the NVIDIA driver. (had to start it with SaX2 -t m=0 or something, exact instructions are at

Good Luck

TeeTee 04-02-2006 08:47 PM

I found a Buzilla entry for this problem

Basic Fix in Display portion of xorg.conf
The mouse cursor is "invisible" when HWCursor is enabled:

Option "HWCursor" "on"

Disabling HWCursor makes the mouse cursor visible.
Option "HWCursor" "off"

This fixed it for me. I'm using the open source nv driver rather than the one from nvidia for now. It's working pretty well so I haven't felt like messing with it yet.

shankarLe 04-03-2006 02:27 AM

mouse does not detect or works in redhat ws 4.0
hi all,

I have recently installed redhat 4.0 on my pc which seems to be working good, but the only problem is mouse. mouse was not detected in readhat i have samsung ps/2 mouse and I have windows xp installed on the other partition. mouse works fine on windows xp before installing linux . Now the strage thging is , sometimes mouse does not work even on windows if i directly switch from linuix to windows xp ( restart computer and choose windows xp from the boot loader) so I have to shutdown computer and wait couple of minutes and then boot to xp -- here mouse works fine as it should be.

I followed these steps in linux in order to be able to fix the mouse problem.

# service gpm restart
# chkconfig gpm on

i do not see any mouse configuration window after trying above steps.

Please give me some suggestion or help on this

thank you...

TeeTee 04-04-2006 09:00 PM


you could try

This will probe youre devices and update the xorg.conf file.

Are you sure the mouse is still working? You said you are also having problems with it in Windows now. Do you have another mouse to test out?

All times are GMT -5. The time now is 10:48 AM.