-   Linux - Hardware (
-   -   no mouse and keyboard is detected.... (

aditya_fx 04-08-2004 11:11 AM

no mouse and keyboard is detected....
whenever i start rh9, no mouse or keyboard is detected, it shows the pointer, but of no use, i cannot use it... i cannot type the username, since the keyboard is also idle. i just installed rh9 5days ago. and now these problems.. what should i do?

WhatsHisName 04-08-2004 11:50 AM

aditya_fx: Are you saying that the keyboard/mouse worked initially, but don’t work now? If you are using USB keyboard/mouse, try using PS/2 keyboard/mouse. If the PS/2 keyboard/mouse work, reboot with both USB and PS/2 devices attached and the hardware detection should pick up the USB devices.:)

aditya_fx 04-08-2004 12:35 PM

it worked
the mouse and keyboard worked when i installed rh9, i hav serial mouse, rh9 took the mouse as generic 2button mouse, since the name of my mouse was not included in the list(a4tech wheelworks mouse).
the system suddenly started ignoring the mouse so i rebooted only to know that now my keyboard was also not working.

WhatsHisName 04-08-2004 01:15 PM

aditya_fx: Did you update (up2date) the system or change the hardware configuration just before the failure? The keyboard/system may be freezing because of the mouse problem. Once, I reconfigured the mouse from a 2-button mouse to a wheel mouse and lost control of the mouse (i.e., it got pulled into one corner of the screen).

Try booting without a mouse and then with a different (brand of) mouse, preferably PS/2-based. Also, to rule out a hardware failure problem, try booting into windows (if available) or into DOS using a Win95/98/Me Startup Disk. Also make sure that the serial and PS/2 ports are enabled and properly configured in the BIOS.

Also, if you can boot to “linux rescue” (i.e., start the RHL9 installation and type “linux rescue” when it stops to ask you how to proceed), then you may have a configuration problem. If you can get “linux rescue” running (i.e., no hardware problems) and since you have only been running for a few days, it might be easier to just reinstall RHL9 than to try fixing a configuration problem. Everyone gets lots of experience reinstalling linux in the beginning.:)

aditya_fx 04-08-2004 01:23 PM

thanks for the reply, i will definately try it. the case in my mouse is same, i too was trying to select wheel mouse, when i first had 2 button mouse.

aditya_fx 04-09-2004 03:11 AM

after inserting the bootdisk floppy when i ran linux rescue it went smoothly but again no mouse and keyboard, but the thing i noticed while booting was that linux initializes the mouse and keyboard as USB
"Initializing USB Mouse [OK]"
"Initializing USB Keyboard [OK]"

BrigitteT 04-09-2004 09:13 PM

I have an ABIT BE6 II motherboard and I'm having this exact problem with RH9. In fact, Red Hat is loading up as if I have a USB mouse and keyboard, just as you are describing. Do you by chance have the same board?

I do hope someone has an idea how this can be solved.


aditya_fx 04-09-2004 10:07 PM

jno i dont hav the same motherboard, this kind of problem is a comoon problem on linux irrespective of the motherboard

BrigitteT 04-10-2004 12:05 AM

thnx. I just looked through 300 posts, all of people who are having this problem. And not ONE of those posts had a solution.

That's very strange.

Oh well, thanks anyway!

aditya_fx 04-11-2004 01:31 AM

hey, i got rid of the mous and keyboard prob in rh9, i entered as single user then replaced the XF86Config file with XF86Config.backup and thats it linux took my mouse and keyboard. thanks to all the ppl helping on the net.

BrigitteT 04-11-2004 01:48 AM

Let me make sure I understand. You booted from a CD, at the colon prompt you typed "Linux single". Then what did you do?

Where did the XF86Config.backup file come from?

I am too new to know this. So I' REALLY like your help! I've been at this ALL DAY and now into the next day. :cry:


aditya_fx 04-11-2004 02:13 AM

please read everything...
the XF86Config.backup file is a backup of the file XF86Config
if ur mouse and keyboard were working when u installed rh9 only then u should do the following.

be carefull...
make a note on paper of the following steps
i hope u have grub, coz i edited the lines from grub,
1. when u r at OS selection screen, highlight RedHat option and press 'e',
2. then there will be three lines, highlight the line which describes about kernel,
3. then again press 'e' to edit the line. go to the end of the line and type 'single' after a space
4. then select the line describing root and press 'b', it will start booting.
5. finally at a stage it will stop proceeding further, then type 'su'
6. then give the following commands 'cd /etc/X11'
7. then the command 'cp XF86Config.backup XF86Config'
8. after this the command 'reboot'
it will start again this time it should take the mouse and keyboard...

All times are GMT -5. The time now is 05:38 AM.