LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 02-24-2011, 10:51 PM   #1
LoneWolfBW
LQ Newbie
 
Registered: Feb 2011
Distribution: CentOS 5.5, RHEL 5
Posts: 4

Rep: Reputation: 0
No microphones will record with CentOS 5.5


Good evening,

This is my first post and question, hopefully I will provide as much detail as I can and will follow up with anything needed/requested to help me solve this.

I have just recently installed CentOS 5.5 on a machine given to me from my workplace. It is a Shuttle box, about 4 years old. I have had no major problems thus far, except for this one.

Background:

I first noticed this problem when I installed Skype and wanted to place a call. However, the recipient heard nothing. I verified that I can hear sounds fine, all tests of the speakers work (whether I use speakers or a headset).

I went through various postings and forums to check if I had some settings that needed altered, but so far I have verified everything listed. Here is the computer's sound card information:

(From System > Administration > Sound Card Detection)
Sound Test tab:

Vendor: Silicon Integrated Systems [SiS]
Model: AC'97 Sound Controller
Module: snd-intel8x0

Sound tests are OK.
Device Settings: PCM Device set to SiS SI7012 (alternative is SiS SI7012 - MIC ADC. When I chose this, the playback no longer works.)

Settings tab:

Default Audio Card: Silicon Integrated Systems [SiS] AC'97 Sound Controller
Default PCM Device: SiS SI7012

ALSA Plugins: Disable Specific Card Configuration is NOT checked.

Audio Cards Order: Only my card is listed.

System tab:

ALSA SOund system information:

ALSA Driver version: Advanced Linux Sound Architecture Driver Version 1.0.20
ALSA Lib Package(s): alsa-lib.1.0.17-1.el5
ALSA Utils Package(s): alsa-utils.1.0.17-1.el5

So, at the command line I ran alsamixer.

On the Playback view I verified that <Mic> was at 100% volume. I have run tests with <Mic> both set to Mute for playback and Not Mute. Mic Boost I have run tests with it both muted and active. Mic Select is set to Mic1 which I believe should be the mic-in jack on the front of the Shuttle Box. However I have tested that jack with both Mic1 and Mic2, and the rear mic-in jack with both Mic1 and Mic2.

On the Capture tab, when I first go into alsamixer, CD is set to L-captur and Mic is set to R-capture. I tested that, to no avail. Then I selected Mic as the L-R Captur device. The <Capture> is set to L-R CAPTUR and is at 100%.

Finally, I opened a second command-line and ran the following:

arecord -vv -d 10 test.wav

To run a test second recording. There is supposed to be a visual output of the recording, but I don't see much.

When I run: aplay -vv test.wav I get ten seconds of silence.

As an alternate test, I set the Mic to not mute at playback. As I do this, the headphones do relay a low-level hiss. The recording is silent, BUT I do hear a bit of crackle and static at times.

I should also mention I tested this mike/headset on a Windows box and it does work. I also tested a separate headphones and a standalone mike and get the same results.

Since the sound output seems fine, I am narrowing my issue down to the microphone itself. It's my belief that I just don't have CentOS configured properly, though every page I have checked has the settings I described above.

What am I missing? If I need to give further information, I will gladly, just let me know what to check.

-BW
 
Old 02-25-2011, 03:44 AM   #2
darkduck
Member
 
Registered: Jan 2011
Location: Cyprus
Distribution: Kubuntu, OpenSuSE
Posts: 495

Rep: Reputation: 26
I had similar problem yesterday. Though, not on CentOS, but on Debian. Solved by installing PulseAudio. Maybe that helps
 
Old 02-27-2011, 03:11 PM   #3
LoneWolfBW
LQ Newbie
 
Registered: Feb 2011
Distribution: CentOS 5.5, RHEL 5
Posts: 4

Original Poster
Rep: Reputation: 0
Update:

As a further test, I tried installing CentOS 5.5 on a VM on a different machine. I used a CentOS DVD iso from a different source than the one I used to install the original machine.

Once I configured Alsamixer to have Mic capture, it works. So, it seems like it's been narrowed down to an issue with the soundcard driver on the original machine. I'll keep at it and see if I can find any more specifics.

I'll give Pulse Audio a shot just to eliminate all possibilities, but after what I saw with the install and the VM, I'm definitely leaning towards a driver issue now. I would just reinstall CentOS on the original box from the new ISO source, but I've put so much work into the install that's there now, I really hate to do that except as a last resort.

-BW
 
Old 02-27-2011, 05:48 PM   #4
jlinkels
LQ Guru
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 5,195

Rep: Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042
Do I understand correctly that you have 1 audio devices, the SiS? I haven't checked it but I can hardly believe that SiS uses the Intel 8x0 driver. I haven't a SiS box around here (or at least I don't know which box contains a SiS...) so I can't check, but it might be a good idea to Google for that.

You assumed correctly that arecord can be used as a debugging tool. Use it in 8 bits unsigned mode (U8, I think that is already set as default). When you see streams of 2-3 different characters while talking in the mic, you are seeing noise around zero, which means no sound. You should see screens full of random values, then you have sound. No need to record into a file first.

I assume you are sure you only have one sound device? Check with arecord -l or arecord -L. Study this output anyway, no trace of any capture which is off?

Start with verifying the driver for this chip though.

jlinkels
 
Old 02-28-2011, 04:39 PM   #5
jefro
Moderator
 
Registered: Mar 2008
Posts: 21,134

Rep: Reputation: 3433Reputation: 3433Reputation: 3433Reputation: 3433Reputation: 3433Reputation: 3433Reputation: 3433Reputation: 3433Reputation: 3433Reputation: 3433Reputation: 3433
Consider Fedora instead of Centos maybe. Much better multimedia support in my opinion.
 
Old 03-02-2011, 09:31 PM   #6
LoneWolfBW
LQ Newbie
 
Registered: Feb 2011
Distribution: CentOS 5.5, RHEL 5
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jlinkels View Post
Do I understand correctly that you have 1 audio devices, the SiS? I haven't checked it but I can hardly believe that SiS uses the Intel 8x0 driver. I haven't a SiS box around here (or at least I don't know which box contains a SiS...) so I can't check, but it might be a good idea to Google for that.

You assumed correctly that arecord can be used as a debugging tool. Use it in 8 bits unsigned mode (U8, I think that is already set as default). When you see streams of 2-3 different characters while talking in the mic, you are seeing noise around zero, which means no sound. You should see screens full of random values, then you have sound. No need to record into a file first.

I assume you are sure you only have one sound device? Check with arecord -l or arecord -L. Study this output anyway, no trace of any capture which is off?

Start with verifying the driver for this chip though.

jlinkels
Please bear with me, as I mentioned I am quite new to Linux, and so I'm not used to the methods of doing things as opposed to Windows. But this is how you learn, so.

I checked my sound device as you suggested, and found the following information:

List of CAPTURE Hardware Devices
card 0: SI7012 [SiS SI7012], device 0: Intel ICH [SiS SI7012]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: SI7012 [SiS SI7012], device 1: Intel ICH - MIC ADC [SiS SI7012 - MIC ADC]
Subdevices: 1/1
Subdevice #0: subdevice #0

When I was trying originally to test Skype (which is what brought this about), I saw several options for the Sound Devices. One of them was Default device (default), all the rest referenced the SiS SI7012. They were as follows:

~~~~~~~~~~~~~~~~~~~
SiS SI7012, SiS SI7012 Default Audio Device (default:CARD=SI7012)
SiS SI7012, SiS SI7012 Front Speakers (front:CARD=SI7012, DEV=0)
SiS SI7012, SiS SI7012 IEC958 (S/PDIF) Digital Audio Output (iec958:CARD=SI7012, DEV=0)
SiS SI7012, SiS SI7012 (hw:0,0)
SiS SI7012, SiS SI7012 - MIC ADC (hw:0,1)
hdmi (unknown)
~~~~~~~~~~~~~~~~~~~

When I set it to Default Audio Device, and used Skype's echo test service call to try it, I got ten second of silence on playback. If I set it to MIC ADC, I got an immediate 'ding' and the test call ended.

I went to SiS site, and downloaded the Linux driver for the SiS 7012, but for the time being I think this may be over my head as far as installing it. I attempted to run the installer after untarring the file, and it gave a bunch of coding errors. (No doubt I'm not doing that properly either.) It said installation OK and I rebooted as directed, but nothing has changed either in the SOundcard Detect screen or in the results.

The box is a Shuttle X that I received second-hand from my employer, it's several years old and was replaced recently. So I have no real history or documentation on it, unfortunately.

ADDENDUM: After the driver install, I went back and tried the arecord test as mentioned in my original post. It seems to be working now, after I went into Alsa mixer again and re-set the settings to how they're supposed to be Mic as capture device, and I tested both Mic 1 and Mic 2. Mic 2 NOW seems to work. I can only assume it was in fact the driver all along, since that's the only thing I've changed from my previous attempts.

I can mark this as resolved now, and thank you everyone for your assistance and replies. I really appreciate it.

-BW

Last edited by LoneWolfBW; 03-02-2011 at 09:43 PM.
 
Old 03-02-2011, 09:46 PM   #7
LoneWolfBW
LQ Newbie
 
Registered: Feb 2011
Distribution: CentOS 5.5, RHEL 5
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jefro View Post
Consider Fedora instead of Centos maybe. Much better multimedia support in my opinion.
The reason I'm using CentOS is because that's largely the distro that I have to support at work. The entire reason I'm getting involved here is that I've been tapped to be the secondary administrator for a series of orphaned Linux servers that my department inherited. So I opted to start with CentOS since that's what's mostly in use in these machines (Red Hat Enterprise Server 5.6 in most of them, and CentOS in some others, which is really just the same thing.)

I also have installed Parallels on my Macbook, and created VMs for Ubuntu and Fedora to get familiar with them as well. So far, I've gotten basics worked out on each, including installing an IM client, configuring email, and installing Java and Flash. (Fedora is resisting the Java install, so that's the one snag, but that's another story.)
 
Old 09-26-2011, 08:31 PM   #8
RootAround
LQ Newbie
 
Registered: Oct 2010
Posts: 6

Rep: Reputation: 0
I also had a similar problem. FYI, here are my methods, problems and workarounds. I installed skype_static-2.1.0.47 on Centos 5.7 (32-bits)running on an ASUS K8U-X motherboard.

Installation. I used this Wiki site to download and install Skype. The download site was:
http://download.skype.com/linux/skyp...1.0.47.tar.bz2

The installation steps in the Wiki Site for Centos 5 are:
1. Create a tmp directory inside the opt directory and move the downloaded file to it. I used File Manager to do this.

2. In the opt directory, enter the commands

tar xjvf /tmp/skype_static-2.1.0.47.tar.bz2

This installs skype in the /opt/skype_static-2.1.0.47 directory.

3. Create Links. When I entered these commands I got broken links.

ln -s skype_static-2.2.0.35 skype
ln -s /opt/skype /usr/share/skype
ln -s /opt/skype/skype /usr/bin/skype

I used File Manager to create an link to the /opt/skype_static-2.1.0.47 directory, then renamed it skype (from "link to skype_static-2.1.0.47"), and copied it into the /usr/share and /usr/bin directories.

Sound and Microphone Configuration.

a. The System/Administration/Soundcard_Detection/Sound_test tab has a test for sound and other tabs for sound card configuration. The test should work.
b. The System/Preferences/Sound panel can be used to test the sound. when invoking the Test buttons, a tone should be heard. I heard a tone on every test except the Audio Conferencing/Sound test (but the latter test didn't matter to me).
c. I activated and gave high volume to all 5 entries in the System/Preferences/Volume_Control/Playback tab--and maximum volume to the master and microphone entry. I also checked all items in the System/Preferences/Volume_Control/Playback tab.


Microphone Problem.
I followed instructions on the Alsa and this site to configure sound and the microphone. Entering the linux command:

alsamixer

produces a sound configuration window. Navigation keys are:

left/right arrows. Move laterally between items.
up/down arrows. Adjust item volume (maximize if possible).
Tab. Toggle between Playback, Capture and All modes.
Space Bar. Enables Left-Right Capture for an item, when in Capture mode.
Mouse. Exit window.

According to the above article:

Ensure Capture is enabled on Mic and Capture items.
Ensure maximum volume on Mic boost, Capture and Digital. I couldn't do this for Mic boost or Digital, but I could for Mic. I also maximized Master.

I also had to reduce the number in Channel to 2--this finally got my microphone working.

Testing. After exiting the Alsamixer panel enter:

arecord -vv -d 10 test.wav

then speak into the microphone. Ctrl-C exits.

Then playback by entering:

aplay -vv test.wav

You should hear your voice.

Invoking Skype. Enter

Skype

at the command line. Enter your logonID and Password. The Skype screen shows an 'Echo/Sound Testing Service' icon for testing.

Issues.

1. When exiting Skype, I see 2 messages:

ALSA lib pcm.c:2184snd_pcm_open_noupdate) Unknown PCM null
ALSA lib pcm.c:2184snd_pcm_open_noupdate) Unknown PCM null

Using Ctrl-C gets to a prompt.

2. Alsa configurations can sometimes be lost. I encountered this after CentOS or application crashes without a soft shutdown.

Applications Menu.
I placed Skype there by:

Right-Click the Applications menu and select Edit Menus.
Select New Item.
Enter or browse for these entries:

Name: Skype
Command: /usr/bin/skype/skype
Icon: /usr/bin/skype/icons/[select an icon]

Click Close.

The Icon you selected should appear at the bottom of the Applications menu.
 
Old 11-09-2011, 09:45 PM   #9
Roc.liu
LQ Newbie
 
Registered: May 2011
Location: YanTai.Shandong province.China
Posts: 3

Rep: Reputation: Disabled
Thank you ,vuery useful for me
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Microphones don't work!! Skellz Linux - Laptop and Netbook 65 06-07-2010 06:17 AM
Adjust and test microphones pwabrahams Linux - Hardware 1 12-11-2009 04:49 AM
Any USB microphones that works well in Linux WillingToLikeLinux Linux - Newbie 5 12-20-2008 10:41 PM
dev file for speakers and microphones ashlesha Programming 9 04-11-2007 08:41 PM
Anyone with experience in microphones...... ksoma General 7 09-19-2004 02:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 12:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration