LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 06-01-2005, 08:31 PM   #1
Dark Elf
LQ Newbie
 
Registered: Oct 2002
Distribution: Fedora Core 6
Posts: 18

Rep: Reputation: 0
No medium found: cant mount swap part


I bought a NEC dvd-rw drive and installed it in an external enclosure. Recently i decided i wanted to install it in my new tower. The two other cd drives occupied one cable, while the other cable had only the hdd on it, as master. Due to physical restrictions inside my machine, i had to set the dvd as master and the hdd as the slave on that same cable. Now FD2 boots normally until it needs to mount all the partitions.
I get:

activating swap partitions:
swapon: /dev/hda6: no medium found
blah blah blah cant read superblock

no medium found while trying to open /dev/hda3


Sorry about the blahs but it was a long message about maybe the drive was corrupt and whatnot. Anyway, i dual-boot XP and FD2 with a FAT partition as /dev/hda2.

I never had any problems booting until i installed this dvd drive. I havent tried taking it out because it was such a hassle putting it in. I dont like being defeated by a machine.

If i left out any necessary info let me know and i'll add it.

Thanks
 
Old 06-01-2005, 08:45 PM   #2
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Fedora and Redhat uses labels to mount certain drives. You have to change the fstab and probably the bootloader for the change of device.
 
Old 06-01-2005, 09:03 PM   #3
Dark Elf
LQ Newbie
 
Registered: Oct 2002
Distribution: Fedora Core 6
Posts: 18

Original Poster
Rep: Reputation: 0
my bootloader listed linux as (hd 0,2) and i've changed it to everything imaginable with no positive effect.
How do i access fstab and change it?
 
Old 06-02-2005, 06:54 AM   #4
michaelk
Moderator
 
Registered: Aug 2002
Posts: 20,074

Rep: Reputation: 3371Reputation: 3371Reputation: 3371Reputation: 3371Reputation: 3371Reputation: 3371Reputation: 3371Reputation: 3371Reputation: 3371Reputation: 3371Reputation: 3371
The reason your having problems is drive drive changed locations from hda to hdb assuming they are connected to the 1st IDE controller. hda is now your DVD drive. Fedora does not use a label for the swap partition. You will need to modify the /etc/fstab file to change the drive id from hda to hdb for swap and the FAT32 partitions. You need to be logged in as root to edit files in this directory.

Change:
/dev/hda6 swap swap defaults 0 0
to
/dev/hdb6 swap swap defaults 0 0

Your fstab might not look exactly like the above. Change the FAT32 partitions from hda to hdb too.

Last edited by michaelk; 06-02-2005 at 07:04 AM.
 
Old 06-02-2005, 02:15 PM   #5
Dark Elf
LQ Newbie
 
Registered: Oct 2002
Distribution: Fedora Core 6
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks for the help.
I changed fstab from hda6 to hdb6. Now i no longer get an error message regarding that. Only:

fsck.ext3/dev/hda3

There's no mention of hda3 in fstab. i dont know what file to change now.



Last edited by Dark Elf; 06-02-2005 at 11:52 PM.
 
Old 06-02-2005, 11:52 PM   #6
Dark Elf
LQ Newbie
 
Registered: Oct 2002
Distribution: Fedora Core 6
Posts: 18

Original Poster
Rep: Reputation: 0
OK, i tried to figure out what file the critical reference to /dev/hda was in. I looked in mtab and lilo.conf, among others. i corrected the entry in lilo.conf, but to no effect. I really need help finding out where to look.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot mount CDROM - No Medium Found rksanders Debian 25 02-15-2011 04:04 PM
mount : No medium found Alwyn Linux - Newbie 3 01-11-2005 12:24 AM
burning, ide-cd and "mount: No medium found" Creak Debian 3 09-18-2004 05:38 AM
unable to mount USB camera: "No medium found" in Fedora Core 2 meonkeys Fedora 0 05-20-2004 02:35 PM
CD ROM mount error: "no medium found"????? RonRussell Linux - Hardware 8 07-01-2002 12:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration