LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 08-25-2006, 07:12 PM   #1
Nilium
LQ Newbie
 
Registered: Sep 2004
Distribution: Ubuntu
Posts: 6

Rep: Reputation: 0
No image with Logitech QC 4000 (PWC)


Hi all,

I use Gentoo Linux, 2.6.15-gentoo-r1 kernel, and usb-pwc-re 10.0.12_rc1 driver for my Logitech Quickcam Pro 4000. Using gqcam or camstream, all I'm getting is a solid gray screen. I tried to enable the pwc driver as module and built in, as well as v4l support. I've even tried the kernel's driver for the Phillips chipset, but no luck. Has anybody gone through the same situation? Any help would be much appreciated.

-- Nilium


*** lsusb ***
Bus 003 Device 003: ID 046d:08b2 Logitech, Inc. QuickCam Pro 4000


*** dmesg ***
pwc Failed to set LED on/off time.
pwc type = 740
pwc type = 740
pwc set_video_mode(176x144 @ 10, palette 15).
pwc decode_size = 1.
pwc Using alternate setting 1.
pwc type = 740
pwc type = 740
pwc set_video_mode(160x120 @ 10, palette 15).
pwc decode_size = 1.
pwc Using alternate setting 1.
pwc set_video_mode(640x480 @ 10, palette 15).
pwc decode_size = 5.
pwc Using alternate setting 6.
pwc Closing video device: 45 frames received, dumped 0 frames, 0 frames with errors.
 
Old 08-25-2006, 09:19 PM   #2
Nilium
LQ Newbie
 
Registered: Sep 2004
Distribution: Ubuntu
Posts: 6

Original Poster
Rep: Reputation: 0
Ok I fixed it myself. I needed the patch, which can be downloaded from the driver's homepage.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
quick cam pro 4000 and pwc install errors sleepindawg Debian 11 08-31-2006 10:21 AM
Logitech quickcam Pro 4000 gives gray image henro Fedora 5 07-10-2006 05:52 PM
Problem with ivtv drivers - pvr 350 and logitech webcam 4000 pro pwc drivers sdavis3 Linux - Hardware 13 03-11-2006 09:34 AM
PWC driver in Mandrake 10 (Philips Toucam II, Logitech Quickcam Pro 4000, etc.) make Mandriva 0 06-19-2004 04:03 AM
Help installing PWC Modules for Logitech Quickcam 4000 pro Techweenie1 Slackware 1 08-25-2003 11:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 01:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration