-   Linux - Hardware (
-   -   No boot of PuppyLinux on USB pendrive (

d1s4st3r 07-21-2004 12:49 PM

No boot of PuppyLinux on USB pendrive
Hi everyone.
I have a 128 MB USB pendrive partitioned like this: one 64 MB FAT32 partition with my all data, university exercises, music and so on, and another 64 MB FAT16 "bootable" partition with PuppyLinux.
The partitions are "/dev/sda1" and "/dev/sda2" then.
Here the commands I tried to install PuppyLinux:

# mount -o loop cd-puppy.iso /mnt/foo
# mount /dev/sda2 /mnt/pendrive
# cp /mnt/foo/* /mnt/pendrive
# cd /mnt/pendrive
# du -ah
2.0K    ./
49M    ./image.gz
10K    ./isolinux.bin
2.0K    ./isolinux.cfg
872K    ./vmlinuz
2.0K    ./syslinux.cfg
8.0K    ./ldlinux.sys
49M    .
# cp isolinux.cfg syslinux.cfg
# cd ..
# umount pendrive/
# syslinux /dev/sda2

Well, everything seemed to work fine, but when I tried to boot with the USB pendrive (I have an Asus P4C800 with USB boot support, and I put USB before anything else in the boot sequence), my USB pendrive had been totally ignored and my Debian booted as always.
So I thought the bootloader (SysLinux) may not work if installed on the second primary partition (/dev/sda2), so I tried with:

# syslinux /dev/sda
/dev/sda: filesystem type "  FAT16" not supported

And now I don't really know what can I do... expecially because the file "syslinux.cfg" is needed by SysLinux to get installed.
This file contains this:

# cat syslinux.cfg
default vmlinuz root=/dev/ram0 initrd=image.gz
append ramdisk_size=61440 initrd_archive=ext2 PFILE=pup080-none-262144

What I need is to have "/dev/sda1" with my all data, and "/dev/sda2" with PuppyLinux, but "/dev/sda" must be bootable by the BIOS!!!
What can I do to have my USB Linux distro working?
Thanks to all you guys!

All times are GMT -5. The time now is 04:41 PM.