-   Linux - Hardware (
-   -   no audio in any software, any OS (

qajaq 07-04-2012 12:14 PM

no audio in any software, any OS
I've recently installed Kubuntu 12.04 on one of my desktop computers, dual-booted with Windows 7. Both operating systems were newly installed after I replaced the machine's motherboard and CPU. For the most part, all is going well; the only problem I've run into (so far) is that I'm getting no audio to the speakers. I've tried from both OSes. I've tried from Amarok, mplayer, Dragon Player, and Windows Media Player. I've tried web-based video, mp3 files, .mpg files, .wmv files, and DVDs. No sound to the speakers (or to headphones).

I've installed numerous different operating systems, including several Windows versions and several Linux distributions, on a variety of machines, and I'm comfortable using the Linux command-line, but I don't have any experience with audio issues. Heretofore, the audio has simply worked.

Any ideas where I should look for a solution?

NyteOwl 07-04-2012 12:35 PM

Well, if you haven't already, the first palce I'd look if it doesn't work for anything is to see if it's turned off in a BIOS option.

If that's not the case, then run dmesg and look to see if the audio device is being picked up.

Further troubleshooting really would depend on that info. The fact that is doesn't work in any OS usually points to a BIOS or hardware problem. Lack of proper driver/modules comes in second.

MisterBark 07-04-2012 01:42 PM

could you give us the output for :
lspci -v

qajaq 07-04-2012 03:01 PM

NyteOwl, I re-booted and looked at the BIOS options, but I didn't see anything that looked like an option to turn audio on/off. I also ran dmesg (which is new to me) and got a huge output -- don't know what to look for in that.

MisterBark, I ran lspci -v and got another huge output, though not as big as from dmesg, and nicely sub-divided and labeled. Here's the output that's marked as related to audio:


00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
Subsystem: ASUSTeK Computer Inc. Device 840b
Flags: bus master, fast devsel, latency 0, IRQ 43
Memory at fe8f8000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [100] Virtual Channel
Capabilities: [130] Root Complex Link
Kernel driver in use: snd_hda_intel
Kernel modules: snd-hda-intel
(If you want the whole 152 lines, let me know and I'll post them.)

Running lsmod delivered 48 lines, as follows:


Module Size Used by
rfcomm 47604 0
bnep 18281 2
bluetooth 180104 10 rfcomm,bnep
ppdev 17113 0
snd_hda_codec_realtek 223867 1
snd_hda_intel 33773 3
snd_hda_codec 127706 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 13668 1 snd_hda_codec
psmouse 87692 0
serio_raw 13211 0
snd_pcm 97188 2 snd_hda_intel,snd_hda_codec
snd_seq_midi 13324 0
snd_rawmidi 30748 1 snd_seq_midi
snd_seq_midi_event 14899 1 snd_seq_midi
parport_pc 32866 1
asus_atk0110 18078 0
snd_seq 61896 2 snd_seq_midi,snd_seq_midi_event
snd_timer 29990 2 snd_pcm,snd_seq
snd_seq_device 14540 3 snd_seq_midi,snd_rawmidi,snd_seq
mac_hid 13253 0
snd 78855 15 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,sn d_seq_device
soundcore 15091 1 snd
snd_page_alloc 18529 2 snd_hda_intel,snd_pcm
lp 17799 0
parport 46562 3 ppdev,parport_pc,lp
raid10 35496 0
raid456 58338 0
async_pq 13187 1 raid456
async_xor 12879 2 raid456,async_pq
xor 12894 1 async_xor
async_memcpy 12529 1 raid456
async_raid6_recov 12776 1 raid456
raid6_pq 88346 2 async_pq,async_raid6_recov
async_tx 13349 5 raid456,async_pq,async_xor,async_memcpy,async_raid6_recov
raid0 17229 0
multipath 13145 0
linear 12894 0
usbhid 47199 0
hid 99559 1 usbhid
raid1 35572 1
usb_storage 49198 1
atl1e 42159 0
i915 468737 2
drm_kms_helper 46978 1 i915
drm 242038 3 i915,drm_kms_helper
i2c_algo_bit 13423 1 i915
video 19596 1 i915

TobiSGD 07-04-2012 03:06 PM

Please use code-tags, not quote tags for output of commands.
So, the kernel can see your sound hardware and has loaded the appropriate modules for the hardware. I assume that means that your hardware is working correctly.
Start alsamixer and look if all channels are unmuted. And the most obvious thing, make sure that your speakers are wired properly (this is often a cause for issues like yours)

MisterBark 07-04-2012 03:07 PM

Well... it definitely looks like you have not only the card connected to the pci bus, but also the driver loaded properly.

You don't have alsa?
What happens if you run "play /.../my-test-file.wav" ?

qajaq 07-04-2012 03:37 PM

TobiSGD - Bingo! After installing the new motherboard, I had mis-wired the speakers. Thanks for pointing to the obvious! And thanks to NyteOwl and MisterBark, as well, for your ideas -- now I have a few more CLI tools to work with in the future.

MisterBark 07-04-2012 03:42 PM


Originally Posted by qajaq (Post 4719360)
Bingo! After installing the new motherboard, I had mis-wired the speakers.

You knew it since the beginning, that's why you've posted in the Hardware section.

All times are GMT -5. The time now is 03:31 AM.