LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Nikon ls-1000 (coolscan) Scanner Problem (http://www.linuxquestions.org/questions/showthread.php?t=4175435163)

jon44 11-01-2012 07:30 PM

Nikon ls-1000 (coolscan) Scanner Problem
 
Am struggling to install a recently aquired Nikon ls-1000 scanner. I made sure synaptic had downloaded all the xsane files. Am running PCLinusOs 2012.2 on main machine and PCLinux XFCE on other machine so parallel ports not recognized automatically.

In coolscan.conf I uncommented the line /dev/parport0, and in coolscan2.conf the line scsi: dev/parport0

I then checked the file dev/parport0 and noticed it is empty.

I tried this on both my Dell Veriton desktops - 2004 vintage. Each has one parallel port usually used for printer.

Xsane Scanning App could not locate the scanner.
No luck after various tweeks and attempts so I installed the trial version of Vuescan.

Vuescan had same problem - it could not find the scanner.

Any suggestions for getting this ancient but reputedly excellent device to work under linux would be much appreciated. Please bear in mind I'm a product of the modern user friendly linux interface, so not much good with compiling and terminals!

michaelk 11-01-2012 09:24 PM

Welcome to LinuxQuestions

According to all the information I could find on your scanner including the coolscan backend it uses a SCSI interface and not the parallel port. Are there different model numbers with different interface types?

To use this scanner you will need to acquire a SCSI card and I would recommend an Adaptec.

www.nikonusa.com/pdf/LS1000ug.pdf
http://linux.die.net/man/5/sane-coolscan
http://www.sane-project.org/README.linux

jon44 11-02-2012 07:34 PM

Thanks Michaelk for sorting me out - I thought the 25 pin female connector I use for my printer was an scsi connector! I'll pick up a card and keep my fingers crossed. Can get an Adaptec on ebay.

michaelk 11-02-2012 07:52 PM

Yes, some SCSI-1 connectors were 25 pin D connectors. Post back when you get a card installed and we can help you get configured if it does not get recognized.

jon44 11-25-2012 10:27 AM

Follow Up re. Nikon LS-1000 scanner
 
After installing my new Adaptec 2903B PCI SCSI Card ($9 from ebay), the LS-1000 immediately did everything it's supposed to without further configuration.

So far as getting a good scan - that was a different matter! Various sessions using the Xsane frontend yielded only two good slide scans which were in fact excellent in terms of sharpness and balance. For an amateur the interface seems so flaky and convoluted that I was unable to replicate these successes. All other scans are out of focus and bloom terribly. As the preview action ends, the so-far decent looking image suddenly becomes over everything - bright, contrast, saturation. No matter how I adjust the sliders, the ensuing full res scan is the same over everything, out of focus mess.

I also tried the free version of VueScan. This gave good results when it worked but most of the time it froze up. Admittedly my PC is somewhat ancient - Dell Veriton 7600G running PcLinuxOs KDE 2012.02.

Finally I accidentally discovered a sane frontend called Simple Scan. Simple it really is but the results were very acceptable after tweeking in Gimp. I don't think Simple Scan is doing the LS-1000 auto focus as Xsane and VueScan did, but I see almost no difference upon comparing the good samples I saved.

So I'll probably stick with Simple Scan for now but would much appreciate any hints for using Xsane from anyone who has come to terms with it.

Thanks.


All times are GMT -5. The time now is 01:20 AM.