LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 11-18-2007, 05:44 AM   #1
cyber203
LQ Newbie
 
Registered: Nov 2007
Posts: 3

Rep: Reputation: 0
Unhappy NIC detection problem


Hi,
I have just installed RedHat enterprise Linux 5 on an intel core 2 Dou Machine with Windows XP already installed on it problem is that my NIC is not getting dtected by RedHat whereas its working fine with windows i have tried the following but still stuck with the problem

Disabled the on board LAN option

#lspci | grep -i ehternet
it shows " ethernet controller: Realtek semiconductor co: RTL8111/8168B PCI Express gigabit Ethernet controller (rev 01) "
#modprobe 8139too
# cat /etc/modprobe.conf
it shows "alisas eth0" no other interface

also tried to manually add it using system-config-network

Kernel release is 2.6.18-8.el5, also when i issue ifconfig -a command it shows an interface "sit0" dont know abt that. Any help will be highy appreciated.
 
Old 11-18-2007, 07:15 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
Quote:
ethernet controller: Realtek semiconductor co: RTL8111/8168B PCI Express gigabit Ethernet
The 8139too driver is not the correct for either in Windows or Linux;

See: http://wiki.centos.org/HardwareList/RealTekRTL8111b
 
Old 11-21-2007, 07:51 AM   #3
cyber203
LQ Newbie
 
Registered: Nov 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Unhappy

well I got the driver from the link, tried to install it according to the readme file but on the very first command i got the following error

[root@localhost r8168-8.003.00]# make clean modules
make -C src/ clean
make[1]: Entering directory `/installations/r8168-8.003.00/src'
rm -rf *.o *.ko *~ core* .dep* .*.d .*.cmd *.mod.c *.a *.s .*.flags .tmp_versions Module.symvers
make[1]: Leaving directory `/installations/r8168-8.003.00/src'
make -C src/ modules
make[1]: Entering directory `/installations/r8168-8.003.00/src'
make -C /lib/modules/2.6.18-8.el5/build SUBDIRS=/installations/r8168-8.003.00/src modules
make: Entering an unknown directory
make: *** /lib/modules/2.6.18-8.el5/build: No such file or directory. Stop.
make: Leaving an unknown directory
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/installations/r8168-8.003.00/src'
make: *** [modules] Error 2

Now what should I do?
 
Old 11-21-2007, 08:33 AM   #4
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
Install the kernel-devel and kernel-headers packages; yum install kernel-headers kernel-devel
 
Old 11-21-2007, 12:10 PM   #5
cyber203
LQ Newbie
 
Registered: Nov 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Hi Lenard,
main problem is that there is no internet connectivity available as there is no NIC so yum is unable to do any thing. any alternative?
 
Old 11-21-2007, 03:19 PM   #6
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
Check the installation media, from where the rpm packages are type;

rpm -Uvh kernel-headers*.rpm kernel-devel*.rpm [and maybe kernel-xen-devel*.rpm]

If you have the kernel-xen package installed then you also need the kernel-xen-devel package.

To find out first type: rpm -qa 'kernel*'
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
detection of NIC vkmgeek Linux - Networking 6 09-16-2007 08:51 AM
same old problem of nic card and sound card detection in 10.2 brgurung Slackware 8 03-29-2007 03:40 AM
nic detection hareeswar Linux - Hardware 2 05-27-2006 04:38 PM
NIC detection problem DeadlyMuffin Slackware 4 01-13-2004 06:16 AM
NIC detection problem qs_tahmeed Linux - Hardware 3 11-11-2003 09:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 11:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration