LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 02-05-2005, 11:05 PM   #1
halfcan
LQ Newbie
 
Registered: Nov 2004
Posts: 14

Rep: Reputation: 0
NIC 3c905BTX with RedHat 7.3


HI all,
I'm trying the add a 2nd NIC on redhat 7.3 but am getting no where.
Currently, eth0 is a Kingston NIC, and works fine.

I want add a second card, (3c905BTX) to be eth1. And from everything I've read, the 3c90x series is suppost to be one of the easiest NICs to use.
(i guess just not for me)

Specifics:

Card: 3com 3c905BTX
Driver I'm trying to use: 3c90x
Downloaded tar: 3c90x-102.tar.gz
from:http://support.3com.com/infodeli/too...uxdownload.htm
Kernel Version: 2.4.18-3

[root@tunes 3c90x-102]# uname -a
Linux 2.4.18-3 #1 Thu Apr 18 07:31:07 EDT 2002 i586 unknown

The first step the readme
File suggests is to Load the Driver Module is to add an alias line in: /etc/modules.conf

I've added: alias eth1 3c90x

If this is suppost to be enough, I don't know because the readme file doesn't say either way.....

[root@tunes 2.4.18-3]# vi /etc/modules.conf
alias eth0 ne
options ne io=0x300
alias eth1 3c90x
alias parport_lowlevel parport_pc
pre-install pcmcia_core /etc/rc.d/init.d/pcmcia start
alias usb-controller usb-uhci

So I rebooted the machine, NIC is not being recognized by kernel:

[root@tunes andy]# /sbin/ifconfig
eth0 Link encap:Ethernet HWaddr 00:C0:F0:0F:27:94
inet addr:192.168.1.50 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:20857 errors:0 dropped:0 overruns:0 frame:0
TX packets:5944 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:1999305 (1.9 Mb) TX bytes:941307 (919.2 Kb)
Interrupt:3 Base address:0x300

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:560 (560.0 b) TX bytes:560 (560.0 b)
********************************************************

Ok, so the Next option is to Build a Loadable Module:
I try using: ./compile_UP

This is what I get: compile results

I don't have a path like: /usr/src/linux/include

I have /usr/src/redhat/BUILD or RPMS or SOURCES SPECS SRPM

I've tried using the long gcc compile command with adding the -I usr/src/redhat/WHATEVER paths, but it still doesn't work.

So, now what? What does this mean?

WHY IS THIS SO HARD?

Someone told me that I possibly need to upgrade or patch my kernel - I'm not sure what this is, or how dangerous this is. I've spent alot of time configuring this box and do not want it F-ed up by doing something stupid that I don't know anything about.

He sent me to: http://www.kernel.org/ but they don't have anything for kernel 2.4.18-3 anyway.

Please help.

HC

 
Old 02-05-2005, 11:11 PM   #2
halfcan
LQ Newbie
 
Registered: Nov 2004
Posts: 14

Original Poster
Rep: Reputation: 0
Heres some more info:

[root@tunes 3c90x-102]# scanpci

pci bus 0x0000 cardnum 0x00 function 0x00: vendor 0x8086 device 0x7030
Intel 82437VX

pci bus 0x0000 cardnum 0x07 function 0x00: vendor 0x8086 device 0x7000
Intel 82371 pci-isa bridge

pci bus 0x0000 cardnum 0x07 function 0x01: vendor 0x8086 device 0x7010
Intel 82371 bus-master IDE controller

pci bus 0x0000 cardnum 0x07 function 0x02: vendor 0x8086 device 0x7020
Intel 82371 bus-master IDE controller

pci bus 0x0000 cardnum 0x13 function 0x00: vendor 0x10b7 device 0x9055
3COM Device unknown

pci bus 0x0000 cardnum 0x14 function 0x00: vendor 0x5333 device 0x8901
S3 Trio64V2/DX or /GX
[root@tunes 3c90x-102]#

NOTE: the existing Kingston NIC is an ISA card, the 3com is PCI
Thanks,
HC
 
Old 02-06-2005, 01:58 AM   #3
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85
This is a bit of a long shot but IIRC (and that's a big if), you should be using the 3c59x driver. The link at the bottom of the 3Com support page you listed has more info. Good luck with it -- J.W.
 
Old 02-06-2005, 10:04 AM   #4
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
There is also a 3c59x module that comes with the linux kernel, so you should just be able to go into your config files (/etc/modules.conf) where you added the 3c90x and change that to 3c59x to get the driver built into linux loaded, instead of having to use a seperate download from 3Com. You CAN use 3Com's driver, but it has to be installed properly and the Linux one has always worked great.

After you change that and reboot, type this in a text console:

lsmod | grep 3c

which should show the 3Com module 3c59x. If it doesn't show up see if you can load it manually:

modprobe -v 3c59x

if not try these commands to look for more troubleshooting help:

dmesg | grep 3c
lspci


and post the results of the commands if you are still having problems.
 
Old 02-08-2005, 02:46 PM   #5
halfcan
LQ Newbie
 
Registered: Nov 2004
Posts: 14

Original Poster
Rep: Reputation: 0
JW and Darin - thanks for the response.

I changed the line in /etc/modules.conf
to: alias eth1 3c59x
and rebooted.


Ifconfig still not showing eth1.

Next, I checked for the mod:

[root@tunes andy]# lsmod | grep 3c
Module Size Used by Not tainted
3c59x 27432 0 (unused)

ok, next I tried to load the mod:

[root@tunes andy]# modprobe -v 3c59x
/sbin/insmod /lib/modules/2.4.18-3/kernel/drivers/net/3c59x.o
Using /lib/modules/2.4.18-3/kernel/drivers/net/3c59x.o
Symbol version prefix ''
[root@tunes andy]#

(That seemed to go ok, although I've never done this before so I'm not sure.....I also tried to modprobe the 3c90x mod just for the hell of it, but it could not be found.)

Did lsmod again:

[root@tunes andy]# /sbin/lsmod | grep 3c
3c59x 27432 0 (unused)

I've rebooted and rechecked /etc/modules.conf and eth1 is still showing in ifconfig.

Results of dmesg command:

[root@tunes andy]# dmesg | grep 3c
3c59x: Donald Becker and others. www.scyld.com/network/vortex.html
00:13.0: 3Com PCI 3c905B Cyclone 100baseTx at 0xfc00. Vers LK1.1.16
[root@tunes andy]#

Results of scanpci:


[root@tunes andy]# scanpci

pci bus 0x0000 cardnum 0x00 function 0x00: vendor 0x8086 device 0x7030
Intel 82437VX

pci bus 0x0000 cardnum 0x07 function 0x00: vendor 0x8086 device 0x7000
Intel 82371 pci-isa bridge

pci bus 0x0000 cardnum 0x07 function 0x01: vendor 0x8086 device 0x7010
Intel 82371 bus-master IDE controller

pci bus 0x0000 cardnum 0x07 function 0x02: vendor 0x8086 device 0x7020
Intel 82371 bus-master IDE controller

pci bus 0x0000 cardnum 0x13 function 0x00: vendor 0x10b7 device 0x9055
3COM Device unknown

pci bus 0x0000 cardnum 0x14 function 0x00: vendor 0x5333 device 0x8901
S3 Trio64V2/DX or /GX
[root@tunes andy]#


Any other ideas?
Thanks,
HC
 
Old 02-10-2005, 09:13 PM   #6
halfcan
LQ Newbie
 
Registered: Nov 2004
Posts: 14

Original Poster
Rep: Reputation: 0
My problem is fixed. I got eth1 working
What happened

I added: alias eth1 3c59x to /etc/modules.conf, and loaded the module using: modprobe -v 3c59x (which completed successfully) and rebooted.

BUT still, I was getting this:

[root@tunes andy]# /sbin/lsmod | grep 3c
3c59x 27432 0 (unused)
When I ran the command: ifconfig, the eth1 was still not showing up. BUT When I did the command: ifconfig with the -a option, eth 1 showed up.
I don't know why.
Here is the output of lsmod now:
[root@tunes andy]# /sbin/lsmod
Module Size Used by Not tainted
3c59x 27432 1
ne 7936 1
8390 7636 0 [ne]
ide-cd 29856 0 (autoclean)
cdrom 33184 0 (autoclean) [ide-cd]
usb-uhci 23492 0 (unused)
usbcore 71168 1 [usb-uhci]
ext3 64448 4
jbd 47608 4 [ext3]

I assigned an IP address to eth1 successfully.
I plugged in the ethernet cable and attempted to reach other hosts on my network.
I could ping localhost, and 192.168.1.51 (assigned to eth1) but I couldn't reach anything else.
I rebooted, but eth1 not being brought up.
I went into /etc/sysconfig/network-scripts and created a file called ifcfg-eth1.
ifcfg-eth1 contents:
DEVICE=eth1
IPADDR=192.168.1.51
NETMASK=255.255.255.0
NETWORK=192.168.1.0
BROADCAST=192.168.1.255
ONBOOT=yes

Service network restart.

eth1 is now fully working, I can reach all my other hosts, and the interface is being brought up/down just like the other interfaces upon reboots and service network restarts.

Any other thoughts/ideas, things I should think about?

Thanks,
hc
 
Old 02-10-2005, 11:56 PM   #7
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85
If you NIC is working, and the interface does not require any manual steps to keep it operational, then it sounds like you've got it settled. Congrats on solving the problem -- J.W.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Best NIC for RedHat 7.3 halfcan Linux - Hardware 2 11-10-2004 06:36 PM
Redhat 8.0 NIC Drivers Big Brad Linux - Newbie 6 01-07-2004 09:10 AM
RedHat 9 - PCMCIA NIC - Nothing... syzygy Red Hat 1 09-06-2003 09:56 AM
NIC not recognized by Redhat 9 rounder Linux - Hardware 0 08-11-2003 01:41 PM
Redhat 9 NIC question Futureman Linux - Networking 1 08-09-2003 06:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 05:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration