LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 12-09-2003, 01:17 PM   #31
krissly1
Member
 
Registered: Oct 2003
Location: Near the 2002 Winter Olympics
Distribution: Linux Redhat 9.0
Posts: 121

Rep: Reputation: 15

Thanks davehudsn
What a great tutorial !!!!!!
AWESOME !! I'm up and running now.
 
Old 12-28-2003, 05:04 PM   #32
krissly1
Member
 
Registered: Oct 2003
Location: Near the 2002 Winter Olympics
Distribution: Linux Redhat 9.0
Posts: 121

Rep: Reputation: 15
Here is my kernel & kernel source.
[dad@localhost dad]$ rpm -qa | grep kernel
kernel-pcmcia-cs-3.1.31-13
kernel-source-2.4.20-27.9
kernel-2.4.20-8
kernel-2.4.20-27.9
kernel-module-alsa-0.9.8-1.fr_2.4.20_20.9
It seems to unpack okay ?
[root@localhost dad]# rpmbuild --rebuild NVIDIA_nforce-1.0-0261.rh90up_2.4.20_9.athlon.rpm
Installing NVIDIA_nforce-1.0-0261.rh90up_2.4.20_9.athlon.rpm
error: source package expected, binary found
error: NVIDIA_nforce-1.0-0261.rh90up_2.4.20_9.athlon.rpm cannot be installed
[root@localhost dad]# rpmbuild --rebuild NVIDIA_nforce-1.0-0261.src.rpm
Installing NVIDIA_nforce-1.0-0261.src.rpm
warning: user buildmeister does not exist - using root
warning: user buildmeister does not exist - using root
warning: user buildmeister does not exist - using root
warning: user buildmeister does not exist - using root
warning: user buildmeister does not exist - using root
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.21984
+ umask 022
+ cd /usr/src/redhat/BUILD
+ LANG=C
+ export LANG
+ echo '---- Copying Sources ----'
---- Copying Sources ----
+ cd /usr/src/redhat/BUILD
+ rm -rf nforce
+ /usr/bin/gzip -dc /usr/src/redhat/SOURCES/nvnet.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2003-05-06 13:36:14 nforce/
drwxr-xr-x buildmeister/adm 0 2003-05-06 13:39:37 nforce/nvnet/
-r--r--r-- buildmeister/adm 16904 2003-05-06 13:39:37 nforce/nvnet/adapter.h
-r--r--r-- buildmeister/adm 794 2003-05-06 13:39:37 nforce/nvnet/basetype.h
-r--r--r-- buildmeister/adm 6752 2003-05-06 13:39:37 nforce/nvnet/nvnet.h
-r--r--r-- buildmeister/adm 4437 2003-05-06 13:39:37 nforce/nvnet/os.h
-r--r--r-- buildmeister/adm 4749 2003-05-06 13:39:37 nforce/nvnet/phy.h
-r--r--r-- buildmeister/adm 37870 2003-05-06 13:39:37 nforce/nvnet/nvnet.c
-rw-r--r-- buildmeister/adm 21504 2003-05-06 13:39:37 nforce/nvnet/nvnetlib.o
-r--r--r-- buildmeister/adm 3088 2003-05-06 13:39:37 nforce/nvnet/Makefile
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ cd /usr/src/redhat/BUILD
+ /usr/bin/gzip -dc /usr/src/redhat/SOURCES/nvaudio.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2003-05-06 13:39:38 nforce/
drwxr-xr-x buildmeister/adm 0 2003-05-06 13:39:38 nforce/nvaudio/
-r--r--r-- buildmeister/adm 2522 2003-05-06 13:39:38 nforce/nvaudio/Makefile
-r--r--r-- buildmeister/adm 58241 2003-05-06 13:39:38 nforce/nvaudio/nvcrush.c
-r--r--r-- buildmeister/adm 32174 2003-05-06 13:39:38 nforce/nvaudio/nvhw.c
-r--r--r-- buildmeister/adm 33857 2003-05-06 13:39:38 nforce/nvaudio/nvmain.c
-r--r--r-- buildmeister/adm 8314 2003-05-06 13:39:38 nforce/nvaudio/nvrec.c
-r--r--r-- buildmeister/adm 26382 2003-05-06 13:39:38 nforce/nvaudio/nvspdif.c
-r--r--r-- buildmeister/adm 14709 2003-05-06 13:39:38 nforce/nvaudio/nvwavout.c
-r--r--r-- buildmeister/adm 4546 2003-05-06 13:39:38 nforce/nvaudio/chaninfo.h
-r--r--r-- buildmeister/adm 5065 2003-05-06 13:39:38 nforce/nvaudio/nvhw.h
-r--r--r-- buildmeister/adm 1570 2003-05-06 13:39:38 nforce/nvaudio/nvioctl.h
-r--r--r-- buildmeister/adm 1392 2003-05-06 13:39:38 nforce/nvaudio/nvrec.h
-r--r--r-- buildmeister/adm 1618 2003-05-06 13:39:38 nforce/nvaudio/nvspdif.h
-r--r--r-- buildmeister/adm 1499 2003-05-06 13:39:38 nforce/nvaudio/nvwavout.h
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ cd /usr/src/redhat/BUILD
+ /usr/bin/gzip -dc /usr/src/redhat/SOURCES/nvmaster.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2003-05-06 13:39:36 nforce/
-r--r--r-- buildmeister/adm 1091 2003-05-06 13:39:36 nforce/Makefile
-r--r--r-- buildmeister/adm 5404 2003-05-06 13:39:36 nforce/NVLicense.txt
-r--r--r-- buildmeister/adm 18007 2003-05-06 13:39:36 nforce/GNULicense.txt
-r--r--r-- buildmeister/adm 23612 2003-05-06 13:39:36 nforce/ReleaseNotes.html
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ cd /usr/src/redhat/BUILD
+ /usr/bin/gzip -dc /usr/src/redhat/SOURCES/nvgart.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2003-05-06 13:39:38 nforce/
drwxr-xr-x buildmeister/adm 0 2003-05-06 13:39:38 nforce/nvgart/
-r--r--r-- buildmeister/adm 590 2003-05-06 13:39:38 nforce/nvgart/Makefile
-r--r--r-- buildmeister/adm 1231 2003-05-06 13:39:38 nforce/nvgart/README
-r--r--r-- buildmeister/adm 14033 2003-05-06 13:39:38 nforce/nvgart/linux-2.4.20-agpgart.diff
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.60329
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd nforce
+ LANG=C
+ export LANG
+ echo '---- Building Drivers ----'
---- Building Drivers ----
+ make
make -C nvnet
make[1]: Entering directory `/usr/src/redhat/BUILD/nforce/nvnet'
cc -c -Wall -DLINUX -DMODULE -DEXPORT_SYMTAB -D__KERNEL__ -O -Wstrict-prototypes -DCONFIG_PM -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -I/lib/modules/2.4.20-27.9/build/include -DMODVERSIONS -include /lib/modules/2.4.20-27.9/build/include/linux/modversions.h nvnet.c
ld -r -o temp.o nvnet.o nvnetlib.o
objcopy --strip-symbol="gcc2_compiled." temp.o
cp temp.o nvnet.o
rm temp.o
make[1]: Leaving directory `/usr/src/redhat/BUILD/nforce/nvnet'
make -C nvaudio
make[1]: Entering directory `/usr/src/redhat/BUILD/nforce/nvaudio'
make nvaudio.o
make[2]: Entering directory `/usr/src/redhat/BUILD/nforce/nvaudio'
cc -D__KERNEL__ -I/lib/modules/2.4.20-27.9/build/include -Wall -Wstrict-prototypes -O -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -DREMAP_NEW -DMODVERSIONS -include /lib/modules/2.4.20-27.9/build/include/linux/modversions.h -c -o nvhw.o nvhw.c
cc -D__KERNEL__ -I/lib/modules/2.4.20-27.9/build/include -Wall -Wstrict-prototypes -O -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -DREMAP_NEW -DMODVERSIONS -include /lib/modules/2.4.20-27.9/build/include/linux/modversions.h -c -o nvrec.o nvrec.c
cc -D__KERNEL__ -I/lib/modules/2.4.20-27.9/build/include -Wall -Wstrict-prototypes -O -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -DREMAP_NEW -DMODVERSIONS -include /lib/modules/2.4.20-27.9/build/include/linux/modversions.h -c -o nvwavout.o nvwavout.c
cc -D__KERNEL__ -I/lib/modules/2.4.20-27.9/build/include -Wall -Wstrict-prototypes -O -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -DREMAP_NEW -DMODVERSIONS -include /lib/modules/2.4.20-27.9/build/include/linux/modversions.h -c -o nvspdif.o nvspdif.c
cc -D__KERNEL__ -I/lib/modules/2.4.20-27.9/build/include -Wall -Wstrict-prototypes -O -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -DREMAP_NEW -DMODVERSIONS -include /lib/modules/2.4.20-27.9/build/include/linux/modversions.h -c -o nvcrush.o nvcrush.c
cc -D__KERNEL__ -I/lib/modules/2.4.20-27.9/build/include -Wall -Wstrict-prototypes -O -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -DREMAP_NEW -DMODVERSIONS -include /lib/modules/2.4.20-27.9/build/include/linux/modversions.h -c -o nvmain.o nvmain.c
ld -r nvhw.o nvrec.o nvwavout.o nvspdif.o nvcrush.o nvmain.o -o nvaudio.o
make[2]: Leaving directory `/usr/src/redhat/BUILD/nforce/nvaudio'
make[1]: Leaving directory `/usr/src/redhat/BUILD/nforce/nvaudio'
make -C nvgart
make[1]: Entering directory `/usr/src/redhat/BUILD/nforce/nvgart'
making gart
make[1]: Leaving directory `/usr/src/redhat/BUILD/nforce/nvgart'
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.46361
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd nforce
+ LANG=C
+ export LANG
+ echo '---- Installing Drivers ----'
---- Installing Drivers ----
+ rm -f /usr/src/redhat/BUILD/nforce/modules.list
+ '[' -z '' ']'
++ uname -r
+ export TARGET_KERNEL=2.4.20-27.9
+ TARGET_KERNEL=2.4.20-27.9
+ make INSTROOT=/var/tmp/NVIDIA_nforce-1.0-0261-root install
make -C nvnet install
make[1]: Entering directory `/usr/src/redhat/BUILD/nforce/nvnet'
mkdir -p /var/tmp/NVIDIA_nforce-1.0-0261-root//lib/modules/2.4.20-27.9/kernel/drivers/net
install -b -m 644 -o root nvnet.o /var/tmp/NVIDIA_nforce-1.0-0261-root//lib/modules/2.4.20-27.9/kernel/drivers/net
/sbin/depmod -a
make[1]: Leaving directory `/usr/src/redhat/BUILD/nforce/nvnet'
make -C nvaudio install
make[1]: Entering directory `/usr/src/redhat/BUILD/nforce/nvaudio'
mkdir -p /var/tmp/NVIDIA_nforce-1.0-0261-root//lib/modules/2.4.20-27.9/kernel/drivers/sound
install -b -m 644 -o root nvaudio.o /var/tmp/NVIDIA_nforce-1.0-0261-root//lib/modules/2.4.20-27.9/kernel/drivers/sound
/sbin/depmod -a
make[1]: Leaving directory `/usr/src/redhat/BUILD/nforce/nvaudio'
make -C nvgart install
make[1]: Entering directory `/usr/src/redhat/BUILD/nforce/nvgart'
mkdir -p /var/tmp/NVIDIA_nforce-1.0-0261-root//usr/src/nvidia/nvgart
install -b -m 644 -o root linux-2.4.20-agpgart.diff /var/tmp/NVIDIA_nforce-1.0-0261-root//usr/src/nvidia/nvgart
install -b -m 644 -o root README /var/tmp/NVIDIA_nforce-1.0-0261-root//usr/src/nvidia/nvgart
make[1]: Leaving directory `/usr/src/redhat/BUILD/nforce/nvgart'
+ echo '%attr(644, root, root) /lib/modules/2.4.20-27.9/kernel/drivers/sound/nvaudio.o'
+ echo '%attr(644, root, root) /lib/modules/2.4.20-27.9/kernel/drivers/net/nvnet.o'
+ /usr/lib/rpm/brp-compress
Processing files: NVIDIA_nforce-1.0-0261
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.78269
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd nforce
+ DOCDIR=/var/tmp/NVIDIA_nforce-1.0-0261-root/usr/share/doc/NVIDIA_nforce-1.0
+ export DOCDIR
+ rm -rf /var/tmp/NVIDIA_nforce-1.0-0261-root/usr/share/doc/NVIDIA_nforce-1.0
+ /bin/mkdir -p /var/tmp/NVIDIA_nforce-1.0-0261-root/usr/share/doc/NVIDIA_nforce-1.0
+ cp -pr NVLicense.txt /var/tmp/NVIDIA_nforce-1.0-0261-root/usr/share/doc/NVIDIA_nforce-1.0
+ cp -pr GNULicense.txt /var/tmp/NVIDIA_nforce-1.0-0261-root/usr/share/doc/NVIDIA_nforce-1.0
+ cp -pr ReleaseNotes.html /var/tmp/NVIDIA_nforce-1.0-0261-root/usr/share/doc/NVIDIA_nforce-1.0
+ exit 0
Requires(interp): /bin/sh /bin/sh
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires(post): /bin/sh
Requires(postun): /bin/sh
Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/NVIDIA_nforce-1.0-0261-root
Wrote: /usr/src/redhat/RPMS/i386/NVIDIA_nforce-1.0-0261.i386.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.40761
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd nforce
+ '[' /var/tmp/NVIDIA_nforce-1.0-0261-root '!=' / ']'
+ rm -rf /var/tmp/NVIDIA_nforce-1.0-0261-root
+ exit 0
Executing(--clean): /bin/sh -e /var/tmp/rpm-tmp.40761
+ umask 022
+ cd /usr/src/redhat/BUILD
+ rm -rf nforce
+ exit 0
When I try to cd I get
[root@localhost dad]# cd /usr/src/redhat/RPMS/i386/NVIDIA_nforce-1.0-0261.i386.rpm
bash: cd: /usr/src/redhat/RPMS/i386/NVIDIA_nforce-1.0-0261.i386.rpm: Not a directory
Can you see what I may be doing wrong ? I used this once and it all went smooth. Then I did a reinstall.
 
Old 01-09-2004, 11:21 PM   #33
Shatterstar
LQ Newbie
 
Registered: Jan 2004
Posts: 2

Rep: Reputation: 0
Hello,

I'm really new to RH9, and I mean I just installed it for the first time. And would you guess what my first problem is?

I have the same problem as above, and I was wondering the following.

My kernel is kernel-2.4.20-8, but the RPM says it's designed for 2.4.20-9 does this make a difference?
 
Old 01-10-2004, 02:09 PM   #34
Shatterstar
LQ Newbie
 
Registered: Jan 2004
Posts: 2

Rep: Reputation: 0
Woot never mind the previous post, I was able to follow the steps you provided... with a few glitches of course.

It's working now.

Thanks all.
 
Old 02-17-2004, 03:40 PM   #35
Sedi
LQ Newbie
 
Registered: Feb 2004
Location: New Zealand
Distribution: libranet-2.8.1, xandros-2.0, fedoracore2, slackware-10.1, sme server-6.5 beta
Posts: 2

Rep: Reputation: 0
sh-t

f--k

f--k--g hell

woot, woot, woot

yeehaa baby

This newbie lives again

Now posting with new OS

I'd like to thank all you guy's and gal's for the information you kindly posted, all of which has contributed to getting my now new OS Fedora Core online .

I now know that warm fuzzy feeling u spoke of hw-tph, it feels good, thanx

voodooutt your tutorial was great worked just beautifully, great work .

Finally again thanx to all who posted, excellent!.
 
Old 03-04-2004, 06:10 AM   #36
bat
LQ Newbie
 
Registered: Mar 2004
Location: The Netherlands
Distribution: Red Hat 9
Posts: 3

Rep: Reputation: 0
i've got to the part of editing the conf file but i have a problem with netconfig
--> message --> cannot find file bad command what to do ???? i've got dual boot with winxp and red hat 9 installed amd 2800+ with asus a8n7x deluxe mobo
 
Old 03-16-2004, 12:11 PM   #37
ViN86
LQ Newbie
 
Registered: Mar 2004
Distribution: Slackware 10.0
Posts: 25

Rep: Reputation: 15
im running a k7n2 delta ILSR board too, and my network is working. i used the kernel tar file that can be found in nVidia's nforce linux driver page. (on the bottom)

then, i just followed the instructions and installed it. everything seemed to go without a hitch. im running slackware 9.1, so maybe that was the reason. just wanted to let you know i got the network working, so there IS hope
 
Old 03-16-2004, 12:20 PM   #38
bat
LQ Newbie
 
Registered: Mar 2004
Location: The Netherlands
Distribution: Red Hat 9
Posts: 3

Rep: Reputation: 0
I've got my network working allready forgot to post it here
 
Old 04-11-2004, 06:22 PM   #39
freeze
LQ Newbie
 
Registered: Apr 2004
Location: Sweden
Posts: 4

Rep: Reputation: 0
Talking

Quote:
Originally posted by voodooutt
OMG

OMG

OMG

I finally GOT IT

heres what i did:

1) installed the kernel-source-2.4.22-10mdk.i586.rpm
2) went to directory and tar xvfz nforce.tar.gz
3) cd /nforce/nvnet/
4) make - AND this time only 5 lines popped up after hitting enter (much better thankyou)
5) make install - and again looked good
6) navigated to /etc/modules.conf
7) used the vi command to edit that file, bacuase under X i cant write to it.....
8) reboot
9) POOF - I HAVE A eth0 finally, configured it to DHCP and voila!

YES!!! That did it for me too!! Thanks for the excellent walkthrough!

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10 nForce2 LAN Support tini1212 Slackware 6 07-12-2004 08:33 AM
nForce2 LAN problem in Mandrake 9.1 smitty1276 Linux - Hardware 7 06-11-2004 05:48 PM
nforce2 on board lan with redhat 9 won't work herbert Linux - Hardware 2 10-19-2003 10:45 PM
nForce2 on-board lan + debian = tears ninab Linux - Networking 3 08-15-2003 02:08 PM
Can't make nforce2 LAN work Johnnie Walker Linux - Newbie 5 08-10-2003 02:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration