LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 06-05-2003, 07:53 PM   #1
dmellem
Member
 
Registered: Mar 2003
Distribution: Fedora
Posts: 42

Rep: Reputation: 15
nForce 2 network card & ifup problem


Hi,

I just got a computer with the nForce chipset. Red Hat 9 didn't recognize the NIC out of the box but I got the drivers from nvidia.com. Upon boot, it would fail, even with a static IP address (it was trying to run dhclient). Anyhow, I discovered that there was a setting in /etc/sysconfig/networking/profiles/default/ifcfg-eth0 that was being using instead of the settings from netconfig (/etc/sysconfig/network-scripts/ifcfg-eth0).

1. How does this get set? It wouldn't work until I renamed the ifcfg-eth0 under default.

2. When I run "route," it shows two identical routes for the LAN. How do I get rid of one?

3. Is there a way to trace or step through a shell script? It would have been a lot easier to find this if I could have stepped through "ifup eth0."

Thanks a lot,

-Dan
 
Old 06-06-2003, 12:45 AM   #2
finegan
LQ Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 65
1. tinker with the GUIs, or better yet, just delete both profiles by hand and then tinker with the GUIs.

2. route delete default (and then) route delete

3. zap both of those annoying profiles, reboot the crate, verify there's no attempted route with "route" and then just try dhcp with dhclient, or...

ifconfig eth0 192.168.0.2 up
route add default gw 192.168.0.1

Cheers,

Finegan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with Debian 2.4.27-2 and NForce 4 audio & network firesnaker Debian 1 11-02-2005 09:54 PM
server ifup: RTNETLINK answers: Network is unreachable problem evasion81 Linux - Networking 5 07-07-2005 08:44 AM
Info needed on Network card detection vs ifup-eth0 setup cdrobsonjr Fedora 0 05-01-2004 09:21 PM
Onboard nForce network card not recognized in RedHat 9 hellfireboy Linux - Hardware 2 04-18-2004 08:40 PM
Onboard nForce network card not recognized in RedHat 9 hellfireboy Linux - Networking 2 04-18-2004 06:16 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 07:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration