-   Linux - Hardware (
-   -   Newbie Trouble Mounting USB with Mandrake 10.1 (

themarina 01-03-2005 03:07 AM

Newbie Trouble Mounting USB with Mandrake 10.1

I have a USB memory stick that isn't working properly. Please bear with me, I'm brand new to Linux (installed 2 days ago) and most of the lingo is still Latin to me. I've read a couple of the other forums about problems mounting USB but I can't seem to find an answer for my problem!

I just installed Mandrake 10.1 and am trying to access the data on my USB drive. I plugged the USB device in and it was automatically detected but I can't view any of the files on it. The files were put on the drive using Windows. Is there a way to configure Linux to read the Windows file directories on the drive so that I can access some of the documents?

From reading some of the other posts, I also managed to get the info below. Hopefully it will help:


usb 1-2: new full speed USB device using address 4 hub 1-2:1.0: USB hub found hub 1-2:1.0: 1 port detected usb 1-2.1: new full speed USB device using address 5 scsi1 : SCSI emulation for USB Mass Storage devices  Vendor: Sony      Model: Storage Media    Rev: PROL  Type:  Direct-Access                      ANSI SCSI revision: 02 SCSI device sda: 256000 512-byte hdwr sectors (131 MB) sda: Write Protect is off sda: Mode Sense: 00 06 00 00 sda: assuming drive cache: write through  /dev/scsi/host1/bus0/target0/lun0: unknown partition table Attached scsi removable disk sda at scsi1, channel 0, id 0, lun 0 USB Mass Storage device found at 5
Any help would be greatly appreciated!


ag2uki 01-03-2005 08:08 AM

Try doing it manually,
You have to be a root to execute this commands.

Plug your device, execute this command,
#mount /dev/sda /mnt/usb
( I assumed that your usb device was "/dev/sda" and your usb mount directory was "/mnt/usb" )
If it works, you will find your usb files in /mnt/usb.

before unplugging your device, execute this command:
#umount /mnt/usb

If you can do that manually, you can do automatically too!
But, we have to know your /etc/fstab

micker 01-03-2005 05:40 PM

Hi themarina,
I'm also using mandrake 10.1 and also use a usb pendrive. It seems to me that mandrake doesn't always automatically recognise my pendrive but when it does, the led on the pendrive will flash for a second or so and then I can browse to /mnt/removable and access the data there. The files appear in exactly the same format as they would if you were looking at them in windows. I can also drag files onto the pendrive and browse them in windows. Hope this helps.


themarina 01-03-2005 07:10 PM

Tried it and still no go...
Ok. So I tried to mount it manually and by using the #mount /dev/sda /mnt/usb (but I changed 'usb' to usbDrive) and it worked...kind of. I can access the files from Terminal and the drive shows up in the /mnt directory but when I select it, no files show up. So I tried to copy the files that I needed from the USB using Terminal and it just got messy!

I found the /etc/fstab file and here's what it says:

/dev/hda1 / ext3 noatime 1 1
/dev/hda6 /home ext3 noatime 1 2
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0

I'm going to keep playing with it but so far, no luck.

Thanks for the help so far!

themarina 01-03-2005 07:52 PM

New Update - Still not working though!
I've added this line to the /etc/fstab file :

/dev/sda1 /bak1 vfat noauto,user,rw,exec,sync 0 0

This is great and all, I can see the drive perfectly in Root but i can access it as a user.
When I try to mount it, this is the error message I get:

mount: mount point /bak1 does not exist
Please check that the disk is entered correctly.


What on earth does this mean? It works as root.....


All times are GMT -5. The time now is 03:28 PM.