LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 05-20-2007, 03:41 PM   #1
Chryyz
Member
 
Registered: Dec 2004
Distribution: Slackware 10, Gentoo
Posts: 46

Rep: Reputation: 15
Newbie - Can't get sound working for nForce2 onboard (AC97)


Well... I compiled a custom kernel to support my sound card as per lspci output and for some reason the sound card isn't working... lsmod doesn't list anyting on there, and I know the driver is correct because not only is it what lspci told me, the nVIDIA site says I need the intel8x0.c driver, which I have, and I also have an ac97 folder... Any suggestions? Should be cake for any veterans... I just haven't done this before and I only recently installed gentoo ^.^;;

lspci output:

Code:
00:06.0 Multimedia audio controller: nVidia Corporation MCP2S AC'97 Audio Controller (rev a1)
00:08.0 PCI bridge: nVidia Corporation MCP2A PCI Bridge (rev a3)
00:09.0 IDE interface: nVidia Corporation MCP2A IDE (rev a3)
00:0b.0 IDE interface: nVidia Corporation nForce2 Serial ATA Controller (rev a3)
lsmod output:

Code:
Module                  Size  Used by
nvidia               6830196  22
 
Old 05-20-2007, 04:35 PM   #2
Okie
Senior Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 1,058

Rep: Reputation: 102Reputation: 102
you may have to rebuild Alsa-lib and Alsa-driver and when compiling alsa-driver use the parameter --with-cards=intel8x0
 
Old 05-21-2007, 12:32 AM   #3
Chryyz
Member
 
Registered: Dec 2004
Distribution: Slackware 10, Gentoo
Posts: 46

Original Poster
Rep: Reputation: 15
Sorry for the delay.

I don't think ALSA is my problem...yet... I think it's the fact that the module isn't running on it's own for some odd reason, even though it's supposed to run with the kernel... So... How would I go about making them load automatically?

I use Gentoo by the way, I'm emerge happy
 
Old 05-21-2007, 01:33 AM   #4
samstar
Member
 
Registered: Apr 2007
Distribution: suse 10.2
Posts: 324

Rep: Reputation: 31
Hi,

Did you try to 'modprobe snd-intel8x0'? That should load your soundcard driver as well as autoload the ac97 drivers.

To load this at boot up, you can add the module name 'snd-intel8x0' to your /etc/modules.autoload.d/kernel-2.6 file. That is, if you're using the latest Gentoo.

You can also try to emerge 'hotplug' and 'coldplug' daemons, and rc-update them, to run at boot and try to install relevant modules.

Sam
 
Old 05-21-2007, 01:44 AM   #5
Chryyz
Member
 
Registered: Dec 2004
Distribution: Slackware 10, Gentoo
Posts: 46

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by samstar
Hi,

Did you try to 'modprobe snd-intel8x0'? That should load your soundcard driver as well as autoload the ac97 drivers.

To load this at boot up, you can add the module name 'snd-intel8x0' to your /etc/modules.autoload.d/kernel-2.6 file. That is, if you're using the latest Gentoo.

You can also try to emerge 'hotplug' and 'coldplug' daemons, and rc-update them, to run at boot and try to install relevant modules.

Sam
Nope...

Code:
Malevolence chryyz # modprobe intel8x0    
FATAL: Module intel8x0 not found.
Malevolence chryyz # modprobe snd
FATAL: Module snd not found.
Malevolence chryyz # modprobe ac97
FATAL: Module ac97 not found.
I'm really starting to get a headache with this, and I think it's just a module problem... Because as seen in the lsmod statement above, the only thing I have loaded is an nvidia graphics mod which I had to reinstall to get running because it didn't want to run automatically. Modprobe gives me the "FATAL: Module xxx not found." error on everything I try. Any suggestions?
 
Old 05-21-2007, 02:47 AM   #6
samstar
Member
 
Registered: Apr 2007
Distribution: suse 10.2
Posts: 324

Rep: Reputation: 31
The proper command is 'modprobe snd-intel8x0', not just 'intel8x0'. All, or most sound modules have the snd- prefix attached to them.

Sam
 
Old 05-21-2007, 07:57 AM   #7
Chryyz
Member
 
Registered: Dec 2004
Distribution: Slackware 10, Gentoo
Posts: 46

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by samstar
The proper command is 'modprobe snd-intel8x0', not just 'intel8x0'. All, or most sound modules have the snd- prefix attached to them.

Sam
Yeah, I tried that too, I guess I just didn't include that in the log over there.
 
Old 05-21-2007, 08:11 AM   #8
Okie
Senior Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 1,058

Rep: Reputation: 102Reputation: 102
hopefully you still have your kernel source in /usr/src/linux or symlinked it there, rebuild alsa lib and alsa-driver with the parameter like i said in my previous post (alsa-driver needs your kernel source in order to build a driver)...
 
Old 05-21-2007, 03:11 PM   #9
samstar
Member
 
Registered: Apr 2007
Distribution: suse 10.2
Posts: 324

Rep: Reputation: 31
You probably built them, but not as modules. They might be compiled into your kernel instead - a bad idea if you ever want to disable them, reload them, or change options on them. Go back to your kernel configuration, and select the drivers you want as modules, not as compiled in, and then rebuild the kernel. In fact, make sure most drivers are built as modules, and everything in 'alsa' is built as modules.

Now make sure you add the command 'make modules_install' after it is finished building.

Sam
 
Old 05-21-2007, 04:07 PM   #10
Chryyz
Member
 
Registered: Dec 2004
Distribution: Slackware 10, Gentoo
Posts: 46

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by samstar
You probably built them, but not as modules. They might be compiled into your kernel instead - a bad idea if you ever want to disable them, reload them, or change options on them. Go back to your kernel configuration, and select the drivers you want as modules, not as compiled in, and then rebuild the kernel. In fact, make sure most drivers are built as modules, and everything in 'alsa' is built as modules.

Now make sure you add the command 'make modules_install' after it is finished building.

Sam
Great idea, I'll try that later today.
 
Old 05-23-2007, 06:52 AM   #11
Chryyz
Member
 
Registered: Dec 2004
Distribution: Slackware 10, Gentoo
Posts: 46

Original Poster
Rep: Reputation: 15
Hey! Here's an update. I got the sound working with your suggestion samstar. So thanks for that ^.^

However, MPlayer still gives me a weird error when I play something, it's a little popup that becomes a real pain when playing a list of files.

Here's what it gives me:

Code:
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
Any idea what that's about?
 
Old 05-23-2007, 03:09 PM   #12
samstar
Member
 
Registered: Apr 2007
Distribution: suse 10.2
Posts: 324

Rep: Reputation: 31
You need to also enable alsa's oss emulation in your kernel. Not all programs are completely liberated from oss, and this helps transition them.

I guess another kernel rebuild is in order - but gentoo users should be used to that

Sam
 
Old 05-23-2007, 08:33 PM   #13
Chryyz
Member
 
Registered: Dec 2004
Distribution: Slackware 10, Gentoo
Posts: 46

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by samstar
You need to also enable alsa's oss emulation in your kernel. Not all programs are completely liberated from oss, and this helps transition them.

I guess another kernel rebuild is in order - but gentoo users should be used to that

Sam
Well... I did enable OSS... Soo... uhh...?
 
Old 05-23-2007, 11:35 PM   #14
samstar
Member
 
Registered: Apr 2007
Distribution: suse 10.2
Posts: 324

Rep: Reputation: 31
You built them as modules also?
 
Old 05-23-2007, 11:38 PM   #15
Chryyz
Member
 
Registered: Dec 2004
Distribution: Slackware 10, Gentoo
Posts: 46

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by samstar
You built them as modules also?
Affirmative.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Realtek AC97 OnBoard Soundcard not working aroden Linux - Hardware 1 01-23-2006 07:22 PM
Installing Onboard AC97 sound in Mandrake 9.1 dhanagopal Linux - Newbie 12 11-13-2003 05:31 AM
realtec ac97 onboard sound bryanlivengood Linux - Hardware 1 07-16-2003 10:27 AM
Slackware sound (AC97 onboard) slacker001 Slackware 12 06-16-2003 01:51 AM
SiS 7012 AC97 onboard sound MatthewTux Linux - Hardware 4 03-29-2003 06:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 03:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration