-   Linux - Hardware (
-   -   New Computer - Old Hard Disk - Boot Problem (

Ingla 03-21-2007 06:08 PM

New Computer - Old Hard Disk - Boot Problem

I'm running Ubuntu 6.06 (Dapper). I have a new computer and am trying to boot the disk on it.

I've managed to find the right IDE connection so Linux boots, but it only gets a console screen and cannot run the GUI.

Both machines use VIA chipsets, but the new one is apparently a later series.

Is there any way I can get Dapper to recognize the new hardware or use/find the right drivers (or whatever it needs) ... short of reinstalling from scratch ( a most unwelcome prospect)?

Any help greatly appreciated.


Benanzo 03-21-2007 06:14 PM

so it is able to boot, right? grub finds the correct drive with Ubuntu but it just goes to a console instead of starting X? Do you get any errors on the boot screen? try running dmesg once you get to the console to see if it's having any problems with the Via hardware. Also, when you're at the console and you type startx what happens?

do this at console to see if X is having errors:

cat /var/log/Xorg.0.log | grep EE

pixellany 03-21-2007 06:32 PM

Old hard disk + new computer makes me nervous. Hard drives are one of the few things that actually wear out in computers.

If you installed Linux on a different machine, then it probably has the wrong video driver specified in /etc/X11/xorg.conf

What is the video card in the new box?

Ingla 03-21-2007 06:46 PM

Thanks for the reply.

Yes, GRUB finds the drive (after a bit of playing around to find the right IDE connection).

The problem is I'm sort of a newbie (been using Ubuntu for some time, but have no idea how to function in console).

I received an error notice about GDM not being configured (I've seen this occasionally but the error notice was not quite accurate ... rebooting or something else solved it then).

I didn't type startx (didn't know the command), but instead pressed cntrl+alt+F7 to leave console and go into the GUI. Got the same type of error message that the GUI was disabled and needs configuring.

What is dmesg? Do I just type that?

I'm on Linux now in the old machine, so posts back and forth will take some time as I need to move the hard disk to the new machine each time I want to to try something ... and then back to the old one to access the forum.

As it's quite late in my time zone, I might have to try fixing this tomorrow. Are you likely to be online sometime then?


Ingla 03-21-2007 07:09 PM

The hard disk is new and running fine on the old machine. I'm thinking drivers.

Must be getting tired. Can't identify driver in the conf file:

Contents of file:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY

Section "Device"
Identifier "S3 Inc. VT8375 [ProSavage8 KM266/KL266]"
Driver "savage"
BusID "PCI:1:0:0"

Section "Monitor"
Identifier "AOC Spectrum"
Option "DPMS"
HorizSync 30-72
VertRefresh 50-160

Section "Screen"
Identifier "Default Screen"
Device "S3 Inc. VT8375 [ProSavage8 KM266/KL266]"
Monitor "AOC Spectrum"
DefaultDepth 16
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"

Section "DRI"
Mode 0666

Can you see a video driver?

I'm checking the documentation to see about the video card. Haven't found it. I might have to go to Windows to run a program to spot it.

Benanzo 03-21-2007 08:33 PM

the video driver is in the Device section.

you're using the savage

Section "Device"
Identifier "S3 Inc. VT8375 [ProSavage8 KM266/KL266]"
Driver "savage"
BusID "PCI:1:0:0"

something tells me the motherboard in the new machine doesn't use the savage driver, if it even has a VIA chipset.

do this at the terminal and follow the instructions:

sudo dpkg-reconfigure xserver-xorg

this will reconfigure xorg to use the graphics in the new machine

Ingla 03-22-2007 03:54 PM


I ran the reconfigure program and there seems to be a problem. It says it can't detect a video card so either there isn't one (not true Windows XP has no problem with it), or it isn't supported by Dapper (more likely).

After continuing as best I could, I got to choosing color depth and the console said "warning, overwriting custom file" but wouldn't let me answer anything (no "y/n" options). I didn't know what to do with that. Hitting ENTER just gave me a prompt so I could only start the config program again or shut down.

Running AIDA on XP in the new machine said the video adapter was VIA Chrome9 HCIGP using driver S3giGP ( Their site says they have a Linux driver, apparently one for Ubuntu, but I couldn't figure out their site as they were asking me to choose between some options that were meaningless to me. So, I didn't download any of them.

I also wouldn't know how to install it from the console (no idea if it's a deb or tar.gz or what). And, if I did manage to install the driver but Dapper doesn't know the card exists ... then what.

I'm not sure what to do at this point. Even a reinstall probably wouldn't work if Dapper doesn't support the motherboard's video card. It is a pretty new machine (I think the motherboard has only been in the world a few months).

Any ideas?

Benanzo 03-22-2007 04:19 PM

a reinstall probably would work because no matter what video chip the motherboard has, if linux can't find the correct driver when installing then it will just use the vesa driver which is very generic and works with every video card. So you'll at least get x working with that. however, I think the chip you have either uses the savage driver or the unichrome driver, both of which are in the dapper repositories. I might also suggest you upgrade to Edgy or maybe get the latest Feisty build. They both have newer versions of the drivers for that chip, although dapper should work just fine after reinstall.

Ingla 03-22-2007 04:59 PM

Thank you for the reply.

It used to be the case with Windows, that I could reinstall the OS on top of itself, which went back to defaults for certain configurations, but left my files and lots of stuff intact.

As far as I know, my only option with Ubuntu is to format the hard drive and start from scratch ... very unfortunate.

Is there any other option?

tredegar 03-22-2007 06:26 PM

You are new, and struggling, & I feel sorry for you.

been using Ubuntu for some time, but have no idea how to function in console
It is a good idea to play and learn, whilst your system is still working - then you are not so lost when something serious needs fixing, and a complete change of hardware isn't trivial, or insurmountable!

Anyway, your problem is that the new hardware is not being set up properly by the old hard disk install. Probably all that needs fixing is the video configuration, but there may be other hardware issues (eg sound, network) as well.

The easiest option for you is to back up your personal files (from /home/username/*), (and don't forget to export & backup your browser's bookmarks!)

If you can, copy all of /home/username/* to a CD or similar. You never know what you might need to refer to later.

Then do a fresh install on your new hardware, apply the updates, and then restore your personal files.

The other option is to learn some command line (CLI) stuff, but if you are saying "What is dmesg? Do I just type that?", you might have to be prepared to exercise parts of your brain you didn't know existed. Your brain might enjoy that.

However, there are plenty of people on this board who will do their best to help you step by step of you wish to follow the "intellectual" (and rational) CLI route rather than "brute force" way. It all rather depends on your timescale, and I do appreciate that swapping HDD's between computers to regain net access, and answers to questions, is very awkward. (Yup, been there, done that!).

I wonder, does your new hardware have a nice new, shiny, clean, empty HDD?

So, linux is partly about choice. Which option do you choose? (Hint: It's kind of a Zen question!)

Ingla 03-22-2007 07:52 PM


Thanks for the reply.

In general, I have used command line quite a bit, but with help from this and other forums. I first came to computers when DOS was on its way out and have little experience with that either. However, when necessary, i've found the proper commands and done whatever had to be done.

Having said that, I admit I keep my knowledge of such things on a "need to know basis". That means I use a computer for serious business purposes and I prefer, as a user, to work with the GUI. This is simply because, if I have to copy or rename a file, I need to do it fast and a click is superior to lengthy commands like mv where I have to be careful of every key I hit. Just no time. I don't hesitate to use the command line when the GUI can't do it for some reason.

On the other hand, in problem situations, I like what Linux can do. I find out the commands and keep text files on all such procedures in case I need them again. All this has made things much easier as I have installed Linux numerous times (new hard disks, etc.) and simply set it up using the GUI or the terminal, whichever I need.

But, since I change computers and hard disks more often than many folks, it would be well worth my while to learn how to fix things like this and will save any information I learn with copious notes.

One problem: I'm in a different time zone from a lot of people on this forum (GMT +2), which means it's almost 1:30 AM right now, so I can't write back and forth much longer as I have to get up tomorrow. Then when I come back on, I'll have trouble finding the same person who was in the middle of guiding me.

I can spend some time on this and I don't imagine setting up video and sound cards would be the end of the world. I'm supposed to give the old computer to someone else, but told him the time line depends on me having my Linux disk working on the new one.

I do regret not having put my home folder on a separate partition from the start (before I filled it up so much ... backup will require DVD's). My standard procedure when installing Windows is to put the OS on a small partition and everything else on another. I should have done that with Linux too.

I have one advantage. I'm running two computers with a switch that lets me assign the screen to either and can therefore access the forum on my Windows box with Ubuntu running on the other. Just switch the monitor to Linux, run the commands, and jump back over to the forum. No reboots or physical hard drive moving.

My goal for sometime has been to switch away from Windows entirely. I'm about 80% there and only use Windows for necessary work which can't be done so easily on Linux (such as using existing and complicated Access data bases, which cannot readily be imported to a Linux program and which are mission critical for work (that's one of my future projects).

I wouldn't be able to start the project for a couple of days. If I could find a way to contact my "guide" during hours I can work, I'd be happy to learn.

tredegar 03-23-2007 03:44 AM


Then when I come back on, I'll have trouble finding the same person who was in the middle of guiding me.
You should set up LQ so you receive an email alert when someone replies to a thread you have posted to. This makes it very easy to keep track of threads you are interested in: This page: Edit Options ->
Messaging & Notification -> Default Thread Subscription Mode -> Instant email notification.

Then you check your emails from LQ, and from there, open the handy links directly to your subscribed threads.

Ingla 03-23-2007 10:32 AM

I do get e-mail notification. But, depending on where the poster is, I may not see it till he's off. I get tons of spam due to running a couple of web sites, so I no longer download messages automatically but choose to delete or download at the servers. Therefore, I might not see a message till the next time I check the mail.

I'll just try to hook up with someone when I come online and, if there's still time in the evening, try to get a realtime dialogue so I can try the command line and report right back, etc.

Hope to get on this Sunday.

Thanks very much.

Ingla 03-25-2007 02:14 PM

tredegar are you available?

tredegar 03-25-2007 05:41 PM


tredegar are you available?
I'm sorry to say that the answer is No. I'm just about to go to bed, & it's been a long day, and we have changed the clocks, so I have to get up earlier tomorrow.

Don't despair though: Just post your problem, and give the details (having already searched for the solution of course!) and someone on this board, will I hope, jump in with an answer or at least some pointers in the right directions.

With any luck, by the time I get back to this board, you'll have your problem resolved. That would be good - because someone else provided the help you needed, and you didn't have to wait for me to reply (though I'm flattered!).

LQ is not like mobile-phone or instant messaging (I never used either - perhaps I'm a dinosaur?).

Just post your question. If no one answers it, I'll get back to this thread later and follow it up.

All times are GMT -5. The time now is 06:23 PM.