LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   New Canon printer - wireless not working (http://www.linuxquestions.org/questions/showthread.php?t=4175476136)

Steve W 09-06-2013 03:58 AM

New Canon printer - wireless not working
 
I have a friend who has just bought a new Canon MG3250 printer/scanner. He is having trouble getting it to print wirelessly on his Ubuntu 12.04 laptop, even though his other Epson printer has no problems printing wirelessly with the same laptop. He doesn't use LinuxQuestions and is quite new to Linux, so I said I'd put a question on here for him.

The Canon printer does print successfully when connected wired through the USB port.

Although the printer's wireless light is on and the printer gives every indication that it should print, it doesn't. Ubuntu also does not "find" and list the printer when he tries to "Add printer". However, when his previous Epson printer is switched on, it finds that immediately and lists it.

Am I right in thinking that the printer would not be receiving data straight from the laptop, but that the wireless capability is made possible through his normal broadband router? I mean, does the data go from laptop to router, then on to the printer? Or does this vary from printer to printer?

The printer is a Canon MG3250. The router (if that's relevant) is a Sagem connected to a Sky HD Box (he's with Sky Broadband).

The printer manual does say that you need to "push the WPS button" on the router during set up, but there is no such button on either of his Sky boxes. I wonder whether that is the reason it doesn't work - although he did not have to do this with his other printer, and that still works. Information on the internet says that if a router has no WPS button, you must enter the SSID code into the printer, so it can find your router. But how does one do this? I can't enter it directly into the printer, as there is no keypad. Is there somewhere on the printer setup for Ubuntu where this should be entered? There is something about "Find by address", but entering it here produces no result.

It has occurred to me that the wireless capability of the printer may be faulty, and it doesn't connect to anything. However, it is more likely that it isn't set up correctly.

The instructions with the printer contains no "troubleshooting" information - and certainly not for Linux.

Thank you for any help you can give. I have tried Googling help for this but - predicably - most help is for Windows and seems centered around the Windows drivers/software supplied with the printer.

camorri 09-06-2013 08:40 AM

You may find this post helpful.

-->http://www.tomshardware.com/forum/27322-43-sagem-router

The WPS key is a auto - configuration function available on some routers. If your router does not have one, you have to go into the router setup to see how the router is configured. This post suggests the router comes with
Quote:

Sky supply routers set up for WPA PSK TKIP
. Note the pass phrase is supposed to be on the case of the router.

Quote:

Am I right in thinking that the printer would not be receiving data straight from the laptop, but that the wireless capability is made possible through his normal broadband router?
Yes. It might be possible to set up an Ad-hoc connection ( system to printer without the router ) that would not be desirable in most situations. Going through the router makes the printer available to all systems on the router.

To get the SSID of the router, in a command prompt, you can run the command 'iwlist scan' ( without the quotes ) and that will cause the system to scan the area and list any access points that are there.

It is better to connect to the router with the ubuntu system, log in, and all the information will be there. Documentation for the router may have come with it, or you can google for it. Most manufacturers have it online, or in .pdf format.

BTW, this is not a linux problem, this is a network configuration issue. The printer needs an IP address from the router, and since it appears the router is using WPA encryption, you will need to configure the printer.

From what you have posted, it is hard to understand how the old printer ever worked. Did someone with network knowledge configure it?

Hope this helps.

thorkelljarl 09-06-2013 11:20 AM

If it's the same...

I have a Canon MG5450 installed as a wireless printer under openSUSE 12.2.

It required firstly that my computer was connected to my router and that the router was available for connection by other devices on a common band and standard(2.4Ghz, 802.11n only in my case), with the correct encryption enabled and an SSID shown so I could find it. Then I needed to turn on the printer and use its built-in function to find and connect to my router, using the encryption matching that of the router.

Thereafter, I could begin configuring the connection in linux, using the Canon drivers and following the instructions in the manual I downloaded from Canon Support for my model. Installing that way (terminal command from tar.gz) presented me with an option to choose a wireless installation. It worked.

Have you established all necessary links and how did you install the drivers?

There is a guide for connecting your printer to a router. It is MG3200_NonPC_EN.pdf, from Canon Support, MG3250, Manuals.

Steve W 09-07-2013 04:05 AM

Thank you for the advice. Next time I'm round his house, which won't be till later in the week, I will run through the suggestions (including the command 'iwlist scan') and see if it works then.

I did download drivers from the Canon website for that series of printers, and installed them. I think it was a tar with an install.sh inside it, so it was all straightforward. However, having installed the drivers the command line tried to connect but was unsuccessful. But the printer works using the USB connection and a lead, so is it likely to be a driver issue?

I remember that his laptop previously ran Windows Vista with the older printer, so I assume the printer would have been configured to work with the router already by Vista, so presumably switching to Ubuntu would not have affected the connection between router and printer. I don't think my friend would have set this up manually, nor to my knowledge would anyone else.

thorkelljarl 09-08-2013 08:21 AM

What to say...

camorri is doubtlessly right about it being a network problem. I would guess that the printer and router haven’t connected correctly. With this Canon model it seems that you can't manually configure the printer with the needed information about the router (SSID and encryption standard, password), and with no WPS button, there may be no automatic connection function signal for the printer to find. I believe the relevant reference here involves a chicken and an egg.

Assuming that the router is working as it should, you could first try to repeat the automatic connection routine on the printer with the two devices close to each other. If the blue WI-FI light is on, there may be hope, but I think the light only indicates a working radio connection.

Otherwise, you probably need a Windows or Apple machine to setup a wireless connection using a USB cable. Canon support has information as a FAQ. Google. Hopefully the connection will still be there after you switch to linux, but I wouldn’t be sure about what happens if the printer or router is unplugged. In any case, always turn the printer or both devices off beforehand.

As I first posted, things have to be set up in sequence, and you have to be sure to check for faults following in sequence.

First possible problem first; you may have more than one. Good Luck

Steve W 11-15-2013 02:59 AM

Well, I have managed to get the wireless printing function working. But now I have a second problem: the printer has built-in scanning facilities, but I cannot get the scanner to be recognised by the computer, using either SimpleScan or XSane. The Canon printer can, however, scan "by itself", meaning it can scan in something and then immediately print it out, like a photocopier.

I did locate a scanner driver package for this range of printer-scanners from Canon's website, and installed them, but to no avail.

Is there a command I can type in to a shell in order to see the state of play for any scanning devices please? Ubuntu system settings has an entry for "Printers", but not for "Scanners".

The computer also fails to recognise any scanning device when connected through a USB cable; so I think it's either a configuration or driver issue.

camorri 11-15-2013 06:43 AM

You need the sane package installed. Then the command sane-find-scanner will try to locate your scanner.

It will locate parallel port scanners and USB scanners, however I do not think it was designed to look for wireless scanners.

Might be a good idea to check the version of scanimage you have installed. At the command prompt, run the command scanimage -V and you should get the version info. Version 1.0.22 is the latest.

thorkelljarl 11-16-2013 10:56 AM

Scanner...

How are you trying to use the scanner. If this model is like my Canon MG5450(Canon linux drivers installed using openSUSE 12.2 with KDE desktop)the scanner opens only by command.

For me, the easy way to scan is to open a search box window with the command "Alt+F2" and type the command "scangearmp". Thereupon a scan function window opens. Otherwise, I can open a terminal and use the same command and the same window opens.

cammori writes SANE, but the Internet tells me that the Canon MG series doesn't use SANE and that you need to use the Canon linux drivers for this machine. You should have installed two, one "Common" and one for this model.

By the way, I was wrong telling you that you needed a Windows or Apple machine to connect this All-in-One to a wireless router. It can be setup by entering the WPS pin code.

http://en.wikipedia.org/wiki/Wi-Fi_Protected_Setup

Steve W 11-21-2013 10:46 AM

“sane-find-scanner” produces amongst other things “found USB scanner”. I am trying to scan using wifi – I know this is working for the device because it prints via wifi; it's just the scanner function that isn't working, even though it's the same device.

Typing “scanimage -V” produces, after a pause, “scanimage: no SANE devices found
”. No version info is given.

Typing “scangearmp” pops up a window “cannot find available scanners”.

Starting any scanning application like SimpleScan just produces more “device not found” messages.

Is there anything I can type into a shell that will determine if any necessary drivers are installed?

camorri 11-21-2013 01:17 PM

Have you found a sane back-end this multi-function printer/scanner? I have looked extensively, and can not find a sane backend for this device. The best bet for Canon devices is their European site. There is a cups driver there for the MG3250, but no scanner driver for linux. There is one for OSx, for MAC users.

If you have a back-end, please post the information. Then we may be able to help.

thorkelljarl 11-22-2013 05:09 AM

Begin again...

There are linux drivers for the printer and scanner function of the MG3250 from Cannon support, Europe.

http://www.canon-europe.com/Support/...MA_MG3250.aspx

The SANE backend now seems to have the MG3200 series listed as supported but that's not a guarantee for your case.

http://web.archiveorange.com/archive...GwRWlFycKTxWr9

Were it my problem, I would remove everything. I mean both the configuration of the MG3250 in your system and the Canon drivers and whatever else (SANE and Cups) I had otherwise installed previously. Then I would install the Canon drivers again. First after making a good effort with the drivers, would I remove them and try Cups and SANE.

You're trying two methods at the same time, and might well have mixed the package versions needed for each method, or have some conflict in the configuration of what's installed.

In any case, reinstalling the Canon drivers with their automatic Wi-Fi configuration function seems to me to be your best bet, although the guides found in the printer and driver packages have to be followed carefully.

Steve W 12-20-2013 03:35 AM

I have carried out your instructions on my friend's laptop, Thorkelljarl, and it now all works - scanning and printing wirelessly. Thank you very much for your assistance.

Quote:

The easy way to scan is to open a search box window with the command "Alt+F2" and type the command "scangearmp". Thereupon a scan function window opens. The Canon MG series doesn't use SANE and you need to use the Canon Linux drivers for this machine.
For clarity to anyone else reading this thread, having the same problem with their Canon device: as Thorkelljarl advised, the scanning part of the system works only with the Canon "ScanGearMP" program that the driver package installs, though for convenience of my friend I have put a launcher to this program on the desktop. At this time, it doesn't appear to work with any scanning application downloaded from the Ubuntu Software Centre.

Thank you once again for your invaluable assistance.

thorkelljarl 12-20-2013 05:17 PM

And thank you...

I'm only the one typing my best efforts at advice, you're the one helping a friend.


All times are GMT -5. The time now is 09:01 AM.