-   Linux - Hardware (
-   -   Network time-out Slackware 10 kern 2.6.7 Network everwhere NIC (

EdwardA 06-25-2004 02:58 PM

Network time-out Slackware 10 kern 2.6.7 Network everwhere NIC
I'm running Slackware 10.0 with kernel 2.6.7 compiled and working. On this kernel and the 2.4.26 kernel my internet connection seems to die at random times. I have to reboot to bring it back up. I try to manually use ifconfig eth0 down then up and it doesn't start. i run dhcpd and i get an error mesg. My card is recognized correct under lspci but in dmesg its recognized as AMD comet. I've run netconfig and set everything up. It works great for a while then it just dies. It mainly dies under heavyload like when i'm playing Call of Duty online or d/l a large file. I dual boot with windows XP PRo and i have noe time-out problems on XP so it has to be a problem somewhere in linux. I'm just not sure where. heres the differant outoputs for referance:


00:00.0 Host bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x] (rev 42)
00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C596 ISA [Mobile South] (rev 11)
00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C/VT8235 PIPC Bus Master IDE (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0 controller] (rev 05)
00:07.3 Host bridge: VIA Technologies, Inc. VT82C596 Power Management (rev 20)
00:0a.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 0a)
00:0a.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 0a)
00:0b.0 Ethernet controller: Linksys Network Everywhere Fast Ethernet 10/100 model NC100 (rev 11)
01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 440] (rev a3)

dmesg | grep eth

eth0: ADMtek Comet rev 17 at 0xb400, 00:04:5A:6E:43:AA, IRQ 10.
eth0: Setting full-duplex based on MII#1 link partner capability of 45e1.


Module Size Used by
nvidia 2075592 12
via_agp 7168 1
emu10k1_gp 2944 0
gameport 4096 1 emu10k1_gp
tulip 44832 0


# Config information for eth0:

anyhelp would be greatly appreciated. I'm trying to convert completely over to linux but i have to get this network thing fixed first.

finegan 06-26-2004 07:08 AM

Have you got the tail of the kernel dmesg, also maybe /var/log/messages and/or syslog, also what's the dhcpcd error? The tulip driver got hacked into like 4 different drivers with 2.6, so it might be the wrong options compiled in or maybe just the wrong driver for the chipset, since yours is an older one (I've got like 4-5 of those cards in business, they were the shizzle before the rtl8139 and the eepro100 stepped up).



EdwardA 06-26-2004 08:16 AM

thanks for the response finegan. I figured out what my problem was. When i compiled the new kernel i compiled a couple of the tulip drivers as modules. I went back and compiled them straight in the kernel not as modules and now i don't have the network-timeout problem. So i seemed to have fixed it by compiling them directly into the kernel.

thanks again

When in doubt try again :)

All times are GMT -5. The time now is 10:46 PM.