LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Network Interface Card config problem (https://www.linuxquestions.org/questions/linux-hardware-18/network-interface-card-config-problem-596404/)

dcalki 11-01-2007 03:05 PM

Network Interface Card config problem
 
I'm a relative newbie.

I have an old AMD Athlon machine I've set up as dual boot with Win98 and PCLOS/KDE.

My old dial-up modem recently died and I upgraded to DSL service, but I'm having trouble getting the NIC to work from PCLOS.

When I boot into Win98 the NIC diode lights up (next to plug) and I can access the internet just fine.

When I boot into PCLOS the NIC diode doesn't light up at all. I've tried going to Kdrake and configuring the card for ethernet, but it still doesn't appear to function at all (ie. no light/no internet), even though the config gui says everything finished just fine.

Being a nearly clueless newbie, I wonder if I'm missing something obvious or not.

Is there something else I ought to do to configure the NIC from PCLOS? Since the card works fine in Win98 it's probably not a h/w issue.

Any suggestions would be greatly appreciated.

MQMan 11-01-2007 03:08 PM

Does the card show up in ifconfig.

Is the card recognised in Linux. Run lspci to check.

Next, is the driver module being loaded. Which one will depend on the card.

Cheers.

dcalki 11-01-2007 03:14 PM

The hardware shows up in Kdrake. Realtek 8139 ethernet card. It's just that running the config tool from Kdrake doesn't seem to do anything to improve the situation.

What little I could find in research indicated that the linux kernel supported this card without any need of external drivers. I'm just trying to figure out how to put two and two together and make four.


All times are GMT -5. The time now is 04:19 PM.