LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Network cards not recognized (http://www.linuxquestions.org/questions/showthread.php?t=4175458695)

rjkfsm 04-18-2013 07:23 PM

Network cards not recognized
 
Hi. I am doing a new install on an ASUS P5N32-SLI motherboard with a dual core xeon. According to ASUS's website the NIC is the "NVIDIA nForce® 590 SLI™ built-in dual Gigabit/ MAC with external Marvell PHY Support NVIDIA DualNet® technology". The board was made in 2009, so there should be support for the device.

lspci -v gives me this about it:
Quote:

00:11.0 Bridge: NVIDIA Corporation MCP55 Ethernet (rev a2)
Subsystem: ASUSTeK Computer Inc. Device cb84
Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
Memory at fe02a000 (32-bit, non-prefetchable) [size=4K]
I/O ports at b000 [size=8]
Memory at fe029000 (32-bit, non-prefetchable) [size=256]
Memory at fe028000 (32-bit, non-prefetchable) [size=16]
Capabilities: [44] Power Management version 2
Capabilities: [70] MSI-X: Enable- Count=8 Masked-
Capabilities: [50] MSI: Enable- Count=1/8 Maskable+ 64bit+
Capabilities: [6c] HyperTransport: MSI Mapping Enable- Fixed+
Kernel driver in use: forcedeth

00:12.0 Bridge: NVIDIA Corporation MCP55 Ethernet (rev a2)
Subsystem: ASUSTeK Computer Inc. Device cb84
Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 21
Memory at fe027000 (32-bit, non-prefetchable) [size=4K]
I/O ports at ac00 [size=8]
Memory at fe026000 (32-bit, non-prefetchable) [size=256]
Memory at fe025000 (32-bit, non-prefetchable) [size=16]
Capabilities: [44] Power Management version 2
Capabilities: [70] MSI-X: Enable- Count=8 Masked-
Capabilities: [50] MSI: Enable- Count=1/8 Maskable+ 64bit+
Capabilities: [6c] HyperTransport: MSI Mapping Enable- Fixed+
Kernel driver in use: forcedeth
My kernel config has:
Quote:

livecd linux # cat .config | grep FORCEDETH
CONFIG_FORCEDETH=y
In fact, I have every NIC driver and PHY driver enabled and it still isn't being seen by ifconfig.

What am I missing?

RK

Edit: Disabling msi with the msi=0 and msix=0 switches has no effect.

ra.amri 04-19-2013 07:33 AM

Try "ifconfig -a" and see if there is your interface. Maybe the interface is just down and you need to bring it up with "ifup iface" or "ifconfig iface up". What distribution are you using ?

rjkfsm 04-19-2013 05:02 PM

Quote:

Originally Posted by ra.amri (Post 4934685)
Try "ifconfig -a" and see if there is your interface. Maybe the interface is just down and you need to bring it up with "ifup iface" or "ifconfig iface up". What distribution are you using ?

Trying ifconfig eth0 up or eth1 up resulted in a device not found error. I looked through the dmesg output and found that udev was renaming the interfaces with rather odd names. I don't know why, but using those names works fine. I'm marking this as solved.


All times are GMT -5. The time now is 01:39 AM.