LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 10-22-2007, 03:37 PM   #1
Fox2k
LQ Newbie
 
Registered: May 2001
Posts: 11

Rep: Reputation: 0
Nested raid gets disassembled on reboot


Hey all,

I'm having a strange issue with a new raid configuration I am trying out. I currently have a 3 drive raid 5 array of 250 gig drives set up (md0) giving me a 500 gig array. I am trying to set this device up as a component of a larger raid 5 array with a 500 gig drive (hda1) (starting in degraded mode until I get a new drive in the mail). My problem right now is that whenever I reboot the new md device (composed of the raid5 array and the single drive) disappears. I can bring it back with:


Code:
mdadm --assemble /dev/md1 /dev/md0 /dev/hda1

and it show up fine:

Code:
server2k ~ # mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4] [multipath] [faulty]
md1 : active raid5 hda1[0] md0[1]
976767872 blocks level 5, 64k chunk, algorithm 2 [3/2] [UU_]

md0 : active raid5 hdg1[2] hde1[1] hdc1[0]
490223232 blocks level 5, 64k chunk, algorithm 2 [3/3] [UUU]

However, every time I reboot, the md1 device is no longer listed in mdstat.

Does anyone have any idea what might be going on?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Will not reboot after mandriva 2006 Install on RAID 1 Mike Armstrong Mandriva 8 05-15-2006 02:07 AM
understanding gdb output of a C function in disassembled form. koodoo Programming 7 04-12-2006 10:55 AM
Software raid 5 always missing 1 disk after reboot birkinshawc Linux - Hardware 0 05-20-2004 10:57 PM
Nested raid troubles Gandalf_Grey_ Linux - General 0 12-28-2003 09:14 AM
RAID array not work after reboot smartsupport Linux - Hardware 0 11-19-2003 05:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration