LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 07-30-2016, 10:21 AM   #1
achim_59
Member
 
Registered: Jan 2009
Location: Huenfeld, Germany
Distribution: Debian Jessie
Posts: 98

Rep: Reputation: 4
Question Neither internal nor external microphone functioning. Not even USB Microphone (Debian Jessie)


As usual, when it comes to hardware problems I am baffled.

I cannot get any sort of response from any microphone. I have tried checking with the pulse audio capture monitor and by using the arecord command. This was done variously using the internal mike, a Sennheiser headset, and an external mike. All results were negative.

Technical details are:
Kernel: 3.16.0-4-amd64
System: Debian 8.5

List of sound devices:
Code:
cat /proc/asound/cards
 0 [HDMI           ]: HDA-Intel - HDA Intel HDMI
                      HDA Intel HDMI at 0xf7e14000 irq 64
 1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7e10000 irq 61
When I plug in my headset, it is recognised by the system (2nd last line):
Code:
root@ascomtux:/home/achim# lsusb
Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 004: ID 5986:0536 Acer, Inc 
Bus 002 Device 003: ID 8087:07dc Intel Corp. 
Bus 002 Device 005: ID 0557:2221 ATEN International Co., Ltd Winbond Hermon
Bus 002 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 002 Device 006: ID 1395:3554 Sennheiser Communications 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
I have the ALSA mixer installed. In order to get a visual of the audio input (that was the intention, anyway) I also installed the pulse audio volume control and associated monitoring tools.

As mentioned, I am baffled. The playback is fine and I have no problems manipulating sound files otherwise.

What can I do to track down the problem? I had considered a hardware problem, but 3 different input devices?? Unlikely. Besides, I know for a fact that the mike on the headset works.

Suggestions anyone?
 
Old 08-01-2016, 02:33 PM   #2
sgosnell
Senior Member
 
Registered: Jan 2008
Location: Baja Oklahoma
Distribution: Debian
Posts: 1,054

Rep: Reputation: 281Reputation: 281Reputation: 281
In pavu, select the configuration tab, and make sure the correct settings are enabled. Then do the same on the input tab. HDMI is not the correct default for input. You'll need the external mic connected to configure it, because it won't show up if not connected. The internal mic should be shown, though, regardless of the state of any external devices.
 
Old 08-14-2016, 08:11 AM   #3
achim_59
Member
 
Registered: Jan 2009
Location: Huenfeld, Germany
Distribution: Debian Jessie
Posts: 98

Original Poster
Rep: Reputation: 4
Thanks for your advice sgosnell and sorry for the extreme delay replying... illness in the family.
I'm not sure I really understand the advice, though.

With "pavu" I assume you mean the pulse audio volume control. I checked out the configuration tab and found 2 profiles:
1. Labeled "Builtin Audio". Set to "Digital Stereo (HDMI) Output (unplugged)"
2. Labeled "Builtin Audio". Set to "Analog Stereo Input"

The first profile has 2 other options: "Digital Surround 5.1 (HDMI) Output (unplugged)" and "Off". Both digital options are listed 3 times in the drop down menu.
The second profile has 3 other options: "Analog Stereo Duplex", "Analog Stereo Output", and "Off". Nothing is marked as default.

On the "Input Devices" tab the Label is "Builtin Analog Stereo Audio". I've switched of the "fall back" button, made sure that it's not muted and then checked the pulse audio volume meter (capture). It would seem that there is sound being captured. Unfortunately I cannot determine if this has fixed my Skype problem, since I don't have the access details with me. I'm not at home and don't have the password and such with me. I will give it a go when I get back to my office later today and post the results.

It looks like I've interpreted your answer correctly.

Last edited by achim_59; 08-14-2016 at 08:12 AM. Reason: spelling
 
Old 08-14-2016, 11:48 AM   #4
achim_59
Member
 
Registered: Jan 2009
Location: Huenfeld, Germany
Distribution: Debian Jessie
Posts: 98

Original Poster
Rep: Reputation: 4
I have no one with whom I could skype at this hour, since my contacts are on the other side of the globe. However, the skype "Echo / Sound Test Service" has worked for the first time. I had to fiddle around with the configuration again in order to get sound working again. I have no idea what caused it to be switched off. So here are my current settings in the hope that it will help somebody else who has Debian Jessie and a problem with their mike.

The following settings are made in the pulse audio volume control application:
Configuration tab -
Profile 1 = Digital Stereo (HDMI) Output [Note that it is not unplugged!]
Profile 2 = Analog Stereo Duplex
Playback tab -
Mono set to around 30% - 35%
Recording tab -
Both channels set to around 30% - 35%
Output Devices tab -
2 profiles :
Builtin Audio Analog Stereo - Port = Speakers - both channels unmuted and set to 100%
Builtin Audio Digital Stereo (HDMI) - Only Port = Display - both channels unmuted and set to 100%
In both cases the button for setting as fall back is checked with a green tick.
Input Devices tab -
Builtin Audio Analog Stereo - Port = Internal Microphone - both channels set to 100%
Set as fall back

Note that clicking the mute icon always set any of these items to "disabled" or "greyed out".

One more thing to check if you also have the ALSA mixer installed as I do: make sure that the following are not muted or set to 0 : Master, Speaker, PCM, Microphone. Leave the microphone boost and the internal microphone boost turned on (unmuted) but be wary of inceasing the level much over 10%. In my case it made the recording way too sensitive. Might be worth it if you have a super quality microphone... I certainly don't and cannot judge this.

I will mark the thread as solved and hope this helps someone else.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Internal microphone not working - Debian Squeeze + Dell Latitude E6410 Zaraphrax Linux - Laptop and Netbook 7 12-03-2017 07:41 PM
Internal microphone broken? How can I find out? duplex Linux - Hardware 6 12-08-2014 12:08 PM
Unable to use my internal microphone dspjm Linux - Hardware 2 07-31-2011 10:44 PM
virtual microphone: FILE ---> MICROPHONE ---> APPLICATION jamal_mohammadi Linux - Hardware 1 02-13-2011 04:10 PM
[SOLVED] Internal microphone not working with KDE alfredo10 Linux - Desktop 4 10-07-2010 02:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 11:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration