LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 04-08-2013, 12:56 PM   #1
Phoenix_Swelter
LQ Newbie
 
Registered: Feb 2011
Posts: 11

Rep: Reputation: 0
Need to (re)-enable wi-fi device in kernel module


A year or so ago I found an article online about how to disable my wi-fi device in the kernel. Knowing I was never going to use the wi-fi, and disliking the need to turn off the bright orange wi-fi light every time I booted, I disabled it.

Now I need wi-fi capability, and I can't remember what I did to disable it!

I am running Kubuntu 12.10 on an Aspire 5610. lspci shows the controller as an Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02). The kernel is 3.5.0-26

lsmod shows 3945 in the following places:
iwl3945 63696 0
iwlegacy 87811 1 iwl3945
mac80211 461261 2 iwl3945,iwlegacy
cfg80211 175574 3 iwl3945,iwlegacy,mac80211

Any suggestions?

Last edited by Phoenix_Swelter; 04-08-2013 at 01:06 PM.
 
Old 04-08-2013, 06:11 PM   #2
evo2
Senior Member
 
Registered: Jan 2009
Location: Japan
Distribution: Debian
Posts: 4,817

Rep: Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011
Hi,

a quick web search seems to indicate that iwl3945 is the correct module... normally I would disable a device by blacklisting the corresponding kernel module, but it seems that is not the path you took. Are you sure it is really disabled? Do you see the device when running iwconfig and 'ifconfig -a'?
Also, what does 'rfkill list all' show (from the rfkill package)?

What method are you using for network configuration? Eg /etc/network/interfaces, wicd, network-manager, etc?

Evo2.
 
1 members found this post helpful.
Old 04-09-2013, 04:06 PM   #3
Phoenix_Swelter
LQ Newbie
 
Registered: Feb 2011
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by evo2 View Post
Hi,

a quick web search seems to indicate that iwl3945 is the correct module... normally I would disable a device by blacklisting the corresponding kernel module, but it seems that is not the path you took. Are you sure it is really disabled? Do you see the device when running iwconfig and 'ifconfig -a'?
Yes, I do see the device with both iwconfig and ifconfig -a.

Quote:
Also, what does 'rfkill list all' show (from the rfkill package)?
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

Quote:
What method are you using for network configuration? Eg /etc/network/interfaces, wicd, network-manager, etc?
Not /etc/network/interfaces. That file only contains:
auto lo
iface lo inet loopback

So, whatever was the default for the Kubuntu installation.
Edit: Apparently it is currently NetworkManager.

Addendum:
I found on the net how to get rid of the Hard block. Now both Soft blocked and Hard blocked read 'no'.

But the wireless HW switch still seems to do nothing - the power light is always off. And I was unable to find any BIOS option to enable or disable wireless.

Thanks for the reply - I hope this helps you get me on the right track

Last edited by Phoenix_Swelter; 04-09-2013 at 04:39 PM.
 
Old 04-09-2013, 11:12 PM   #4
evo2
Senior Member
 
Registered: Jan 2009
Location: Japan
Distribution: Debian
Posts: 4,817

Rep: Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011
Hi,

other than the light being off, it sounds like it is working. Can you see any access points if you run a scan? Eg:
Code:
iwlist wlan0 scan

Evo2.
 
Old 04-10-2013, 12:14 AM   #5
EDDY1
Senior Member
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: DebianSqueeze, winsxp, wins7, Debian wheezy, LFS 7.2
Posts: 4,658

Rep: Reputation: 408Reputation: 408Reputation: 408Reputation: 408Reputation: 408
Have you tried
Quote:
rmmod -f iwl3945
rfkill unblock all
modprobe iwl3945
 
Old 04-10-2013, 05:30 PM   #6
Phoenix_Swelter
LQ Newbie
 
Registered: Feb 2011
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by evo2 View Post
Hi,

other than the light being off, it sounds like it is working. Can you see any access points if you run a scan? Eg:
Code:
iwlist wlan0 scan
$ iwlist wlan0 scan
wlan0 Failed to read scan data : Network is down

# ifup wlan0
Ignoring unknown interface wlan0=wlan0.
 
Old 04-10-2013, 05:35 PM   #7
Phoenix_Swelter
LQ Newbie
 
Registered: Feb 2011
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by EDDY1 View Post
Have you tried
rmmod -f iwl3945
rfkill unblock all
modprobe iwl3945
# rmmod -f iwl3945
#

# rfkill unblock all
#

# modprobe iwl3945
#

# ifup wlan0
Ignoring unknown interface wlan0=wlan0.
 
Old 04-10-2013, 05:37 PM   #8
evo2
Senior Member
 
Registered: Jan 2009
Location: Japan
Distribution: Debian
Posts: 4,817

Rep: Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011
Hi,

"ifup wlan0" will only work if you have a wlan0 section in your /etc/network/interfaces. Try

Code:
ifconfig wlan0 up
iwlist wlan0 scan
Evo2.
 
Old 04-10-2013, 05:46 PM   #9
Phoenix_Swelter
LQ Newbie
 
Registered: Feb 2011
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by evo2 View Post
Hi,

"ifup wlan0" will only work if you have a wlan0 section in your /etc/network/interfaces. Try

Code:
ifconfig wlan0 up
iwlist wlan0 scan
# ifconfig wlan0 up
SIOCSIFFLAGS: No such device
 
Old 04-10-2013, 05:53 PM   #10
evo2
Senior Member
 
Registered: Jan 2009
Location: Japan
Distribution: Debian
Posts: 4,817

Rep: Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011
Hi,

ok... have to guess a bit here otherwise it will be a tedious one post per command

What about the following?
Code:
rfkill list all
ifconfig wlan0
iwconfig wlan0
ifconfig wlan0 0
iwconfig wlan0
iwlist wlan0 scan
Evo2.
 
Old 04-10-2013, 06:01 PM   #11
Phoenix_Swelter
LQ Newbie
 
Registered: Feb 2011
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by evo2 View Post
Hi,

ok... have to guess a bit here otherwise it will be a tedious one post per command

What about the following?
Code:
rfkill list all
ifconfig wlan0
iwconfig wlan0
ifconfig wlan0 0
iwconfig wlan0
iwlist wlan0 scan
No problem - I appreciate the effort.

$ rfkill list all
1: phy1: Wireless LAN
Soft blocked: no
Hard blocked: no

$ ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 00:18:de:4d:14:d3
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

$ iwconfig wlan0
wlan0 IEEE 802.11abg ESSIDff/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thrff Fragment thrff
Power Managementn

# ifconfig wlan0 0
SIOCSIFFLAGS: No such device

$ iwconfig wlan0
(same as above)

$ iwlist wlan0 scan
wlan0 Failed to read scan data : Network is down

# iwlist wlan0 scan
wlan0 Interface doesn't support scanning : Network is down
 
Old 04-11-2013, 04:02 AM   #12
EDDY1
Senior Member
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: DebianSqueeze, winsxp, wins7, Debian wheezy, LFS 7.2
Posts: 4,658

Rep: Reputation: 408Reputation: 408Reputation: 408Reputation: 408Reputation: 408
Have you tried right-clicking on network icon & enable wireless?
 
Old 05-17-2013, 07:45 AM   #13
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 3,975

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
Have you solved this? I am also struggling with an Acer Aspire. WiFi controller is different, but what is see is exactly the same. If you solved it, it might give me a pointer.

jlinkels
 
Old 05-17-2013, 10:14 AM   #14
EDDY1
Senior Member
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: DebianSqueeze, winsxp, wins7, Debian wheezy, LFS 7.2
Posts: 4,658

Rep: Reputation: 408Reputation: 408Reputation: 408Reputation: 408Reputation: 408
Quote:
Originally Posted by jlinkels View Post
Have you solved this? I am also struggling with an Acer Aspire. WiFi controller is different, but what is see is exactly the same. If you solved it, it might give me a pointer.

jlinkels
What's the model of your acer?
Aso post output of lspci
 
Old 05-18-2013, 07:29 AM   #15
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 3,975

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
Aspire 5040
Do you mind if I point you to my post in the Mint forums?
http://forums.linuxmint.com/viewtopic.php?f=53&t=134064

Furthermore, I discovered something else. On the front of the Aspire is a radio on/off button. Now when I press that button, I see this happening in the output of rfkill list all:

After booting:
Soft blocked: no
Hard blocked: no

press 1
Soft blocked: yes
Hard blocked: no

press 2
Soft blocked: no
Hard blocked: yes

press 3
Soft blocked: yes
Hard blocked: yes

press 4
Soft blocked: no
Hard blocked: yes

And pressing the radio switch keeps toggling the Soft blocked. While at the second press the Hard blocked became asserted, it never changed again.

Apparently it is possible to control Hard blocked from software. If I knew how to do it... Obviously I tried to write 0 or 1 to /sys/class/device/net/..../rfkill (I am not sure about the exact path, I am not behind that laptop now)

It was also remarkable to see that the value /sys/class/device/net/..../rfkill
after boot:
/sys/class/device/net/..../rfkill = 0

echo 1 > /sys/class/device/net/..../rfkill
/sys/class/device/net/..../rfkill = 1

echo 0 > /sys/class/device/net/..../rfkill
/sys/class/device/net/..../rfkill = 2

jlinkels
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Module question: how to know if device is supported by module mustafaupk Programming 3 04-02-2013 12:00 AM
A simple Linux Kernel Device Module jhwilliams Programming 1 08-07-2007 06:37 PM
Cant enable SCSI device support in kernel Oxagast Linux - Software 0 01-02-2006 02:24 PM
Character Device kernel(2.4.18) - module problem shibdas Programming 2 11-11-2004 03:52 AM
Where do I enable ide-scsi module in kernel config? TheOneAndOnlySM Slackware 3 12-12-2003 08:43 PM


All times are GMT -5. The time now is 12:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration