-   Linux - Hardware (
-   -   need Silan SC92031 PCI Fast Ethernet Adapter redhat rhel5 driver (2.6kernel) (

ferozaferoz 12-28-2008 03:09 PM

need Silan SC92031 PCI Fast Ethernet Adapter redhat rhel5 driver (2.6kernel)
Please help if you know on this ,

I need link for Silan SC92031 PCI Fast Ethernet Adapter for redhat rhel5.0 driver (2.6.x kernel). This nic works fine on win XP as REALTEK
8139D but on RHEL5 not working .

my lspci shows as follows,

01:02.0 Ethernet controller: Hangzhou Silan Microelectronics Co., Ltd. RTL8139D [Realtek] PCI 10/100BaseTX ethernet adaptor (rev 01)

camorri 12-29-2008 09:30 AM

That card should run with the 8139too driver. That is a common card.

Is there a diver loaded? To find out, open a konsole, and run the command '/sbin/lsmod |grep 8139too' and post the results.

If it is loaded, then run '/sbin/ifconfig' and post the results.

If it is not loaded, then try to load it. As root, try 'modprobe 8139too' and see what happens. No news is good news, so if you appear to get no response, that is good. If you get a message, post it.

What have yo done to configure the interface?

ferozaferoz 12-30-2008 01:08 PM

Thanks for your response.

My system has two cards one is working with 8139too driver in Redhat5, But the another that i recently bought not working with that tried all options but of no use . i have 8139cp module also in my linux that also didnt work for my new NIC card (Advik Lan card).This second new nic works fine with XP.I tried ndiswrapper also that i configured as wan0 interface ,intrestingly it works but if i remove the lan cable from working first nic, my wan0 (Nic2) not working seems nic2 not using nic cable . Whats the use of ndiswrapper driver ?.

camorri 12-30-2008 02:43 PM


Whats the use of ndiswrapper driver ?.
NdisWrapper is not a driver. It is a piece of code to interface between non-linux drivers ( windoze drivers ) and linux. Basically, you run the windoze driver, through Ndiswrapper, instead of a native linux driver. It was written to broaden the number of wireless cards that work with linux. A lot of card makers do not take the time to write linux drivers.

In some cases it is the only way to get some cards to work under linux.

parkarnoor 09-17-2010 11:07 PM

unable to ethernet card in ifconfig
Dear all,

i have Hangzhou silan micro. co. LTD.SC92031 pci fast ethernet card

as per instruction. i executed modprobe 8139too

and it loaded successfully. but next what to do.

i issued ifconfig but it is not listed there.

it is only lo

what to do for that


camorri 09-18-2010 06:32 AM


Try the command 'ifconfig eth0 up' This will try to activate the eth0 interface. Of course for it to work you have to have the correct driver loaded. The output will look something like this:


eth0 Link encap:Ethernet HWaddr 00:1D:7D:20:F4:67
inet addr: Bcast: Mask:
RX packets:829 errors:0 dropped:0 overruns:0 frame:0
TX packets:1035 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:619046 (604.5 KiB) TX bytes:191157 (186.6 KiB)
Interrupt:24 Base address:0xc000
Depending on your network configuration, it could just work, or you may have to do some more configuring. If you need more help, please post the OS you are running, and the output of the above command.

HasC 09-18-2010 09:59 AM

the module for silan SC92031 isn't "8139too" nor "8139cp", it's "sc92031". but AFAIK you need a kernel > 2.6.20 to get that module already included, or compile it yourself

parkarnoor 09-18-2010 11:06 AM

it is not working
Yes dear i tried ifconfig...

it is not eth0 interface...

once it is shown i can issue ifconfig eth0 up or ifup eth0

when i issued lspci -v it is showing Silan SC92031 PCI fast ethernet adapter

physically on the card it is written RTL 8139D..

so i dont know how it loades 8139d module

currently i am googling internet for the right drivers


HasC 09-18-2010 11:14 AM

there isn't "8139d" module. you need "sc92031" module.
but you won't get it include on 2.6.18 kernel, which is the one redhat/centos 5 uses. probably you should compile the module yourself

parkarnoor 09-19-2010 04:01 AM

my linux kernel is 2.6.18-194.el5xen
Dear as listed in title i am using redhat 5.5 kernel 2.6.18-194.el5xen.

i downloaded kernel source RPM. also i downloaded sc92031 tar.gz package but i suspect it is is for 2.4.x

then i tried rpm -ivh ...src.rpm

but is giving error .i.e unable to locate %sources ...

after that i created redhat directory manually...and then i executed rpm -ivh again..

this time error was mockbuilder unable to find user ...(didnot remember full path)

once i am able to install kernel source rpm, i will try to follow instruction written in readme.txt of sc92031

but if you can provide me link to right source rpm file and command to install this rpm package ..i can check wheter sc92031 can be installed or not.


All times are GMT -5. The time now is 06:59 AM.