LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 02-09-2006, 12:22 AM   #1
artofchobo
LQ Newbie
 
Registered: Feb 2006
Posts: 5

Rep: Reputation: 0
Ndiswrapper: Troubleshooting


Hi guys,
One whole day of trying to figure out on working with ndiswrapper. Bumped into lots of problem installing. Finally, I managed to install the ndiswrapper v1.9. Then, I linked it with the .inf files with all other files in place in a single folder. The driver is working in windows (confirmed). The installation msg of ndiswrapper was successful with 'driver and hardware present' (soemthing like that) but I further check the dmesg log created by ndiswrapper... finding the following messages as shown below:

[4294825.477000] ndiswrapper version 1.9 loaded (preempt=no,smp=no)
[4294825.542000] ndiswrapper (import:241): unknown symbol: ntoskrnl.exe:'ZwEnumerateKey'
[4294825.542000] ndiswrapper (import:241): unknown symbol: NDIS.SYS:'NdisCloseAdapter'
[4294825.542000] ndiswrapper (import:241): unknown symbol: NDIS.SYS:'NdisRequest'
[4294825.542000] ndiswrapper (import:241): unknown symbol: NDIS.SYS:'NdisOpenAdapter'
[4294825.542000] ndiswrapper (import:241): unknown symbol: NDIS.SYS:'NdisDeregisterProtocol'
[4294825.542000] ndiswrapper (import:241): unknown symbol: NDIS.SYS:'NdisRegisterProtocol'
[4294825.542000] ndiswrapper (load_sys_files:217): couldn't prepare driver 'net2pg54'
[4294825.543000] ndiswrapper (load_wrap_driver:111): loadndiswrapper failed (65280); check system log for messages from 'loadndisdriver'
[4294830.999000] acpi-cpufreq: Transition failed

I tried getting inf files from other sources but to my dismay, they also pose the same problem.
Any solutions?


Thanks

regards,
chobo
 
Old 02-09-2006, 12:32 PM   #2
spicyed
LQ Newbie
 
Registered: Jan 2006
Location: New Jersey
Distribution: Fedora Core 4, Slackware 10.2
Posts: 29

Rep: Reputation: 15
How are you installing ndiswrapper, and the drivers for your card? Also just so I can fully understand the problem, did you find your driver from the Ndiswrapper Wiki?

Similar problem solved by this.
 
Old 02-10-2006, 05:52 AM   #3
artofchobo
LQ Newbie
 
Registered: Feb 2006
Posts: 5

Original Poster
Rep: Reputation: 0
I have used the original windows xp from the manufacturer and it didnt worked out.
I have also tried broadcom's chip set since the manufacturer id and some stuff shows that its from broadcom.
I havent try out the Buffalo of the Ndiswrapper list yet....
Any other suggestions?

Regards,
chobo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
WUFTPD troubleshooting wendallsan Linux - Networking 0 06-05-2005 01:11 PM
troubleshooting how-to? chilehead Linux - Hardware 2 02-06-2005 05:58 PM
Apache 2.40 troubleshooting FlamingoJeff Linux - Newbie 4 08-13-2003 10:08 AM
Troubleshooting Question gauge73 Linux - Newbie 2 07-07-2003 02:27 PM
ipmasqadm troubleshooting sparkly Linux - Networking 5 10-17-2001 12:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration