-   Linux - Hardware (
-   -   my hard drive or my optical drive is failing (

fatblueduck 01-28-2006 05:59 PM

my hard drive or my optical drive is failing

I've built a new computer. The hard drive is an OEM seagate 250 Gb, with SATA connection and the optical drive is a Plextor PX-740 E-IDE (ATAPI) DVD+-R/RW.

Every linux livecd that I've tried cannot operate with the hardware, but for the purpose of specifics, I'll say Knoppix-v4.0.2 is what I'm using.

The cd is detected at boot. The cd begins to run along and detects some of the hardware, but then there is a problem. Sudennly five or six messages printed out to the screen thousands of times, looping very rapidly.

ide: failed opcode was: unknown
hda: drive not ready for command
hda: ATAPI reset complete
hda: status error: status=0x58 { DriveReady SeekComplete DataRequest }
end_request: I/O error, dev 03:00 (hda), sector 16080

I would like to know what I should do to fix my computer, so that I can run linux on it.

saikee 01-28-2006 06:21 PM

Check the jumper setting of the DVD drive.

If the jumper is set at "cable select" you should have it connected to the end plug so that it is a master, otherwise set it as the Master because Sata uses its own connection and will be called sda.

fatblueduck 01-28-2006 06:35 PM

The jumper is set to "master". That is the way it should be, isn't it?

Electro 01-28-2006 06:52 PM

Recompile the kernel to set multi-mode by default. It is in the ATA/IDE section if you use make menuconfig. In the kernel .config file it will be IDEDISK_MULTI_MODE=Y.

If a drive is set as cable select and it is the only one on the IDE channel, the BIOS will not show the drive. You need a special cable that has one wire going to the slave connector that is disconnected.

The disc could be a problem because you wrote at a very fast speed. I suggest setting the write speed near 1X to decrease pit distortion. Writting (burning) at a high speed creates a lot of pit distortion because the disc is warping while it is spinning. I write at 4X speed for OS and data discs because that is the lowest my drive go.

fatblueduck 01-28-2006 07:01 PM

Recompiling the kernel would require a working linux envioronment.
I don't have that. There is nothing on my hard drive.

I am using a LiveCD called knoppix

also, the BIOS menu shows the hard drive and the optical drive.

saikee 01-28-2006 07:42 PM

The master setting should be OK and I doubt if the DVD drive speed has an influence, not with a V4 Knoppix I would have thought. I have a LG (16xDVD+-R, 8xDVD+RW 48xCD-R) and used 52x CD drive before without meeting any speed problem myself.

I have also installed Knoppix 4.0.2 in the box plus many others.

If you said the problem has been consistent with a few other distros then it could be a hardware fault.

I would perhaps check again the connection, say if the wire No 1 (colored) is plugged to the designated position and not reversed.

ANother way of checking it is to down load a FreeDos or a Ultimate boot disk CDs which are Dos systems that supports CD drives. That way you can test the DVD drive if you do manage to burn the iso image somewhere. The DVD drive by default also doubles as a CD drive.

fatblueduck 01-28-2006 07:51 PM

I've plugged and unplugged the optical drive many times. I'm sure that things are plugged into their correct place.

Here's an interesting quote that I found from one of Ubuntu's forums concerning this optical drive...

Oh well. As many of you are well aware, this drive does NOT work with Breezy installs. hdparm -I (capital i) says that this drive does not have any DMA support. Trying to tweak this during install didn't help; telling the BIOS to not use DMA also didn't help. I also tried to install Solaris 10 on this new system; it failed miserably as well. ... So I'm sending the Plextor back to NewEgg... and trying to decide what DVD writer -- hopefully DL --to buy for the new system

fatblueduck 01-28-2006 08:30 PM

Ok, I've solved the problem -here's the solution.

Since there is no DMA support on the Plextor Drive (this is actually a good thing -google results surrounding 'exact audio copy' and 'cdparanoia stinks' will show you why), type knoppix dma and the command prompt.

knoppix will boot up all the way and work just fine. :)

Its always a bit embarassing to answer one's own questions. I hope this helps someone buying this drive.

All times are GMT -5. The time now is 01:52 PM.