LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 08-08-2011, 05:18 PM   #1
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 9, LineageOS 13
Posts: 1,415

Rep: Reputation: 169Reputation: 169
my dial-up modem not working


Hello. I have a Dell D600 Latitude. It has a dial-up modem:
Code:
root@debian:/home/mark# lspci | grep -i -e modem
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 01)
In searching for drivers for this modem, I discovered that I needed the package sl-modem-daemon from the non-free repositories of Debian (which I use). So, I obtained this package and installed it. After installing it, I used gnome-ppp, which set up the modem (at /dev/ttySL0). I then added myself to the groups dip and dial-out:
Code:
mark@debian:~$ groups
mark dialout cdrom floppy audio dip video plugdev netdev bluetooth scanner
I then checked to make sure that there were no voicemail messages affecting the dial-tone, and after verifying this, I connected the phone line to the modem. I tried gnome-ppp:
Code:
--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L3DT4164913537
--> Waiting for carrier.
ATM1L3DT4164913537
NO DIALTONE
--> No dial tone.  Trying again in 5 seconds.
--> Sending: ATM1L3DT4164913537
--> Waiting for carrier.
ATM1L3DT4164913537
NO DIALTONE
--> No dial tone.  Trying again in 5 seconds.
--> Maximum Attempts Exceeded..Aborting!!
--> Disconnecting at Mon Aug  8 16:36:28 2011
I had set it up to try twice, which it did, but it still reported that there was no dial tone. So I then set up kppp, including the creation of a kppp-options file that reads "noauth" in the /etc/ppp/peers directory. I then tried kppp:
Code:
ATZ
OK
ATM1L1
OK
ATDT4164913537
NO DIALTONE
Does anyone have any suggestions as to how I can fix this? Has anyone else gotten this or a similar modem to work? Has anyone else ever successfully set up a modem only to have it fail to detect the dial tone?
 
Old 08-08-2011, 07:41 PM   #2
qlue
Member
 
Registered: Aug 2009
Location: Umzinto, South Africa
Distribution: Crunchbangified Debian 8 (Jessie)
Posts: 747
Blog Entries: 1

Rep: Reputation: 172Reputation: 172
You can try un-checking the 'abort connection if no dial-tone' option. (setup>options)
If that doesn't help, try checking the 'ignore terminal strings' option.
 
Old 08-08-2011, 08:43 PM   #3
jefro
Moderator
 
Registered: Mar 2008
Posts: 18,617

Rep: Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785
Might put a pause in. atdt ,,,

Or just atd ,,
 
Old 08-09-2011, 01:17 AM   #4
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 9, LineageOS 13
Posts: 1,415

Original Poster
Rep: Reputation: 169Reputation: 169
Thanks for the answers. Within both gnome-ppp, and then WvDial (specifically wvdial.conf), I tried your suggestions, but it didn't work. I also tried some of the tips from this site here. Still no luck.

Even though WvDial, gnome-ppp, and kppp all indicate that they're dialing the number before reporting that there's no answer (due to it being set to ignore the no dial tone error -- otherwise it would report no dial tone), there's absolutely no sound coming from the modem to indicate that it's actually dialing (in spite of turning up the volume in kppp and gnome-ppp).

So, I've tried stupid mode, declining the option to abort if no dial-tone, adding "atdt ,,," (WvDial didn't understand this, admittedly -- should it be capitalized?), adding "Init3 = AT+MS=34" to wvdial.conf, and setting it for "Carrier Check = no". Nothing works. Just silence.

Anyway, all further ideas are appreciated.
 
Old 08-09-2011, 04:04 AM   #5
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 9,540

Rep: Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996
does /dev/ttySL0 exist? My memory of dialup modems was that they masqueraded as serial ports, or hung out of serial ports. So a modem card would take /dev/ttyS0 or ttyS1 - the next free number above your existing ports. I would grok the AT commands to see what you can do for yourself and send it some of those. There is a debug mode - forget how & where you set it.

The PPP-Howto up around section 14 or 15 ( he f_i_n_a_l_l_y gets to the subject of PPP around section 10) actually gives direct ppp invocations.
 
Old 08-09-2011, 05:26 AM   #6
michaelk
Moderator
 
Registered: Aug 2002
Posts: 17,825

Rep: Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401
Since this is a winmodem and not real hardware /dev/ttySL0 is the correct device. Have you tried using minicom to manually dial out?
 
Old 08-09-2011, 04:58 PM   #7
jefro
Moderator
 
Registered: Mar 2008
Posts: 18,617

Rep: Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785
The thing replies to an AT so in my mind it is good to go.

There was one time where a phone line was hooked up oddly. I needed a 4 wire rj-11 cable to get it to work right. Might look at your cable and if it only has two wires get one that has 4 in it.
 
Old 08-09-2011, 07:44 PM   #8
qlue
Member
 
Registered: Aug 2009
Location: Umzinto, South Africa
Distribution: Crunchbangified Debian 8 (Jessie)
Posts: 747
Blog Entries: 1

Rep: Reputation: 172Reputation: 172
Quote:
Originally Posted by mark_alfred View Post
Thanks for the answers. Within both gnome-ppp, and then WvDial (specifically wvdial.conf), I tried your suggestions, but it didn't work. I also tried some of the tips from this site here. Still no luck.

Even though WvDial, gnome-ppp, and kppp all indicate that they're dialing the number before reporting that there's no answer (due to it being set to ignore the no dial tone error -- otherwise it would report no dial tone), there's absolutely no sound coming from the modem to indicate that it's actually dialing (in spite of turning up the volume in kppp and gnome-ppp).

So, I've tried stupid mode, declining the option to abort if no dial-tone, adding "atdt ,,," (WvDial didn't understand this, admittedly -- should it be capitalized?), adding "Init3 = AT+MS=34" to wvdial.conf, and setting it for "Carrier Check = no". Nothing works. Just silence.

Anyway, all further ideas are appreciated.
I think we need to establish if the modem is, indeed, working! Can you use it with another system? It is possible that the modem has developed a hardware fault.
 
Old 08-10-2011, 03:57 AM   #9
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 9,540

Rep: Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996
In addition to all the correct advice here, take a lesson from my experience in this.

I had a tel/fax which would only work with one particular phone cable. I am a hardware guy, and put a meter on it. It needed a crossover in the cable; the inner pair in the phone socket were connected to the outer pair in the phone, and vice versa :-//.

Try some way of fiddling that together.
 
Old 08-10-2011, 08:43 PM   #10
jefro
Moderator
 
Registered: Mar 2008
Posts: 18,617

Rep: Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785
Actually if it replies to an AT it doesn't mean it can use an on or off hook. It just means that your system can talk to part of the modem to get a reply.
 
Old 08-10-2011, 11:05 PM   #11
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 9, LineageOS 13
Posts: 1,415

Original Poster
Rep: Reputation: 169Reputation: 169
Thanks for your responses. The phone jack does look as if the line is a four wire rather than a two wire. However, the modem slot/hole for plugging in the phone line just has two thingies* for wires, rather than four (*forgive my non-technical language -- I'm just not familiar with phone lines). So, I believe this may be the issue. Can I buy a 4 to 2 wire converter plug in thingy for the phone line, to then try with the modem?
 
Old 08-11-2011, 03:45 PM   #12
qlue
Member
 
Registered: Aug 2009
Location: Umzinto, South Africa
Distribution: Crunchbangified Debian 8 (Jessie)
Posts: 747
Blog Entries: 1

Rep: Reputation: 172Reputation: 172
Quote:
Originally Posted by mark_alfred View Post
Thanks for your responses. The phone jack does look as if the line is a four wire rather than a two wire. However, the modem slot/hole for plugging in the phone line just has two thingies* for wires, rather than four (*forgive my non-technical language -- I'm just not familiar with phone lines). So, I believe this may be the issue. Can I buy a 4 to 2 wire converter plug in thingy for the phone line, to then try with the modem?
There should be two wires per line. usually, the middle two wires are the primary line. The outer two lines are usually not connected. Have a look at the connector box that's mounted on the wall. If all four are connected, try swapping the inner two with the outer two. (but be aware that you may need to call a service technitian from your phone company to do this legally. Laws may be different in you area to here!)
 
Old 08-11-2011, 04:32 PM   #13
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 9, LineageOS 13
Posts: 1,415

Original Poster
Rep: Reputation: 169Reputation: 169
My phone line does work. It's the modem that is not working. I also have a desktop computer with dial-up access, and the modem in it works. It appears to accept the four lines of the phone line plug (IE, the desktop modem outlet has four little thingies to meet up with the four little thingies in the phone line plug), whereas the modem in the laptop I'm having problems with appears to just have two thingies within its modem outlet. If, as you say, that it's only the two middle lines that matter, then this isn't what's causing the issue with the modem.
 
Old 08-11-2011, 05:01 PM   #14
jefro
Moderator
 
Registered: Mar 2008
Posts: 18,617

Rep: Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785Reputation: 2785
In the good old days of POTS ATT or Bell did wire everything with a spare. Every jack was connected to two sets of wires. They would just go outside and switch to the spare set if a problem came up. After many years in the walls they might have had to switch to even an odd set to get the last two wires working.

The part I mean is the cable between the jack and your modem might need to have 4 wires. Not all do. Just because a phone you have works doesn't mean this modem will. Basically the phone working does not prove the jack or cable is good for the modem to work.

We are not even sure this modem works yet.
 
Old 08-12-2011, 03:54 AM   #15
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 9,540

Rep: Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996
Phone systems use 2 of the 4 wires, unless you're on a switchboard. In that case all bets are off.

If your modem returns a 'no dial tone' error, as is said below I would take it you have no dial tone, and that the wrong 2 wires are coming to the modem. There are some conventions, but I don't remember them. Here (Ireland) I think it that the call comes in on the inner pair and gets transferred to the outer pair. This was to allow fancy phone features, & isolation. Here, isdn lines could have one call on each pair independent of each other. If that's right, and you went to the phone socket where the line comes in, you would have the call on the inner pair; to be more precise, I would.

I would unset 'ignore no dial tone.' It's your error.
 
  


Reply

Tags
modemsetup, sl-modem


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why does my dial-up modem not have a dial tone on Mepis but does on Windows? (laptop) spirobulldog2004 MEPIS 10 10-28-2007 06:35 PM
I need to know how to get dial-up internet working in linux with and internal modem!! BrockW Linux - Networking 3 10-21-2007 02:54 AM
Dial-In PPP dial-in server/ Cable-modem & LAN / Setting up "dannyboyOnline" dannyboy259 Linux - Networking 2 01-12-2007 01:40 AM
D-Link Dial-up Modem:: No Dial Tone AJones Linux - Networking 1 01-01-2006 07:30 AM
SUSE 9.2 detect my [B]ADSL USB-Ethernet Modem-Router [/B] as a [B]Dial up modem[/B]. myprecius Linux - Hardware 0 06-27-2005 10:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 04:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration